Bricked TL-WA850RE v2

Hi, I had decided to install LEDE on my TP-LINK TL-850RE (v2) (I still have an old image from before they were taken down), and hardware-wise, it was functioning great on LEDE, however apparently, I have no idea how to set it up without a GUI (all my attempts ended up in me being unable to connect to the extender).
So I decided to reflash the stock firmware, however it would appear that, like the V1 model, I had to modify the firmware first, so all I have now is an extender which fails to initialize any network interface.

Can anyone help me unbrick my extender?

Try this tutorial, which works for several TP-Link routers -

Rename the stock firmware file to wa850V2_tp_recovery.bin

Thanks, however do you think that there is an equivalent for Linux?

And to be noted, I am returning to stock only temporarily, until I have another extender to replace this one, I intend to flash LEDE on this extender.

Well then, after being unable to connect to the extender from laptop due to the mask address not sticking, I had tried doing so according to the tutorial you had posted from my mother's laptop.

After a few tries, I had managed to "put" the file (the program did not do anything automatically), and waited for about 5 minutes, however nothing changed on the extender's side.

Any tftpd will do, I have very good experiences with tftp-hpa on Debian.

Thanks, although as I had already posted (without specifing my distro of choice), that I was unable to get the network mask address to stick on my laptop (it kept reverting to 24 upon save).

As to my current setup, I am using a Lenovo IdeaPad 300-15 (although I am planning on switching over to Dell once I find a buyer for my laptop and have enough money to buy a 3000-series Vostro, Lenovo's consumer products are subpar quality, especially considering their extravagant prices and unhealthy practices), running Solus.

I personally wanted to use the standard TFTP, which is preinstalled on Solus (and I am guessing also on many other distros).

10 Best Free TFTP Servers (Windows, Linux, Mac) -

1 Like

Common issues I see when it doesn't work...

  1. TFTP server running on the attached computer does not have permissions through the firewall.

  2. Router not powered off first.

  3. Reset button not held in for at least 10 seconds after the router is powered on.

Thanks, although:
1. I had both given firewall permissions and run Tftpd as an admin.
2. I had tried both plugging in the extender right after starting the app, as well as resetting it while Tftpd was running.
3. I had pressed the reset button for nearly 15 seconds.

Do you have any idea whether I had hardbricked the extender, or whether I am doing something wrong?

I have the same problem, is there no other solution?


Sorry for not being here for such a long time, I haven't had the time to tackle this issue.

However, now that I have flashed PandoraBox (basically OpenWRT, just with closed-source drivers) on my Xiaomi Mi 3G (I have no choice with the Mi3G if I want semi-decent reception to my extender (currently the TP-Link RE200, until I unbrick my WA-850RE, since the WA-850RE has better reception (due to having better hardware), but a completely unstable stock firmware) with this router), I can think about this again (and about my bricked Netgear DM200).

If we can't figure out how to do this via ethernet, then we will need to serial flash directly to the chip.


Any news on how to unbrick this piece of shit?
TFTP method doesn't seem to work here.

It's on a infinite LED loop

  • All leds ON (500 mS)
  • 1 LED On (1 s)

Sorry if I sound irritated (I'm not), but the TL-WA750RE v2 is actually a great (if old) piece of hardware (with an unstable stock firmware).

Qualcomm's Atheros products are amongst the best choices for OpenWrt due to how receptive Qualcomm is to open-source development (Intel/Lantiq are better though in that regard though).

Realtek's WiFi drivers are horrid, so if you wish for an an example of horrid networking, there's that.

As for the TFTP method, I'm still trying to figure that out, not being experienced enough as it is, and my Linux distribution (Solus), not yet having TFTP server software (I'm going to ask for one soon).

amigo estou com este mesmo problema. conseguiu solução.?

Hi all,

Just want to share that I was able to unbrick my WA850REv2 using serial flash method.

Basically I followed these tips extracted from these two links below:

  1. TP-Link WA850RE v2.0 Bricked


The USB to TTL Serial adapter I used: FTDI FT232RL (IMPORTANT: Set the jumper to 3.3V!!!)

Note: I confirm you must bridge two soldering points for TX and also two soldering points for RX to make things working.

Any specific doubts, just let me know. The process is straight forward for those with a low-level experience with serial firmware uploads.


Could you please share a pic or some instructions on "two soldering points for TX and also two soldering points for RX"?
I'm stuck at this point - and cannot find some clear instructions but some bad quality photos.
( Soldering the 3 wires are done, device linked on 3.3V level but no serial comms possible... )

Hi Janos,

Right, looks like you are missing this step only. Without it, no comms at all. I faced the same.

I'm uploading a new pic with the 2 pair of soldering points (yellow circle).

wa850reSerial (2)

You have to make sure you link the two points for TX and the two points for RX as indicated by the red arrows in the middle of the yellow circle.

Not easy task to accomplish. They are very small points, and you have to be very carreful to not short circuit any other points around the ones you are trying to joint.

A magnifying glass may help !

Good luck! Let me know the results.

After soldering the points com is ok. ( It was really not easy...)

Now I could flash - and my device is back & running! :slight_smile:

1 Like

It would be great if someone with the device at hand could take some better photos of the PCB, including the serial port area, including the soldering points to be closed.

The devicepage would then be the place to add this new and better photo. See how to upload photos to the wiki.

1 Like

Would be a pleasure to do it, however after making it alive again, I used a powerful glue to close the case.