Bricked Redmi Ax6000 Openwrt

Hi everyone,

I recently managed to brick my redmi ax6000 while upgrading from ImmortalWRT to Openwrt using sysupgrade (Openwrt Uboot Mod Layout, First used: Immortalwrt). When finished, after Rebooting no leds show up but my pc can detect ethernet connected. I tried to use tftp server and provided file in but it says no dhcpd detected. And since there are no leds working Its blind and I cant understand if its in recovery mode or not. Thanks.

screenshots attached:

Do I need to follow the UART method for this?


no dude, based on your other thread, that's not what happened...

1 Like

The given device link do you mean I need to use UART to fix this issue? Sorry I may not be able get your message properly. my English is bad forgive me.

Tried the suggestion in the other thread?

Or you could just keep reading ...


yes I did. Its blind and if reset did fix the issue the leds would light up its dark

Sorry, I still couldnt catch you. :frowning:

He suggests you correctly follow the instructions located on the Wiki URL above.

For example, you need to address your server and client according to the Wiki instructions. Your screenshot shows you did this incorrectly.


Thank you for responding @lleachii

this time I used tftpd application and it says that the file is transferred sucessfully


But still not working

i transferred this file:


Provide details.

1 Like

no it seems I was being stupid, the files was sent to the pc folder and telling it was transferred successfully. I still cant figure out what is wrong can you help?

this is what tinypxe shows:

Am I still missing something? Is the board fried by any short circuit or something?



Issuing a x.x.x.255 IP is invalid for a subnet. Configure "IP Pool start" to use valid IPs.

1 Like

It's quicker to try it, than post a question, and wait for a reply..

1 Like

As I am in bed now I gave up testing I will reply with results again after 8 hours or so Thanks

Its still the same no matter what I try.

But when I switch the ipv4 address manually to wireshark logs keep spamming with something relating to, I dont know what that means but I am attaching a screenshot

And by any chance is the board fried by any electric fault?


Should I go for the UART solution? how much helpful would that be? Since I am using openwrt uboot and not stock uboot. I think i expect to get some output from there?

probably a lot, unless you bricked your router.

do you have a firewall on your windows box, and have you disabled it ?

1 Like

yeah it asked for firewall access during the first phase. I allowed it but after that I disabled the firewall anyway. And I recovered my old Xiaomi R4A gigabit the same way. And few days back this AX6000 router was bricked from stock due to a wrong cmd input and I fixed it using TFTP. Now if it doesnt work it probably had hardbricked itself.

and So, if my router is bricked UART wont be able to fix it? I need to desolder NAND and reprogram it?