Bricked Netgear R6260

After installing openwrt on a Netgear R6260 and then attempting to revert back to the factory firmware, the router bricked and is unresponsive. Here are the details.

I loaded the factory to openwrt installer bin openwrt-21.02.0-ramips-mt7621-netgear_r6260-squashfs-factory.img

Then I installed the latest full openwrt bin openwrt-21.02.0-ramips-mt7621-netgear_r6260-squashfs-sysupgrade.bin successfully.

I installed DDNS from opkg and got Luci syntax errors when I tried to go to system->DDNS.

After several hours, I was unable to figure out how to enable Telnet so I decided to go back to the factory firmware. I uploaded the factory bin file from the Netgear website - R6260-V1.1.0.84_1.0.1.img . I got an error message saying it wasn't a openwrt bin, but that if it was a factory bin, then hit Force upload. I did and it bricked the router.

Router is totally bricked and will not respond to TFTP.. This is obviously a critical bug. If you have a Netgear router, this version will not let to revert without bricking.

Telnet haven't been shipping with openwrt for ages, it's ssh now.

  1. factory images are needed only for the very first install from the OEM GUI. there is no need to flash a sysupgrade.bin after. You only do this when a newer version comes out.
  2. you can't reverse to OEM firmware but flashing it from OpenWrt, but I guess you figured it out yourself.
  3. to unbrick or reverse to OEM firmware, use nmrpflash as @frollic suggested.

Thanks for the replies.
I downloaded the program and found that its not compatible with XP. Fortunately, I have a test laptop that runs win7. It put up a fight, but reloading npcap with older drivers got the program running.

Unfortunately, after all that, it still doesn't work. The router is in a constant reboot cycle. BTW, the wireless adapter was disabled during the run. Also, I manually set the laptop ip address to to match the router address, but there was no difference. Here is a copy of the run.

C:\Downloads\Routers\NetGearR6260>nmrpflash -L
net10    d9:ff:a5:5c:09:da  (Wireless Network Connection)
net12     f4:6d:ff:7d:47:97  (Local Area Connection)

C:\Downloads\Routers\NetGearR6260>nmrpflash -i net12 -f openwrt-21.02.0-ramip  { accidentally chopped off by editor }
Waiting for Ethernet connection.
Advertising NMRP server on net12 ... \
Received configuration request from 9c:c9:09:6d:2b:08.
Sending configuration:
Received upload request without filename.
Uploading openwrt-21.02.0-ramips-mt7621-netgear_r6260-squashfs-sysupgrade.bin
. OK (6257218 b)
Waiting for remote to respond.
Received configuration request from 9c:c9:09:6d:2b:08.
Sending configuration:
Received CONF_REQ while waiting for TFTP_UL_REQ!
Received configuration request from 9c:c9:09:6d:2b:08.
Sending configuration:
Received CONF_REQ while waiting for TFTP_UL_REQ!
Received configuration request from 9c:c9:09:6d:2b:08.
Sending configuration:
{repeat forever}

Apparently, the utility is not able to overcome the constant reboots. I believe that is the problem.

UPDATE: After I sent that last post I was greeted with a blue screen on the laptop. I tried system restore, but it hasn't worked yet. The laptop will only run in safe mode. Any other mode and it just reboots a few seconds after showing the blue screen.

So not only did my router get bricked, but there is a good chance it tried to do the same thing with my laptop.

Update2: Looks like a second run of System Restore may have worked. I suspect the standard install of NPCAP is what messed it up. it didn't work at all until I installed the earlier version of the driver by reinstalling with the checkbox. Anyhow, just uninstalling NPCAP didn't fix it.

Nope. Many errors.

  • When booting in TFTP mode, the custom IP of the router (10.10.10.x/24) doesn't apply, so forget for your laptop.
  • Disconnect from wifi, use only wired LAN. Set IP of wired LAN to
  • nmrpflash can't use sysypgrade.bin file. Use factory.img or Netgear firmware.
  • check your firewall to allow nmrpflash.
  • install the latest LAN driver
  1. I used several different addresses, and
    2.Wifi was always disconnected.
  2. The nmrpflash instructions say that it can handle img and bin. I tried both.
  3. Windows firewall popped up and asked me if I wanted to whitelist the app and I said yes.
  4. Already has the latest lan driver.

Something is causing it to reset every 20 seconds or so. I don't think the utility can work like that. Maybe if there was a small program that had just the loader. The 20 second reboot sounds like a watchdog timer was left on. A small app might be able to be uploaded before the timeout. The factory img is 25 MB. That's why I tried the openwrt bin because its only 6 MB.

Anyhow, it looks like the only solution is to take it back to the store and return it for one that works.

That's too short to allow you to do something.

By installing openWrt, you may have void the warranty. Read it to be sure.

With a new device, only install the factory.img from the OEM GUI.

I do believe that the program was able to get the router's attention, at least for a few seconds. If there was a transitional program to load that was very small, say less than 5K, the router would have time to start it so that the watchdog timer could be shut off. This would allow the next run of the flash utility to complete successfully with the real firmware.

I do think this whole thing was an intentional effort on the part of the openwrt developers. So instead of just saying "img files are not supported" they said to click "force" to upload factory firmware - knowing that it would brick the router. Kind of like we got you and you're not going back. The fact that they are going out of their way to block Telnet says they have an orwellian Big Brother "we know what's best for you" attitude. Telnet has been a standard native app in Windows since Win 3.1. In private networks, there is zero security risk with Telnet. When I get the new router, I'm going to stick with the stock firmware.

Sorry to say that, but telnet client isn't installed ootb in windows for a long time (i think since Windows 7). You have to install it by yourself. For security reasons.

I'm also using a R6260 and had no problem to do a factory install with nmrpflash.
But i am using OpenWrt as it is the superior solution for home-network equipment.

I remember trying several times before nmrpflash could link to the router. So keep trying.

Despite best efforts, openWrt is given without warranty. It's up to the user to face the consequence of installing. But I highly doubt that a release is done knowing willingly that it would brick a router. That is not the open source communauty spirit. That being said, this device is new, and so the support is: you may have encountered a legit bugging circumstance. You may have entered into a bootloop or any other issue. It happened me several times on various devices, and I have always blamed myself for improper use. Each time I was able to use nmrpflash to recover the situation, and sometimes situation seemed really desperate.

About telnet, it is not blocked, it's just not implemented. SSH is.

Win 10 includes telnet with the distro. You only need to enable it. I just did it. There is no need to install anything. I like OpenWrt, but I need telnet. I found the telnet source and its crazy simple. Should be no problem compiling and installing it. The point being that I shouldn't have to.

I think the nmrpflash utility made a valiant attempt to get it working, but for some reason, the constant resetting is likely what caused it to fail. Boot loops seem to be a common occurrence with netgear routers.

I noticed before the failure that the DDNS system wasn't working either. When I get the new one, I'm going to keep it factory and then disable automatic updates.

The telnet server is literally less than 1K in size. There is no reason to go out of the way to prevent it from being installed. Not only is it not in the distro, but its blocked in the package manager as well.

I made this account just to ask how is the range/performance/stability on openwrt compared to the latest stock firmware. :slight_smile:

Stability/Range etc. is good for me. Use it as main router with more or less latest openwrt.
Can‘t say anything about stock firmware as i never used it.

Thanks for the help.

Some of you guys are going to say "I told you so" and I won't blame you. Today I exchanged the bad router for a new one and attempted to proceed with the factory firmware. The factory firmware was so atrocious and reprehensible that I had no choice but to load OpenWRT back on it. I will leave OpenWRT on there for good this time as we all know what happens when you try to load the factory junk back on there. OpenWRT has its faults, but nothing compared to the contemptible firmware that the factory had on there.

As for stability and range, its only been up a few hours, but its stable so far. The range on maximum is better than the old router it replaced. It has a wifi spectrum analyzer that tells you the best (least congested) channel to be on. So that helps.

What it doesn't have is parental controls or any way to easily block websites by name. So until I figure it out, I guess the kids will be able to get to all the porn sites.

One very odd thing with the new openwrt install is that one of my cameras would not let me log in to it with its local IP or local lan name. I worked for about 2 hours and finally gave up. Yet, I could ping it just fine. Then, for whatever reason, it had no problem letting me log in using the port forwarded external address. Using the local IP address still doesn't work with openwrt, but worked fine with the $30 linksys router that it replaced. I have several cameras, and only one is acting up like that.

Any ideas on how to implement parental control section to block outbound traffic based on name, not IP?