Bricked my ASUS AC58U?

I just tried to upgrade my ASUS AC58U router using the firmware openwrt-19.07.0-ipq40xx-generic-asus_rt-ac58u-squashfs-sysupgrade.bin through the luci-web interface ticking (as asked for major upgrade) no save settings.

When it rebooted unfortunately DHCP didn't seem to work and no IP4 was assigned to my computer so I couldn't access router via

I could do a Failsafe Mode via pressing the WPS button when LED blinking and access the router through SSH through manual assignment of my Windows 10 machine. Unfortunately following the commands for soft reset and hard reset doesn't work. It says writing /dev/ubi0_6 failed: Bad file descriptor.

I also tried resetting by holding the reset button for 10 seconds. This also doesn't work.

When both methods above come back up I still can't access Luci-web software.

Help? Do I have to do full recovery to stock firmware and try again to install openwrt? Last time I had to install some custom less vetted firmware from the forums. I'm not sure if I'm still comfortable doing that?

Unfortunately I'm running out of time this weekend so I'll restore stock firmware and maybe try again next weekend when I have more time. Thank you in advance for any help offered.