Bricked Archer C7 V2?

Hello folks.

Today I once again did something stupid.
I wanted to flash dd wrt coming from locked eu build 160616 (First mistake). So I came up with a guide to flash Lede and from there on I could flash the firmware I wanted. Everything went fine. Using Putty I flashed lede-ar71xx-generic-archer-c7-v2-squashfs-factory-eu. Then the Web UI. Then I tried to flash ArcherC7v2_tp_recovery.bin. That was the last time I could connect with my router. Now when it powers up all lights blink but after a few seconds only the lan and internet lights are on. I tried the recovery method using Tftpd32 setting fixed ip but I can't connect to the router. Using the WPS button to get into recovery mode doesn't seem to work or I am doing something wrong. Is there any solution for this or do I have to spend some money again for the second time in two weeks? any help would be very much appreciated. Thanks in advance. gr Nick

Hello @StupidMe,
Despite your chosen name, you're not that stupid in fact. The situation you are into is the one that I feared for myself one day, if I wanted to reinstall the original TP-Link. That's why I ordered a serial cable for recovery just in case...

First thing first: Have you seen this video on Youtube: ? This is a step-by-step to recover your Archer. For the firmware, try the one from FriedZombie, because apparently you must use a stripped firmware when going back to stock TP-Link, unlike the one used in the video which is an unstripped one. The rest of the procedure in the video is fine.

So setup your TFtpd, use FriedZombie's firmware, and please report back so we know that your problem is fixed. Be sure to view the video completely to understand what you have to do. Your report will be important because you'll be another documented proof that we need to use a stripped firmware.

EDIT: @Hophead confirmed that using stripped firmware worked for him - See further in this thread.


1 Like

Hi. Thanks for your reply. Yes I watched that vid to. Gonna try the firmware to but I'm not getting any response from Tftpd32 when trying to use recovery mode. I hold the wps button, power on but no connection. The blinking of the lights doesn't change nothing. Also nothing to find in the log.
I'm getting the idea i'm sol.

I don't remember which model was it that holding the wps button didn't help, but rapidly pressing it did -- quite possibly it was Archer. So, instead of just pressing the wps button and keeping it pressed, try rapidly pressing and releasing the button during the boot up process until you see the fast blinking of the status LED.

Good Point I remember reading about that trick too. Also try, if not already done, to plug your ethernet cable into LAN1.

You might have to recover using serial if you cannot get it into recovery mode.

Also tried the rapid clicking. I thought that it works on a Archer C5. No succes. I think the bootloader is screwed. Only reason i can think of why it isn't connecting. Gonna try the rom posted above. If that don't work i'm gonna get a Netgear Nighthawk for replacement. I only payed €40 for the router because it was sold as accespoint by my isp. Don't feel like spending to much time on it because it drives me crazy. Maybe in the future i will get a serial so i can fix it. Btw. I don't have to use the internet connection do i? Only a cat5 cable to port 1 should be enough to connect with it right?

When performing the recovery, there should only be power connected to the router and lan port 1 to your computer directly. No switch between the two. So yes, only cat5e cable to lan 1.

Yes that's what i figured. I tried and tried and then some more but whatever i do there is no connection. When i power on the router i can see my network adapter searching for a network then Tftpd32 sets the ip back to software loop. When it starts up al lights go on but after 10 seconds only the powerled and lan connection light stays on. No difference in blinking. :frowning:

I bought a Netgear Nighthawk for replacement. Since this was cheap thing i'm not gonna try anymore.

Just one last shot: you did fix your computer IP to, not DHCP? If you stopped the boot loop that means you were in tftp recovery.

It should require but is also possible on older firmwares released by Tp-Link.

Also disable your firewall temporarily to make sure tftp is allowed to listen.

Yes i tried both. Also no dns setting. Turned off the firewal. The thing is there is no bootloop. It boots up and stays the same untill i reboot. I registered at dd-wrt forum and the guy there thought i have a messy boot or nvram is full. Which requires serial connection to fix. Also said that since i used Lede i should go over here and ask for help. I read almost every guide for restoring but if the router won't react then i have no clue.

I downloaded wireshark. If i set my ip to i can see a line in the activity with a different ip. ARC
This isn't there when i set it to Then i can see something that says who is 192.168.1. From what i understand is that you should be able to see in Tftpd32 if the router fetches the bin file. But nothing happens.

There is something missing here. It should be something like

ARP Who has 192.168.x.x? Tell 192.168.y.y

y.y is the router address, and x.x is your expected computer address.

Yeah correct. That's it.

I bought a bricked Archer c7 once. Had to use serial to recover.

Serial adapters are pretty useful when working with multiple routers :stuck_out_tongue:

Yeah i'm gonna buy one. I wanna fix it. :slight_smile:
Any advise which one to buy?

1 Like

Wiki says PL2303 adapter; I'm still waiting for my order of PL2303TA to arrive.

PLX chips have been garbage for me. Too many bad clones. I currently use a CP2102 one. Works pretty well. Mine's a cheap clone but still works well.

I tried to ping the router. On it says connection timed out. If i try to ping it says ping destination unreachable followed by timed out. If i type arp -a i can see a ip with Don't know what this means but at this moment i think i tried everything without serial connection. My Nighthawk arrives today so i will order a cable and see what i can do with the Archer.

Ordered this one.

I just wanted to add that I came across this post after i did a very similar thing to my AC1750, had LEDE reboot and wanted to go back to factory. I followed a guide and the bin file seemed to flash but all the lights just started to flash, After a few searches I came across this post and I followed the video and the stripped firmware and I am up and running again. thanks for posting and hope you get your router sorted out too.