Breed cannot recognise the self-complied squashfs bin file, Breed latest version for R3G

For the current stage, I've build an env with python and gcc which I'm working around.
Then I build from the official OpenWRT Repo with branch 21.02,
<Can't upload image>

The basic build config are as follows:

  1. The overall menuconfig
    <Can't upload image>

  2. The target image section:
    <Can't upload image>

  3. The output packages:
    <Can't upload image>

What I have done is using the "squashes-sysupgrade.bin" for either Redmi or Mi(The latest breed for r3g on my redmi device told me that the chip is MTK7621A, which belongs to Mi and not Redmi) to refresh ROM of my device, but the breed told me that "It cannot recognise the upgrade file.".

What's wrong with that, I can't find anything (breed log included, for absence of COM device) explaining how did this problem arise.
By the way, I've tried using just the official builds from, and tried for Mi and RedMi, which both failed for the same reason.

If anyone cloud help me out, I would be more than appreciate.