Br-lan: received packet on wlan0 with own address as source address

Suspect this is a bug. Has existed on every kernel-5.10.X version tried.

Goal: Use inexpensive Amlogic TV boxes to replace RPI's for services infrastructure
Hardware: Tanix TX9 Pro (TV box)
uname -a: Linux SecureOffice 5.10.80 #0 SMP PREEMPT Tue Nov 23 11:58:23 2021 aarch64 GNU/Linux
Using a recent trunk: version r18171-cee0a95
wifi: Ampak AP6330 (brcmfmac4330-sdio.bin)
eth1: usb/eth adapter bridged to lan

First, to get WiFi working at all (thanks Hauke, using same OpenWrt version)
https://www.mail-archive.com/openwrt-devel@lists.openwrt.org/msg60620.html

Every time I attempt to connect a WiFi client, I get (multiple) this and connection fails:

br-lan: received packet on wlan0 with own address as source address (addr:wlan0 MAC, vlan:0)

I have heavily researched this and eliminated network loops as a possibility.

what tried:

  • unique MAC addresses for WiFi and lan - issue persists
  • enable stp on lan - issue persists
  • disconnected wan, no devices on br-lan except bridged wlan0 - issue persists

This looks promising (disable_eap_hack), patch applied, but makes no difference, not sure how to activate:
https://git.openwrt.org/?p=openwrt/openwrt.git;a=commitdiff;h=7d542dc8047d276517b296132926e722004065e0

my /etc/rc.local contains:
echo 1 > /sys/class/net/br-lan/bridge/disable_eap_hack

post-boot /sys/class/net/br-lan/bridge/disable_eap_hack is still 1, not sure if used by N/W stack or, how to set so it is.

Q - What is proper way / place to set "disable_eap_hack=1"

In researching this issue, saw suggestions to place wlan0 on a vlan.
Q1 - Not sure how to place wlan0 on vlan and still bridge to lan or if it will decrease performance. Config example?

/etc/config/wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/d0000000.apb/d0070000.mmc/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
        option htmode 'HT20'
        option hwmode '11g'
        option channel 'auto'
        option band '2g'
        option country 'US'
        option disabled '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'SecureOffice'
        option encryption 'psk2'
        option key 'take a guess'
        option iw_qos_map_set 'none'
        option macaddr 'redacted - different than br-lan MAC'

/etc/config/network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdf0:2095:9059::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'static'
        option ipaddr '192.168.10.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option macaddr 'redacted - different than WiFi MAC'
        option stp '1'
        #option bridge_empty '1'

config interface 'wan'
        option proto 'dhcp'
        option ifname 'eth0'

Any ideas what to try next? Will be happy to provide further info.

Thanks;
Bill

also:

tcpdump -i wlan0 ether host e0:76:d0:69:35:2e:

13:48:33.642683 e0:76:d0:69:35:2e (oui Unknown) > 01:40:96:ff:ff:00 (oui Unknown) SNAP, oui Unknown (0x004096), pid Unknown (0x0000), length 52:
        0x0000:  aaaa 0300 4096 0000 0022 0202 0140 96ff  ....@...."...@..
        0x0010:  ff00 e076 d069 352e b0fc 36fa 2273 e076  ...v.i5...6."s.v
        0x0020:  d069 352e e076 d069 352e 0000 0000 0000  .i5..v.i5.......
        0x0030:  0000 0000 0000 0000 0000 0000            ............

br-lan: received packet on wlan0 with own address as source address (addr:e0:76:d0:69:35:2e, vlan:0)