BR-LAN does not establish connection to the internet. (22.03.0-rc1)


TESTED ON.

Target Platform
x86/64

Firmware Version
OpenWrt 22.03.0-rc1 r19302-df622768da / LuCI openwrt-22.03 branch git-22.119.37115-66994a5

Kernel Version
5.10.111


BR-LAN does not establish connection to the internet. (22.03.0-rc1)

x86 box has internet verifyed with ping and updated all packages. etc.

LAN PCs connects but it does not have internet connection
collectd-luci-stats showing a stable connection (router is online)

OpenWrt 22.03.0-rc1 will not send internet from WAN to LAN had to revert to openwrt-21.02.3-x86-64-generic-ext4-combined-efi.img


Everything is working on 21.02.3 but when I flash over to 22.03.0-rc1 my computers has no internet.

I checked DNS DHCP FIREWALLS all the settings are the same (ext FW4/NFT) I flashed back 3 times now in the past 2 hours.

Any ideas ?

post your /etc/config files

Did you upgrade from 21.02.3 to 22.03.0-rc1 and kept the configuration, or did you configure everything from scratch? The unstable snapshot is, you know, an unstable snapshot and there could be issues with converting settings.

I did a sysupgrade. I can try from scratch and flash the img threw dd and report back.

You could run firstboot and try to configure from scratch as first test (make a backup of /etc first*)

*) On squashfs based routers I routinely save all of /overlay before making an update, which nicely gives me all modified/post installed packets, allowing to recreate the pre-update situation by installing the old sysupgrade image and copying in the contents of the saved /overlay back onto the router, but on x86 I assume you use a "real" filesystem and hence this will not work ;(

1 Like

well haha ok yeah I tried but for some reason on x86 "firstboot" does not work for me.
when using x86-64-generic-ext4-combined-efi.img I think I need to use squashfs ? or root idk.
I get error MTD partition 'rootfs_data' not found when I say yes and it does nothing after that.

Anyways I finally figured it out after a few hours. was my firewall.conf

when I go under the Firewall option from luci.
/luci/admin/network/firewall then Zones
Zone ⇒ Forwardings (click on edit zones)
IPv4 + IPv6 for both under "Adv settings" for Restrict to address family

I personally don't use IPv6 and always both those options set to "IPv4 Only"
I'm not even running IPv6 on this router I have everything IPv6 related disabled.

I should just compile my own wrt iso via sdk and untick ipv6 for when I do fw upgrades.

edit: sorry it's late had to fix some words here.

Sorry my error, fastboot/firstboot also only works with a read-only primary partition, not sure what I was thinking....

This is going to get more and more problematic in the future, for a) IPv6 is becoming more prominent in the wild, and b) more importantly some OpenWrt core developers voiced their goal to stop special casing IPv6 and simply assume IPv6 to be there (mind you on the LAN, OpenWrt still intends to work just fine with IPv4 internet access). But that does not mean IPv4 only is going to be impossible, just that it is not going to get easier...

1 Like

no no sorry again I had edited my post I meant to say firstboot not fastboot haha :slight_smile:

funny tho removing the 2 strings by adding a # to cancel it out.

option family 'ipv4'

from under config zone
both entrys in my firewall.conf

config zone
	option name 'lan'
   #option family 'ipv4'
config zone
	option name 'wan'
   #option family 'ipv4'

set it from how I described from "IPv4 only" -> "IPv4 and IPv6" under /luci/admin/network/firewall
Then oddly enough I have internet on LAN side. :slight_smile:

I have most all IPv6 settings disabled in openwrt and even on client PCs
Not sure how important IPv6 core is but that little string seemed to break the net on lan side with rc1

1 Like

Things are working great now again with that edit

Firewall - Zone Settings -> Advance settings -> Restrict to address family " IPv4 and IPv6 "

Idk why it will not allow me to set it to "IPv4 only" as before in rc-1 but hey needle in a hay stack.

If I had to guess it would something to do with the new firewall4 implementation. ( food for thought )

1 Like

It is a known issue. Bugfix pending for rc2.

1 Like

Another thing I've noticed bugged on rc1 my IP is not changing.

usually when I reboot or restart my WAN interface I pull a new ip.

I've rebooted restarted reset and even turned my router off for 30 minutes yet still same IP every time.