Bluetooth not working on Raspberry Pi 3

I have tried LEDE 17.01.1 and 17.01.2 and i can't get bluetooth running on raspberry pi 3.

It will not flash the firmware for the bluetooth controller on rpi3:

root@LEDE:~# /usr/bin/hciattach /dev/ttyAMA0 bcm43xx 921600 noflow -
Patch not found for BCM43430A1, continue anyway
Set Controller UART speed to 921600 bit/s
Device setup complete

Instead of patch not found it should produce:
Flash firmware /lib/firmware/brcm/BCM43430A1.hcd

I could not find this firmware via opkg, so i used a file from OpenELEC at

This however won't load and my bluetooth is not initialized correctly and unusable:

root@LEDE:~# /usr/bin/hciattach /dev/ttyAMA0 bcm43xx 921600 noflow -
Flash firmware /lib/firmware/brcm/BCM43430A1.hcd
Initialization timed out

So what is needed to get rpi3 bluetooth working on LEDE?

Solved it for now by using an USB bluetooth dongle which works with LEDE.

Don't get me wrong, i am very grateful that LEDE runs on the Raspberry Pi 3 B and how it performs.

But it is frustrating that core hardware components such as WIFI AP-mode and Bluetooth are not working or not working reliably and you only find out if and when you start using them.
You do not read about those problems anywhere beforehand and nobody will answer on the forums when you ask. So all i can do is buying my way through components unless i find ones that work reliably.

Just run :

/usr/bin/hciattach /dev/ttyAMA0 bcm43xx 115200 noflow -

and then :

hciconfig hci0 up

and you're all set ;). Then start using the bluetooth console as usual. My version of the stack is the latest (v5.47) which has already included the UART high speed patch :


I'll test it tomorrow and get back to you. My intention also is to write a simple script to have the interface ready and activated at boot time.

Best, Arturo

thanks...will try it


The only issue you have is the baud rate for the UART connection, if you place the firmware you have in the /lib/firmware/brcm folder and then run the attach command as follows you will get a connection to the bluetooth device

hciattach /dev/ttyAMA0 bcm43xx 115200 noflow -bcm43xx_init