Bittorrent client help

Hi and thanks for trying to help me:

@ulmwind: nothing changed
@frollic when I run it on foreground, it seems to be starting as I get a message on the browser:

403: Forbidden

Unauthorized IP Address.
Either disable the IP address whitelist or add your address to it.
If you're editing settings.json, see the 'rpc-whitelist' and 'rpc-whitelist-enabled' entries.
If you're still using ACLs, use a whitelist instead. See the transmission-daemon manpage for details.
when I enter the webaddres.
Output of the transmission-daemon -f:

root@OpenWrt:~# transmission-daemon -f
[2021-11-20 18:21:33.684] Transmission 3.00 (bb6b5a062e) started (session.c:769)
[2021-11-20 18:21:33.685] RPC Server Adding address to whitelist: (rpc-server.c:956)
[2021-11-20 18:21:33.685] RPC Server Adding address to whitelist: ::1 (rpc-server.c:956)
[2021-11-20 18:21:33.686] RPC Server Serving RPC and Web requests on (rpc-server.c:1244)
[2021-11-20 18:21:33.686] RPC Server Whitelist enabled (rpc-server.c:1249)
[2021-11-20 18:21:33.687] DHT Generating new id (tr-dht.c:389)
[2021-11-20 18:21:33.687] Using settings from "/root/.config/transmission-daemon" (daemon.c:646)
[2021-11-20 18:21:33.688] Saved "/root/.config/transmission-daemon/settings.json" (variant.c:1221)
[2021-11-20 18:21:33.689] Port Forwarding (NAT-PMP) initnatpmp succeeded (0) (natpmp.c:73)
[2021-11-20 18:21:33.689] Port Forwarding (NAT-PMP) sendpublicaddressrequest succeeded (2) (natpmp.c:73)
[2021-11-20 18:21:35.684] Port Forwarding (UPnP) Found Internet Gateway Device "" (upnp.c:200)
[2021-11-20 18:21:35.685] Port Forwarding (UPnP) Local Address is "" (upnp.c:201)
[2021-11-20 18:21:35.685] Port Forwarding (UPnP) Port forwarding through "", service "urn:schemas-upnp-org:service:WANIPConnection:1". (local address: (upnp.c:276)
[2021-11-20 18:21:35.686] Port Forwarding (UPnP) Port forwarding successful! (upnp.c:280)
[2021-11-20 18:21:35.686] Port Forwarding Forwarded (port-forwarding.c:107)
[2021-11-20 18:22:14.684] DHT Attempting bootstrap from (tr-dht.c:299)

BTW: Here is the config file:

config transmission
	option config_dir '/tmp/transmission'
	option config_overwrite '1'
	option user 'transmission'
	option group 'transmission'
	option mem_percentage '0'
	option nice '10'
	option alt_speed_enabled 'false'
	option alt_speed_time_enabled 'false'
	option bind_address_ipv4 ''
	option bind_address_ipv6 '::'
	option blocklist_enabled 'false'
	option cache_size_mb '2'
	option dht_enabled 'true'
	option download_queue_enabled 'true'
	option download_queue_size '4'
	option encryption '1'
	option idle_seeding_limit_enabled 'false'
	option incomplete_dir_enabled 'false'
	option lazy_bitfield_enabled 'true'
	option lpd_enabled 'false'
	option message_level '1'
	option peer_limit_global '240'
	option peer_limit_per_torrent '60'
	option peer_port '51413'
	option peer_port_random_on_start 'false'
	option peer_socket_tos 'default'
	option pex_enabled 'true'
	option port_forwarding_enabled 'true'
	option preallocation '1'
	option queue_stalled_enabled 'true'
	option queue_stalled_minutes '30'
	option ratio_limit_enabled 'false'
	option rename_partial_files 'true'
	option rpc_authentication_required 'false'
	option rpc_bind_address ''
	option rpc_enabled 'true'
	option rpc_host_whitelist_enabled 'false'
	option rpc_port '9091'
	option rpc_url '/transmission/'
	option scrape_paused_torrents_enabled 'true'
	option script_torrent_done_enabled 'false'
	option seed_queue_enabled 'false'
	option speed_limit_down_enabled 'false'
	option speed_limit_up_enabled 'false'
	option start_added_torrents 'true'
	option trash_original_torrent_files 'false'
	option umask '18'
	option upload_slots_per_torrent '14'
	option utp_enabled 'true'
	option scrape_paused_torrents 'true'
	option watch_dir_enabled 'false'
	option download_dir '/mnt/sda1/transmission/done'
	option enabled '1'
	option rpc_whitelist_enabled 'false'

What does it mean?

Make option message_level '7', and see more messages in the log.

Remove also these options.

Well @ulmwind I left the default option '/tmp/transmission'. What it should be?
With message option 7:
I get the following log:

Sat Nov 20 18:45:43 2021 user.notice transmission: Starting with 0 virt mem
Sat Nov 20 18:45:43 2021 procd: - init complete -
Sat Nov 20 18:47:40 2021 daemon.err nmbd[3614]: [2021/11/20 18:47:40.096343,  0] ../../lib/util/become_daemon.c:136(daemon_ready)
Sat Nov 20 18:47:40 2021 daemon.err nmbd[3614]:   daemon_ready: daemon 'nmbd' finished starting up and ready to serve connections
Sat Nov 20 18:47:40 2021 daemon.err smbd[3613]: [2021/11/20 18:47:40.609200,  0] ../../lib/util/become_daemon.c:136(daemon_ready)
Sat Nov 20 18:47:40 2021 daemon.err smbd[3613]:   daemon_ready: daemon 'smbd' finished starting up and ready to serve connections
Sat Nov 20 18:47:42 2021 daemon.err uhttpd[2406]: luci: accepted login on / for root from
Sat Nov 20 18:48:01 2021 procd: Instance transmission::instance1 s in a crash loop 6 crashes, 0 seconds since last crash

option user 'transmission'
option group 'transmission'
However nothing changes.


OK, sorry, I have no idea: Transmission no longer working

1 Like

Thanks anyway @ulmwind .

Don't have access to my transmission atm, but I think you have to change your whitelist params.

I have tried it @frollic, but didn't work. Will play around again later. The same error message " forbidden" appered on transmission remote. It is a good sign, however I am not sure why it doesn't work with default settings. On my previouse Tp-Link wdr 3600 it worked with the default settings.
I will report later. Thanks
PS: it may be related with the fact that I have another Dump ap with padavan xiaomi mir3 running transmission.Highly unlikely, but I will switch it off when changing settings.

Again no luck. After I started it on foreground, I tried all possible whitelist combinations which I can think of, and again I am receiving the forbidden message.
Whenever you have a chance please check your settings @frollic
I wonder if my problem (if we disregard that I need to start transmission manually) is not similar to the following:
However I am not sure how can I execute the solution in my case.

i think the parameter I was thinking about was bind-address-ipv4, and yours already

what URL are you attempting to use when you access transmission, anyway ?
and did you install transmission-web and/or transmission-web-control ?

this is my config, as config.json,

    "alt-speed-down": 50,
    "alt-speed-enabled": false,
    "alt-speed-time-begin": 540,
    "alt-speed-time-day": 127,
    "alt-speed-time-enabled": false,
    "alt-speed-time-end": 1020,
    "alt-speed-up": 50,
    "bind-address-ipv4": "",
    "bind-address-ipv6": "::",
    "blocklist-enabled": false,
    "blocklist-url": "",
    "cache-size-mb": 4,
    "dht-enabled": true,
    "download-dir": "/bleh/",
    "download-queue-enabled": true,
    "download-queue-size": 5,
    "encryption": 1,
    "idle-seeding-limit": 30,
    "idle-seeding-limit-enabled": false,
    "incomplete-dir": "/blah/",
    "incomplete-dir-enabled": false,
    "lpd-enabled": false,
    "message-level": 2,
    "peer-congestion-algorithm": "",
    "peer-id-ttl-hours": 6,
    "peer-limit-global": 200,
    "peer-limit-per-torrent": 50,
    "peer-port": 8895,
    "peer-port-random-high": 8895,
    "peer-port-random-low": 8890,
    "peer-port-random-on-start": false,
    "peer-socket-tos": "default",
    "pex-enabled": true,
    "port-forwarding-enabled": false,
    "preallocation": 1,
    "prefetch-enabled": true,
    "queue-stalled-enabled": true,
    "queue-stalled-minutes": 30,
    "ratio-limit": 0,
    "ratio-limit-enabled": true,
    "rename-partial-files": true,
    "rpc-authentication-required": true,
    "rpc-bind-address": "",
    "rpc-enabled": true,
    "rpc-host-whitelist": "",
    "rpc-host-whitelist-enabled": false,
    "rpc-password": "{25asasdasdasdasdasdd4Fqybk",
    "rpc-port": 9091,
    "rpc-url": "/transmission/",
    "rpc-username": "ben.dover",
    "rpc-whitelist": "",
    "rpc-whitelist-enabled": false,
    "scrape-paused-torrents-enabled": true,
    "script-torrent-done-enabled": false,
    "script-torrent-done-filename": "",
    "seed-queue-enabled": false,
    "seed-queue-size": 10,
    "speed-limit-down": 100,
    "speed-limit-down-enabled": false,
    "speed-limit-up": 100,
    "speed-limit-up-enabled": false,
    "start-added-torrents": true,
    "trash-original-torrent-files": false,
    "umask": 18,
    "upload-slots-per-torrent": 14,
    "utp-enabled": true

Yep - I've installed transmission-web 3.00-12. I am trying to access it via, as my Dump AP IP is at .228.
I tried the binding and again - "Forbidden".

What I have tested as well is to install again transmission on my main AP and run transmission-daemon -f, as I have suspected that my Dump AP is not properly set, however I got the same message "Forbidden..."

Kind regards

try adding transmission/ to the URL.

also, make sure transmission isn't already running.
if you play with the config, but it's already running, they won't bite until you actually restart it.

if that doesn't help, I'm out of ideas :frowning:

It didn't work, however thanks

I made that post. I'm pretty sure it was due to the transition to wolfssl. I waited until the next full release of openwrt a couple of months later then recompiled and transmission started working again like it had been. I'm not sure how to mark that one as resolved now.

My most common reasons transmission will stop working now is if i didn't add my user properly into /etc/passwd, I didn't set the correct user in my transmission config file, or permissions on my download folder got reset after a reinstall or a new HDD upgrade.


Thanks @kufkis. I gave up to be honest for now as I spent 20+ hours on re-installing. In fact I tried without user access. After some months, probably will try again. I will mark this topic as solved, so the people can see your topic as well.
Thanks again.
Kind regards

OK, please, try to install libmbedtls package.

Haha @ulmwind I just given up, but your post is making me rethink my decision :wink:
I will try give it a last chance/ try starting from scratch. I am away from my router for 7 days, but I will report back the findings. Thanks!
PS: Probably it is good to mention why am I doing it. I have an ISP connection of 100 megabits and the following architecture:

  1. AP: Netgear R6800 running Openwrt taking care of the adblock and SQM. Wifi enabled.
  2. Wired Dumb AP: Xiaomi MIR3 running padavan. Used for Samba and transmission. No Wifi. Samba and transmission works out of the box.
  3. Wired Dumb AP: Xiaomi MIR3G running Openwrt used just for WiFi.
    My aim is to upgrade my internet speed to 300+ megabits and take advantage of the gigabit connections of R6800 and MIR3G.
    I want to remove the padavan device as it is only 100 megabit and it just consume power and at the same time MIR3G is not used at all.Moreover R6800 and MIR3g have an USB3 port and MIR3 only USB2.
    However upgrading to more than 100 megabits connection, doesn't make sense without gigabit connection between the routers, USB3 and working SMB and transmission. Rtorrent seems to be very very last option.
    Kind regards

Same story - it gives a crash error message. I started from scratch, got USB up and running, than Samba4, and again transmission crashes.
I am leaving it for now :frowning: . Will test if after next major release or will downgrade from 20.02.0 to 19.x.x. after I get higher internet speed.
My wife looks at me very violent now, after spending so much time on fixing this, so it is time to give up - really hate that.
Thanks for your help.
Kind regards

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.