Billion BiPAC 7700N - New device

Hi Ladies and Gents!
I have a new device I'm in the process of "tinkering" with. I took a punt with a Billion BiPAC 7700N by taking the board out and checking the model numbers of the SoCs.

I looked on the OpenWrt wiki, filtered out a list of the bcm6328 devices and spotted that the board on a Comtrend AR-5387un looked very similar to the board inside the 7700N. The BiPAC 7700N has a bcm63281tk CPU and a bcm43225kml Wi-Fi chip.

So with nothing to loose (I don't have any use for the ADSL function and the firmware has not been updated by Billion in over five years,) I took a punt and guessed that the two boards were going to be similar enough. And I guessed that lazy OEMs and/or sub-contractors had just taken the development platform they had purchased from Broadcom and made very few changes to the final product (so few, that I suspected the chance of bricking the device was low.)
I could also see the GPIO pins on the mainboard in case I needed to connect to the serial port, so I thought I would try a re-flash with OpenWrt.

I followed the flashing instructions on the Comtrend AR-5387un page but the firmware would not take. I have a small amount of experience having flashed quite a few devices before and I guessed that the way that the web interface was reacting to the firmware file, that it might be the wrong size.

So not to be discouraged, I chopped the link to the firmware down to /releases/18.06.2/targets/brcm63xx/generic/ to see if there were any smaller images floating around.
There were. Still feeling a little bit cheeky, I grabbed a 4M and an 8M image for the 963281TAN-generic-squashfs-cfe and the 96328avng-generic-squashfs-cfe boards. I then flashed the first 8M one which appeared inside the folder I had saved them into (this was 96328avng-generic-squashfs-cfe for reference) simply by using the web interface on the 7700N.

Wouldn't you know it. It flashed. The web interface took the firmware and even gave me a progress bar as it uploaded and installed.
The device rebooted and OpenWrt had installed!
Cool! I thought.

Next, I investigated what I had now done to this device and explored the web interface to see what it was like (being completely new to OpenWrt.)
I was surprised to find a complete lack of Wi-Fi. I checked the OpenWrt wiki and there should have been a Wi-Fi option shown at the top of the web interface.
My assumption was that the correct kernel Wi-Fi driver was not up, configured or installed. So I flashed the other firmware version (963281TAN-generic-squashfs-cfe) but still the same result. OpenWrt installed but Wi-Fi was missing.

Next, I scanned the wiki for a device which had an 8M image size designed for a board which has both bcm 63281 and bcm 43225. I found the Sagem F@ST2704 V2 and the page on the wiki displayed a picture of a circuit board which looked almost identical (except one antenna instead of two) to the one inside the 7700N. I flashed the image.

The result: Wi-Fi was now up and appeared inside the web interface.
I was able to scan and access points appeared within a list and I tried several times to create a client connection to other Wi-Fi APs but none worked.
I then manually added the MAC address to the configuration for the Wi-Fi adapter according to the instructions on the wiki for the F@ST2704 V2 and the client connection to the access point worked! I had an OpenWrt instance with Wi-Fi which i could use.

I have since written a wiki page about the device and it is available here: