Best practise to use OpenWrt on TP-Link Archer C6

Hey there,

I am a big fan of the tp-link low cost routers. But I am not a big fan of its stock firmware. So I decided to install openwrt to my C6 routers. Unfortuneatly there are a lot of descriptions that have incomplete or even wrong informations. So I decided to make up new thread describing my goals and how to achieve them.

My goals:

  • use C6 as access point (dump ap) with a wireless interface for all my devices
  • use C6 to establish a guest network that has no access to any other devices within my network
  • C6 using openwrt must be as fast (transmission rates) as the stockfimrware

Step 01: Installing openwrt on C6
For me it was the easiest way to use the firmeware loader in stock rom.
There I used the " [Firmware OpenWrt Install]" given on this page:

After flashing connect I connected the router to my PC and called the luci web interface (luci already installed in the C6 image ;)) on
Welcome to openwrt!


In my case I started with this openwrt version:
OpenWrt 19.07.6 r11278-8055e38794 / LuCI openwrt-19.07 branch git-21.018.57536-6ba9740

Step 02: Setup Access Point Modus and include router to my network

In my case there is an existing network with a router (fritx box) connecting to DSL and a dhcp server.
My goal was to establish a wifi connected to this network.

2.1 Setup Wifi Network
Under Network->Wireless you can find to wifi devices:

  • Qualcomm Atheros QCA9886 802.11nac
    for 5 GHz band
  • Generic 802.11bgn
    for 2.4GHz band

As the router has not the best position and most devices are not in sight to the router I focused on the 2.4GHz band.

So I just activated the predefined wifi with these settings: be continued...

Unfortunately I cannot add more than one picture...maybe I can talk the admins into giving me permission to add more pics.

In problems an how I solved them:

Problem 01:
After connecting the device to my network, I found out the transmission rate was only at 72Mbit/s as the stockfirmware made up to 102Mbit/s.
I used internet speedtest and my port supports only 100 Mbit/s maximum at the moment.


  • Uncheck "Allow legacy 802.11b rates " in the settings of youf wifi -> tab "advanced"
  • Check "Force 40MHz mode" in the settings of youf wifi -> tab "advanced"
  • install " luci-app-sqm" to prevent bufferbloat

Problem 02:
Setup a guest wifi with its own network and access restriction to the network

So what exactly is your question now ?

1 Like

it is not a question but an advice how to setup a router for basic needs. Got the permission to add more images...going to continue my post tonight...maybe this can be set to wikki after some positive replies...

btw...the link you described has wrong information especially concering firewall rules!

What information exactly do you think is wrong?

1 Like

This image took me hours:

I wasn´t familiar with those zone rules but to my understanding and experience the marked values should be changed as this is the view from lan an therefore INPUT should be accepted , OUTPUT should not be set to accept.

Since @vgaetera has reviewed this page last year, I doubt that this is a mistake.

1 Like

Funnily in my own config input is set to accept ( I have exactly your combo: Archer C6 as dump ap with guest wifi).
I changed it back and forth, and tried a traceroute from lan to a computer in guest net, worked in both combinations. And being in guest net I could do the same things with and without this setting set, also my pihole dns in lan was accessible, also the pihole web server ( for which I of course have a special rule to allow http and https).

So maybe @vgaetera can help here...

To me it looks like the 3rd rule in the description (Block guest access to private network) does the same thing as the reject setting, as it also affects guest -> lan. That's probably why I don't see any effect on changing the input zone setting from guest -> lan.

No, the LuCI point of view is always the router:
Help me understand output in firewall - #2 by vgaetera

in that case on my system something goes wrong.
By changing to this settings:

the connectivity for www gets lost instantly.

Collect the output and post to redacting the private parts:

ubus call system board; uci show network; uci show wireless; \
uci show dhcp; uci show firewall; \
ip address show; ip route show table all; ip rule show; iptables-save; \
head -v -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/*

just installed all availbale updates and called the config data you requested. While checking the data I found the traffic rules for DNS and DHCP weren´t set to destinantion zone "Device" but "LAN".
After I have fixed that, the guest interface works as described...sorry for the mess!

1 Like

This topic was automatically closed 0 minutes after the last reply. New replies are no longer allowed.