Belkin RT3200/Linksys E8450 WiFi AX discussion

I must have not explained well.

The install of the ubi opwnWRT firmware is already done.

It was up and working.

But some change I dir in the config (a VLAN I think) turn the device inaccesible.

I need to reboot in safe mode in order to disable all wifi, network config, luci or other modules and just listen through ssh in the standard IP in all ethernet ports.

Usually you have to push som button while booting or press the reset and power on the device while you keep it press. That is what I did and the device seems to be in safe bootmode as the power light is blinking quickly.

But the usual address 192.168.1.1 does not work.
So I cannot connect to the device.

Looks like some newcomers did not really follow our early discussion into the topic.

How did you some hours ago access the recovery?

The router came with a half migration to openWRT, with the recovery image installed instead of the ubi snapshot.

I simply installed uploaded and flash the ubi image and it worked.

The image and partitions are OK and working.

The device is not really bricked, just a misconfigured of vlans is preventing it from connecting though the port.

What I need is just return it to a failsafe mode where it listens through ssh in address 192.168.1.1 (or usually openWRT does, after booting in failsafe mode).

But I don't know how to put this router in failsafe mode while booting. It is not documented in the openWRT page of the router.

I have tried to press reset button during boot or maintain it pressed while booting.

It seems it has entered boot mode, as the power light flashes quickly, but I cannot ssh to it in 192.168.1.1.

How do yo boot this device in failsafe mode?

UPDATED:

Well I could at last ssh to the router.

You have to press the reset button while the device is bootint while it the power light flashes slowly.
So it is the same as in other routers.

But you cannot connect to any lan port or port 4, it seems it only connects in port 1. At least that is the port where I could connect to it.

Now I have another problem.

It seems that the config files in this version are different thatn in 21.02.

I have done moun_root in order to mount the config partition.
I was trying to edit /etc/config/network

But there is no such file in /etc/config (nor wireles file), just dhcp and some others.

Where is no the configuration of interfaces and devices saved?

You should really do a clean install as i wrote yesterday:

@ariznaf: This is the UBI recovery, so install UBI image
After that you could update to latest RECOVERY with delete of all settings.
Then Install again the same UBI image and again with delete of all settings

You dont know what is installed and maybe modified! So just replace with known clean default images withou keep any settings...
eg my own build images dont use the default IP!
Maybe just 1 or multiple port are broken?
On your screenshot is visibel that recovery 0.6.0 is installed which is not the latest

How to access recovery is wroten in the readme of the recovery installer - seems you did not check :wink:
Btw, non-UBI dont have a recovery for easy flash a new image if something is broken

1 Like

I found the way to boot in failsafe mode (pressing reset button during boot) and the port to be use to connect.

It only seems to accepts connections in port 1 in failsafe mode.

The recovery image you see is what was installed when I received the device. It seem that the guy that had the device previously tried to install openWRT with no luck, and could not return to stock firmware and let the device with the openWRT recovery image installed.

The firmare with ubi and latest snapshot is already and now it is working again (after being able to do the soft reset and enter failsafe mode).

I am not sure if the boot firmware (the ubi firmware itself) is up to date or not. Does it not get upgraded when you do a sysupgrade or burn the ubi-snapshot firmware?

This is the current status:

fw_printenv in console should tell you about the version of U-Boot which initially wrote the environment. However, even if the bootloader is not the most recent build, I woundn't care much about that if things are working fine for you. Updating the bootchain is always much more risky than just updating OpenWrt -- if something goes wrong, JTAG or raw access to the SPI flash chip using external hardware are then the only ways to recover.

1 Like

(Sigh) Kinda hard to spot one little needle in a hay-stack mound that is over 1000+ postings.

I was going to try get a serial console log for daniel of trying to flash a non-ubi snapshot from stock so that perhaps it could help him figure out why it's not working. Guess I won't now.

Restoring the vendor/official firmware
Hi all, I apologise for not so perfect English :grinning:
I tried openwrt using v0.6.1 and every thing went smoothly then I decided to return to stock and preformed the following steps

  1. Bootted into on-flash recovery
  2. Used scp to copy the original/vendor bootchain (mtdx files) to the device's /tmp folder
  3. Connected to the device via SSH and entered the following commands:
    ubidetach -d 0
    insmod mtd-rw i_want_a_brick=1
    mtd write /tmp/mtd0 /dev/mtd0
    mtd write /tmp/mtd1 /dev/mtd1
    mtd write /tmp/mtd2 /dev/mtd2
    mtd write /tmp/mtd3 /dev/mtd3
  4. Rebooted the device

Now I have white led blinking fast and a bit confused about how to restore the factory image or working openwrt. I hope someone could guide me to complete the recovery process.
Note, I don't get a replay when pinging 192.168.1.1 and any help is appreciated

Regards

1 Like

When running OpenWrt in failsafe mode (power LED blinking rapidly), the router does not issue DHCP addresses over the LAN. You have to set the PC to a static IP in 192.168.1.0/24 such as 192.168.1.10 netmask 255.255.255.0.

1 Like

In this case, I would not trust the unknown person who installed the recovery did not modfy it
Even when there are problems connecting to it

1 Like

Thank you very much, I will try both and submit the results :smiling_face_with_three_hearts:

Has anyone tested the Wireguard VPN troughput on this device?

I'm curious if I should buy the Belkin RT3200/Linksys E8450 as main router, or as dumb access point. My internet connection is 500Mbps download. So would love to know how much of that would be remaining when using Wireguard.

1 Like

To solve the white flashing power led, thank you dangowrt :smiling_face_with_three_hearts:

  1. I opened the device and connected CP2102 module as shown in the attached images tx-rx, rx-tx and ground to device body
  2. Fixed the lan IP to 192.168.1.254 and disabled wifi adapter and firewall
  3. Used putty with the serial option, com from the pc device manager, speed 115200, data bits 8, stop bits 1
    4.Powered the device while pressing reset and luckily the original u boot was intact
  4. Used the advice from dangowrt (https://github.com/dangowrt/linksys-e8450-openwrt-installer/issues/48#issuecomment-1001066649) as follows:

That looks like the old bootchain coming up properly. It's weird that you didn't manage to trigger TFTP using the button. Now that you have serial access, choose option 2. System Load Linux Kernel then write to Flash via TFTP. in the bootmenu and serve the vendor firmware via TFTP (you will see the expected filename when trying, rename the file accordingly).

*** U-Boot SPI NAND ***

 1. System Load Linux to SDRAM via TFTP.
 2. System Load Linux Kernel then write to Flash via TFTP.
 3. Boot master system code via Flash.
 4. Boot slave system code via Flash.
 5. System Load U-Boot then write to Flash via TFTP.
 6. System Load U-Boot then write to Flash via Serial.
 7. System Load ATF then write to Flash via TFTP.
 8. System Load Preloader then write to Flash via TFTP.
 U-Boot console

after that using the tftpd64 the factory image renamed to
lede-mediatek-mt7622-MTK-AX3200-MT7531-squashfs-sysupgrade.bin
and was sent to the device and booted to factory firmware
[https://ibb.co/ncjhzBM
https://ibb.co/gMSdzdz
https://ibb.co/Ln6wcR4
https://ibb.co/hXVD8bC
https://ibb.co/yQdC0wv
https://ibb.co/vYBjZqV
https://ibb.co/LQz4zsY

1 Like

I haven't used wireguard yet, but with openvpn I get 120-140 on my 200 down connection using it as my main router, so around 60% or so, which is pretty good, I'm assuming it would be even better with wireguard.

1 Like

Is that with irq balance enabled? If not can you enable and post results?

That's not bad! What is the encryption cypher used for OpenVPN? AES-256-GCM?

Off-topic, is irabalance included in the default image?

Cheers.

No and I don't know why not. Because it vastly improves performance.

I am on it.
But having problems to configure wireGuard under openWRT. I had it running in a QNAP NAS.

It was way more quick than other VPN solutions, I almost did not realize or see significant difference in performance connecting through wireGuard VPN with respect to connecing with no VPN at all.

I expect it to work very well in this router, once I get it working.

1 Like