Belkin RT3200/Linksys E8450 WiFi AX discussion

is the RT3200 the device "to go" in 2022?
any disadvantages over ath9k/ath10k ?
ath11k won't be ready this year I think?

Yeah 5.15 kernel. I'll probably just wipe and configure everything again.
I assume its not safe to use the backup/restore settings

In my experience, the 2.4Ghz wifi on the RT3200 is not great. Otherwise amazing router.

I recently switched to a Netgear WAX202 because I want better 2.4ghz wifi.

1 Like

You can safely keep settings between snapshot and 22.03.x images, there have been no changes relevant to configuration (other platforms were converted from swconfig to DSA, and that makes configuration incompatible. there is a warning in case, grep for COMPAT_VERSION).

2 Likes

2.4GHz wifi should have been stabilized significantly by

which contained

(thanks to @mrkiko who didn't get tired to bug MediaTek about the problems, esp. with Apple devices)

6 Likes

that's interesting. I was probably using an older version.

In any case, I'll take ax on 2.4ghz any day.

One other thing I've noticed with the RT3200 is that 160MHz channel width doesn't result in faster speeds vs. 80. The MT7915DBDC doesn't support 160MHz.

I thought it did but only in 2x2 antenna config and not 4x4?

1 Like

I've now been on 22.03 RC5 for ~ 3 days.
I am still seeing some download fail / network errors

Is there anything I can check log wise or rule out (maybe fw4 issue)?
Wired clients also have the same issue, so not a radio configuration problem.

A while back, I was having issues with my E8450 with both wired and wireless connections. Web pages would randomly stop loading, and I'd have to reload a few times to get the page to fully load. My Nintendo Switch would fail the download phase of an Internet test. I ran a git bisect and ended up with this commit as the failure:

https://git.openwrt.org/?p=openwrt/openwrt.git;a=commitdiff;h=03685d347025e62faa8f89d0502dcd1dcf6152b4

I was about to revert the commit, but instead tried setting

net.netfilter.nf_conntrack_tcp_no_window_check=1

in /etc/sysctl.conf, and that seems to have fixed my problems.

2 Likes

very interesting. I have this issue as well on a D-Link dir-1960 (mt7621 device). Will try the fix.

By any chance do you have any 100Mbps wired device connected to one of the routers port? I have a Redmi AX6S (same mt7622 chipset with similar configs) and I experienced packet loss just because I had a Samsung TV (100Mbps) connected to the router. Every time a streaming service was used on the TV I observed 1%~2% packet loss on the network (more details here).

3 Likes

Hi guys,

I'm a newbie, so at the beginning of my learning path... :slight_smile:
I just got the RT3200 today and I managed to brick(?) the device. Basically everything is working but the device is booting into recovery mode after every reboot. Of course, all settings are lost after the reboot. I think, that is normal if it boots to ramdisk.
As I see, the /dev/root and the overlay are missing.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt SNAPSHOT, r20167-a8e1e30543
 -----------------------------------------------------
=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
--------------------------------------------------
root@OpenWrt:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
tmpfs                   250644     13516    237128   5% /
tmpfs                   250644        72    250572   0% /tmp
tmpfs                      512         0       512   0% /dev
root@OpenWrt:~# 

I can access the router via SSH, SCP.
Can I manually restore UBI layout somehow?
Could you advise?

Thanks!

Edit: In addition the SSH key changes after every reboot.

Thank you. I tried this, but the boot process seemed to be the same after the echo c > /proc/sysrq-trigger command.

Did you try the 2nd step?

rm /sys/fs/pstore/*

I tried that. Went through the whole process. Also, tried googling for missing root partition. My understanding is that I might need to flash an image, but I am not sure.

Can you list out the exact steps you followed (and the files you flashed in those steps)?

EDIT: Maybe disconnect power from the router, wait about 1 min and then connect back the power. That may clear the RAM and make it boot into the firmware on the disk.

Basically, I went through the OpenWrt conversion process, but skipped the backup. I am not planning to go back to the original firmware. Everything seems to be fine at that point, however I could not update the package list because of the old kernel, so I started figuring out how to update that.
I basically flashed the images from here: https://downloads.openwrt.org/snapshots/targets/mediatek/mt7622/

I am going to try to power cycle the router tomorrow and report back. Thanks for the idea @ka2107 . :slight_smile:

Is your RT3200 is already converted to UBI layout?

How can I confirm that?

Edit: I did flash openwrt-22.03-snapshot-r19338-ae64d0624c-mediatek-mt7622-linksys_e8450-ubi-initramfs-recovery-installer.itb from dangowrt.