Belkin RT3200/Linksys E8450 WiFi AX discussion

yup, I can confirm I had my 5ghz channel stop & unable to connect today with OpenWrt SNAPSHOT r19421-3aa96efa24

While I had problems with 5Ghz yesterday a simple restart of the network interface via LUCI solved it. Luckily I have a wireguard vpn from which I can access my Router to do that without connectivity.

I have fixed the pppoe hw offload. Now the cpu usage is zero during speedtest.

I also deleted 252-254. 252-254 seems to make kernel oops sometimes.


Very nice! Are you planning to submit this as a patch or PR to OpenWrt?

1 Like

good evening everyone is there a difference between 21.02.3 and 22.03 and is the belkin now compatible with 21.02.3? thank you in advance

Yes. Forthcoming 21.02.3 is a just maintenance release from the old 21.02 branch.

21.02.3 is still mainly the same code from February 2021, with a few more bug fixes than 21.02.2

22.03.0 will be the new major release, and will support this device.

See the current branches below. Hopefully this clarifies the situation for you


This is part of pppoe hw offload patch. Another part is

I will consider to make a pr after several day's test. But I feel the pr process is even difficult in somewhere.

1 Like

Yeah, that doesn't look so good, as instead of turning the if into a noop (as both branches now return true) it should then rather be removed entirely. As I don't understand it: Can you explain why this is needed?
@nbd any idea how to get flow offloading with PPPoE working in a clean way (and hopefully without breaking something else)?

1 Like

From my understanding, there are two problems that broke the pppoe hw offload.

1.PPPOE can't pass the dev->type != ARPHRD_ETHER || dev->addr_len != ETH_ALEN check. It will return here. I used to mention it here.

2.There is no valid resoure address with pppoe. we can see that both resource and dest address are created in linux 5.4 version but now there is only dest address.

So we should reopen I supposed, right?

1 Like

I remixed the patch of nbd, now we don't need any other modification, just add this patch to make pppoe hw offload take effect. I'll reopen that issue after I'm sure there's no problem with this patch.

1 Like

I suppose your patch should be placed in /target/linux/generic instead of /target/linux/mediatek? It should apply for mt7621 routers using mt7530 switches. In fact, any router using mt753x switches should work.

I placed it in Mediatek folder just because I haven't test it with mt7621 although it should also work for mt7621.
In fact hwnat module is only about ppp engine which isn't in switch.
I‘m still use swconfig in mt7622 instead of dsa as there still some bugs with dsa. Luckily hwnat works properly with swconfig.

I stand corrected. :stuck_out_tongue:

I'll be testing your PPPoE patch on my Linksys EA7500v2 mt7621 router using the latest master repo. Need some pointer from you. Do I need to switch back to firewall3 since the default now is firewall4? I remember reading somewhere that firewall4 does not support h/w offloading?

Yes, my patch is based on xt_flow_offload which firewall3 is using.


Many thanks for your contribution. I used your new patch (slighty modified) with a new 5.15 build and indeed the CPU usage is close to zero :open_mouth: when using an ethernet-connected client (previously the CPU usage was even higher than for WLAN clients).
But for WLAN clients the CPU usage is still the same like your previous fix for PPPoE (with wed enabled), about 25% when download and 50% when uploading. Also I noticed after the ethernet test that the bridger process started to consume 50% CPU so I restarted it, don't know what caused this. I really hope now that you've managed to discover the PPPoE issue, Felix will look into it and make a final hw offloading patch that applies also to PPPoE and doesn't break other packages.

It's normal that wan->wifi consume 25% cpu. Stock firmware also consume some cpu usage during wan->wifi test. This patch only fix the wire performance issue.

Bridger is only about lan->wifi offload. If it works, you can see some bind from cat /sys/kernel/debug/mtk_ppe/bind during lan->wifi speedtest.

The default profile needs to be modified (delete # like this) to make bridger works correctly. I haven't meet the situation that bridger process consumes a lot of cpu usage.

1 Like

i have download a last version for rt3200 work very well

the packages is donwloadable everywhere with this version you know ?

openwrt 22.03.0 rc1 e19302

Anyone know when we'll get brave and swap out 5.10 for 5.15 for these chipsets by default for master? Seems like it is pretty stable but I'm sure I'm not touching sections that other people do (like PPPoE).

Hi, does anyone know if RT3200 support jumbo frames wan-side (I need 1540 MTU to overcome encapsulation overhead)?

If it does not, is it a driver or hardware issue?

I tried raising MTU in luci but it seems not working well