Belkin RT3200/Linksys E8450 WiFi AX discussion

This is a totally unrecommended practice! The person returning a "hacked" router is one of many reasons why the vendors are locking the bootloaders... Many thumbs down to the original owner... Now you can just try a newer UBI OpenWRT (it IS UBI variant as it is shown in the interface), there is no simple way to put non-UBI OpenWRT or original firmware back.

4 Likes

Thanks, I will try wiith ubi version if it works.

Should I make backup of all partitions, first?

(Well. I have made it just in case, downloaded files from all four mdt blocks (bl2, fip, factory and ubi).
I suppose that would let me revert to the current state at least.)

If it works and everything is OK it is not important for me as I am going to install openWRT.

But I won't be able to revert to stock firmware or try it, or even try non ubi.

For the price, I can get one new from Germany (about same price) but it will take several days, until 29 or so.

If they tell you the truth and you buy a bargain, it is OK. But it was only about 25% discount and says in perfect state, only minor scratchees (I can see none) and box not being perfect.

The only very important partition for this router is the factory partition (original mtd4 or ubi mtd2) containing MAC addresses and calibration. The original firmware also used the original mtd5 partition for default wlan settings, serial number and other settings which are not used by OpenWRT. If the factory partition is not damaged then you can install OpenWRT UBI and use it without problems.

1 Like

@ariznaf: This is the UBI recovery, so install UBI image
After that you could update to latest RECOVERY with delete of all settings.
Then Install again the same UBI image and again with delete of all settings

1 Like

Thank, I have made a download of all 4 partitions (I expect the factory is not damaged, as wifi seems to work).

I will try to install ubi. At least the router will be in a better state than now in recovery mode (if I understood well that is the mode when you burn the recovery partition in order to revert to original firmware, for example)

But I think I will return it next week, with it working if possible, as a new router costs more or least the same.

BTW: If you want to install an OpenWRT build with more packages already inside, you can try this version: https://forum.openwrt.org/t/build-ubi-for-belkin-rt3200-linksys-e8450/94569 or... build your own.

1 Like

I will try, that then.

Can I install other software like wireGuard using luci interface under snapshot firmware?

I am not at the level of being able to build my own openWRT custom router firmware.

Well it seems the flashing went OK and it is working. Now I have to configure it:

How should I do a reset in this router to get access when connection is lost?

Usually when you have lost connection to the router you reinit the router and press some key to enter put the router in save mode and access it using 192.168.1.1.

I have pressed reset button while bootin to put it in safe mode. The light is flashing quickly which indicates that it is in safe mode.

But when I try to access it using ssh in 192.168.1.1 it does not answer (I have assigned 192.16.1.254 to my PC with mask 255.255.255.0).

Is it on other IP when booting safemode?

I must have not explained well.

The install of the ubi opwnWRT firmware is already done.

It was up and working.

But some change I dir in the config (a VLAN I think) turn the device inaccesible.

I need to reboot in safe mode in order to disable all wifi, network config, luci or other modules and just listen through ssh in the standard IP in all ethernet ports.

Usually you have to push som button while booting or press the reset and power on the device while you keep it press. That is what I did and the device seems to be in safe bootmode as the power light is blinking quickly.

But the usual address 192.168.1.1 does not work.
So I cannot connect to the device.

Looks like some newcomers did not really follow our early discussion into the topic.

How did you some hours ago access the recovery?

The router came with a half migration to openWRT, with the recovery image installed instead of the ubi snapshot.

I simply installed uploaded and flash the ubi image and it worked.

The image and partitions are OK and working.

The device is not really bricked, just a misconfigured of vlans is preventing it from connecting though the port.

What I need is just return it to a failsafe mode where it listens through ssh in address 192.168.1.1 (or usually openWRT does, after booting in failsafe mode).

But I don't know how to put this router in failsafe mode while booting. It is not documented in the openWRT page of the router.

I have tried to press reset button during boot or maintain it pressed while booting.

It seems it has entered boot mode, as the power light flashes quickly, but I cannot ssh to it in 192.168.1.1.

How do yo boot this device in failsafe mode?

UPDATED:

Well I could at last ssh to the router.

You have to press the reset button while the device is bootint while it the power light flashes slowly.
So it is the same as in other routers.

But you cannot connect to any lan port or port 4, it seems it only connects in port 1. At least that is the port where I could connect to it.

Now I have another problem.

It seems that the config files in this version are different thatn in 21.02.

I have done moun_root in order to mount the config partition.
I was trying to edit /etc/config/network

But there is no such file in /etc/config (nor wireles file), just dhcp and some others.

Where is no the configuration of interfaces and devices saved?

You should really do a clean install as i wrote yesterday:

@ariznaf: This is the UBI recovery, so install UBI image
After that you could update to latest RECOVERY with delete of all settings.
Then Install again the same UBI image and again with delete of all settings

You dont know what is installed and maybe modified! So just replace with known clean default images withou keep any settings...
eg my own build images dont use the default IP!
Maybe just 1 or multiple port are broken?
On your screenshot is visibel that recovery 0.6.0 is installed which is not the latest

How to access recovery is wroten in the readme of the recovery installer - seems you did not check :wink:
Btw, non-UBI dont have a recovery for easy flash a new image if something is broken

1 Like

I found the way to boot in failsafe mode (pressing reset button during boot) and the port to be use to connect.

It only seems to accepts connections in port 1 in failsafe mode.

The recovery image you see is what was installed when I received the device. It seem that the guy that had the device previously tried to install openWRT with no luck, and could not return to stock firmware and let the device with the openWRT recovery image installed.

The firmare with ubi and latest snapshot is already and now it is working again (after being able to do the soft reset and enter failsafe mode).

I am not sure if the boot firmware (the ubi firmware itself) is up to date or not. Does it not get upgraded when you do a sysupgrade or burn the ubi-snapshot firmware?

This is the current status:

fw_printenv in console should tell you about the version of U-Boot which initially wrote the environment. However, even if the bootloader is not the most recent build, I woundn't care much about that if things are working fine for you. Updating the bootchain is always much more risky than just updating OpenWrt -- if something goes wrong, JTAG or raw access to the SPI flash chip using external hardware are then the only ways to recover.

1 Like

(Sigh) Kinda hard to spot one little needle in a hay-stack mound that is over 1000+ postings.

I was going to try get a serial console log for daniel of trying to flash a non-ubi snapshot from stock so that perhaps it could help him figure out why it's not working. Guess I won't now.

Restoring the vendor/official firmware
Hi all, I apologise for not so perfect English :grinning:
I tried openwrt using v0.6.1 and every thing went smoothly then I decided to return to stock and preformed the following steps

  1. Bootted into on-flash recovery
  2. Used scp to copy the original/vendor bootchain (mtdx files) to the device's /tmp folder
  3. Connected to the device via SSH and entered the following commands:
    ubidetach -d 0
    insmod mtd-rw i_want_a_brick=1
    mtd write /tmp/mtd0 /dev/mtd0
    mtd write /tmp/mtd1 /dev/mtd1
    mtd write /tmp/mtd2 /dev/mtd2
    mtd write /tmp/mtd3 /dev/mtd3
  4. Rebooted the device

Now I have white led blinking fast and a bit confused about how to restore the factory image or working openwrt. I hope someone could guide me to complete the recovery process.
Note, I don't get a replay when pinging 192.168.1.1 and any help is appreciated

Regards

1 Like

When running OpenWrt in failsafe mode (power LED blinking rapidly), the router does not issue DHCP addresses over the LAN. You have to set the PC to a static IP in 192.168.1.0/24 such as 192.168.1.10 netmask 255.255.255.0.

1 Like

In this case, I would not trust the unknown person who installed the recovery did not modfy it
Even when there are problems connecting to it

1 Like

Thank you very much, I will try both and submit the results :smiling_face_with_three_hearts: