Belkin RT3200: iPhone 11 frequently loses connectivity

I have an iPhone 11 that frequently loses WiFi connectivity from my RT3200 configured as a dumb AP. Other devices do not experience this (newer and older iOS devices, miscellaneous laptops, etc).

This RT3200 is running a snapshot I complied a few days ago, but the losing connectivity has been pretty constant ever since I switched to using the RT3200. Prior to the RT3200, I was using a Netgear R7800 and I did not experience these disconnects on this particular iPhone 11.

Here is an example output from logread with time stamps that correspond to the disconnection:

Sun Feb 27 08:02:45 2022 daemon.notice hostapd: wlan1-1: AP-STA-DISCONNECTED xx:xx:xx
Sun Feb 27 08:02:45 2022 daemon.info hostapd: wlan1-1: STA xx:xx:xx IEEE 802.11: disassociated
Sun Feb 27 08:02:47 2022 daemon.info hostapd: wlan1-1: STA xx:xx:xx IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)

At the time that occurred, the screen was on, and I was using the phone. I noticed the WiFi symbol change to LTE. The behavior stabilized a bit but came back about 15 minutes later as you can see in the more complete logread output:

more complete logread output
Sun Feb 27 07:34:35 2022 daemon.info hostapd: wlan1-1: STA xx:xx:xx IEEE 802.11: associated (aid 2)
Sun Feb 27 07:34:35 2022 daemon.notice hostapd: wlan1-1: AP-STA-CONNECTED xx:xx:xx
Sun Feb 27 07:34:35 2022 daemon.info hostapd: wlan1-1: STA xx:xx:xx WPA: pairwise key handshake completed (RSN)
Sun Feb 27 07:34:35 2022 daemon.notice hostapd: wlan1-1: EAPOL-4WAY-HS-COMPLETED xx:xx:xx
Sun Feb 27 08:02:45 2022 daemon.notice hostapd: wlan1-1: AP-STA-DISCONNECTED xx:xx:xx
Sun Feb 27 08:02:45 2022 daemon.info hostapd: wlan1-1: STA xx:xx:xx IEEE 802.11: disassociated
Sun Feb 27 08:02:47 2022 daemon.info hostapd: wlan1-1: STA xx:xx:xx IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Sun Feb 27 08:08:14 2022 daemon.info hostapd: wlan1-1: STA xx:xx:xx IEEE 802.11: associated (aid 2)
Sun Feb 27 08:08:14 2022 daemon.notice hostapd: wlan1-1: AP-STA-CONNECTED xx:xx:xx
Sun Feb 27 08:08:14 2022 daemon.info hostapd: wlan1-1: STA xx:xx:xx WPA: pairwise key handshake completed (RSN)
Sun Feb 27 08:08:14 2022 daemon.notice hostapd: wlan1-1: EAPOL-4WAY-HS-COMPLETED xx:xx:xx
Sun Feb 27 08:08:30 2022 daemon.notice hostapd: wlan1-1: AP-STA-DISCONNECTED xx:xx:xx
Sun Feb 27 08:08:30 2022 daemon.info hostapd: wlan1-1: STA xx:xx:xx IEEE 802.11: disassociated
Sun Feb 27 08:08:31 2022 daemon.info hostapd: wlan1-1: STA xx:xx:xx IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Sun Feb 27 08:09:07 2022 daemon.info hostapd: wlan1-1: STA xx:xx:xx IEEE 802.11: authenticated
Sun Feb 27 08:09:07 2022 daemon.info hostapd: wlan1-1: STA xx:xx:xx IEEE 802.11: associated (aid 2)
Sun Feb 27 08:09:07 2022 daemon.notice hostapd: wlan1-1: AP-STA-CONNECTED xx:xx:xx
Sun Feb 27 08:09:07 2022 daemon.info hostapd: wlan1-1: STA xx:xx:xx WPA: pairwise key handshake completed (RSN)
Sun Feb 27 08:09:07 2022 daemon.notice hostapd: wlan1-1: EAPOL-4WAY-HS-COMPLETED xx:xx:xx
Sun Feb 27 08:10:30 2022 daemon.notice hostapd: wlan1-1: AP-STA-DISCONNECTED xx:xx:xx
Sun Feb 27 08:10:30 2022 daemon.info hostapd: wlan1-1: STA xx:xx:xx IEEE 802.11: disassociated
Sun Feb 27 08:10:31 2022 daemon.info hostapd: wlan1-1: STA xx:xx:xx IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Sun Feb 27 08:15:39 2022 daemon.info hostapd: wlan1-1: STA xx:xx:xx IEEE 802.11: authenticated
Sun Feb 27 08:15:39 2022 daemon.info hostapd: wlan1-1: STA xx:xx:xx IEEE 802.11: associated (aid 2)
Sun Feb 27 08:15:39 2022 daemon.notice hostapd: wlan1-1: AP-STA-CONNECTED xx:xx:xx
Sun Feb 27 08:15:39 2022 daemon.info hostapd: wlan1-1: STA xx:xx:xx WPA: pairwise key handshake completed (RSN)
Sun Feb 27 08:15:39 2022 daemon.notice hostapd: wlan1-1: EAPOL-4WAY-HS-COMPLETED xx:xx:xx
Sun Feb 27 08:30:27 2022 daemon.notice hostapd: wlan1-1: AP-STA-DISCONNECTED xx:xx:xx
Sun Feb 27 08:30:27 2022 daemon.info hostapd: wlan1-1: STA xx:xx:xx IEEE 802.11: disassociated
Sun Feb 27 08:30:28 2022 daemon.info hostapd: wlan1-1: STA xx:xx:xx IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Sun Feb 27 09:34:50 2022 daemon.info hostapd: wlan1: STA xx:xx:xx IEEE 802.11: associated (aid 3)
Sun Feb 27 09:34:50 2022 daemon.notice hostapd: wlan1: AP-STA-CONNECTED xx:xx:xx
Sun Feb 27 09:34:50 2022 daemon.info hostapd: wlan1: STA xx:xx:xx WPA: pairwise key handshake completed (RSN)
Sun Feb 27 09:34:50 2022 daemon.notice hostapd: wlan1: EAPOL-4WAY-HS-COMPLETED xx:xx:xx
/etc/config/wireless
config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/18000000.wmac'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option disabled '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option band '5g'
	option country 'US'
	option beacon_int '101'
	option cell_density '1'
	option htmode 'HE80'
	option channel '149'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'ap'
	option encryption 'sae'
	option dtim_period '3'
	option wpa_disable_eapol_key_retries '1'
	option ssid 'name'
	option key 'xxx'
	option ieee80211w '2'
	option network 'lan'

config wifi-iface 'wifinet3'
	option device 'radio1'
	option mode 'ap'
	option encryption 'sae-mixed'
	option dtim_period '3'
	option wpa_disable_eapol_key_retries '1'
	option ssid 'guestname'
	option key 'xxx'
	option ieee80211w '2'
	option network 'guest'

config wifi-iface 'wifinet4'
	option device 'radio1'
	option mode 'ap'
	option dtim_period '3'
	option wpa_disable_eapol_key_retries '1'
	option ssid 'anothername'
	option encryption 'psk2+ccmp'
	option key 'xxx'
	option ieee80211w '1'
	option disabled '1'

Finding this wiki page, I tried applying option disassoc_low_ack '0' to all the wi-fi interfaces. In doing so, I found that an iPhone 13 began experiencing the same wifi dropping so I removed those lines.

Instead, I disabled cell density coverage option cell_density '0' and am testing that out.

An update: I just built from master pulling in the PR to update the kernel to 5.15.38 (previously on 5.10.113 from about 2 weeks ago). I have not experienced this yet. Not sure what change/changes to credit to it.

# logread| grep DEAUTH | wc -l
0

Havn't noticed much but I have three DEAUTH over 13h but for three different devices on the rc-snapshot r19338.