Belkin RT3200 BRICKED

Yesterday i flashed openwrt on RT3200 which I bought the day before yesterday.
everything was working fine i was enjoying the OpenWrt on my new router and basically, i bought this router just for OpenWRT.

today I thought I should have used USB drive also so it i wached youtube video for how to do it and found one video i followed the tutorial and install 4 packages
3 packages for kmod-usb-storage
1 package for ntfs 3g
after than i reboot router it rebooted for for couple second than all the LED went off.
now my router is not turning on not showing any led light blinking.
and no ethernet connection even.

please help me to fix this issue.

You'll probably need serial, unless it's dead.

I assume you tried starting it without having the drive connected, and temp replaced the power adapter?

drive was connected and i was using 512 512 GB sata hard drive with caddy converted to usb 2.0.

I hope the drive had a power supply of its own, if it was a HDD, not a SSD ?

its SATA HDD and it takes all the power from usb as i used it so many times with my laptop

The laptop doesn't have a 2-3A power supply.

You might have fried your router.

1 Like

i can still return this router...if i return it will there be any option for them to check it having openwrt?

If it's dead, it's dead.

But I'd try to replace the power adapter 1st.

i have tplink ax3000 router also can i use that adapter with this router.....the adapter supply 24w but tplink supply 12w but both adapter having 12v 2A

and one thing more no burning smell is coming from router.

Higher wattage isn't a problem, as long as the voltage and polarity is the same.


You can't always smell, if a device is defective.
Please try it first with the original power supply, but without the hdd and caddy. Just to make sure you haven't destroyed your router.
If the router won't work with the original power supply, try one of the others.
Please heed what @frollic wrote.
If your router is still ok, obtain an usb-hub with a power supply and connect it to your router and the hdd to the hub.

If not...get a new router and better luck next time.

Tried with Tp link adapter and without caddy nothing worked.

Now I request for Return as a defective item on Amazon let's hope they Don't find What i did with there Router :slight_smile:

An obvious question, make sure that you didn't bump the little on-off switch next to the power inlet to off. That powers down the whole router.

When you plug it in (with switch on) does the power LED light up at all?

Dumb question, but could you elaborate on that? Is the point that the power supply on the router isn't large enough and wouldn't there be protection to prevent this sort of thing happening?

The excessive power draw might have damaged the power supply, and it damaged the router in the process.

Regarding protection, yes there should be, but again, we don't know what killed what, in which order.

Bro Just now i checked Rt3200 power adapter with my tplink Router And it worked fine than I plug it in the Rt3200 and pressed the off and on button...This Rt3200 works but after Unplugging and plug again the Adapter it doesn't work.

You should make sure it's really broken before you decide to return it (and even then you should reflect on the fact that if it's broken it was not the fault of the manufacturer, but your own for plugging in the HDD). Because it's sad how many electronic devices end up in landfill or sent for extraction of precious metals, sometimes even by little children in dreadful conditions. I'm no eco-warrior, but it seems there is something wrong about how we handle electronics.

1 Like