Belkin RT3200 (aka linksys e8450) performance

I am curious if anyone has been able to get ~1Gbps wifi performance on this device (ax 3200 wifi 6)?

I have tried to enable the 160MHz bands, but that does not actually improve performance.

At best via iperf3 I see 690Mbps and usually average ~600Mbps within 3 feet (-38dBm signal / 80MHz). I have confirmed iperf3 running via LAN gives ~980Mbps, so I was hoping for something similar. I have a neighbor who has an eero pro setup which gets 900Mbps which I am trying to match with what I thought was similar hardware.

Is this really just an mt76 limitation as discussed here?

This is all on 22.03

~# cat /etc/openwrt_release
DISTRIB_DESCRIPTION='OpenWrt 22.03.0 r19685-512e76967f'

Tried snapshot too, same results.

~# cat /etc/openwrt_release
DISTRIB_DESCRIPTION='OpenWrt SNAPSHOT r20856-2b4f12e55b'

I checked the WiFi performance and created a youtube video

TL;DR - The WiFi strength is weak on this router - period.

Maybe it's your client? I consistently see 780Mbit/sec with occasional intervals over 800Mbit/sec in 802.11ac with 80mhz channel. This is from a Samsung Galaxy S21 Ultra using PingTools. The phone reports a 1.1Gbps connection.

I could not get 160mhz channels working at all. Every time I enable 160mhz the 5ghz radio fails to start.

Fri Nov 11 17:30:54 2022 daemon.notice netifd: radio1 (4910): Command failed: ubus call hostapd config_remove {"iface":"wlan1"} (Request timed out)
Fri Nov 11 17:30:54 2022 daemon.notice netifd: Wireless device 'radio1' is now down
Fri Nov 11 17:30:54 2022 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy1.conf (phy wlan1) --> new PHY
Fri Nov 11 17:30:54 2022 daemon.notice hostapd: wlan1: interface state UNINITIALIZED->HT_SCAN
Fri Nov 11 17:30:55 2022 daemon.err hostapd: could not get valid channel

@dan3 From what distance are you testing? Are there any walls between?

my mt7621 (the older AC cousin) in dir-1960 has around 460mbit within 3meters of the device, when configured as router and around 630mbit/sec when used as access point only. But depends on client.

So you may want to disable NAT, routing and firewall, to measure max Wifi thoughput.

@stmtpr That was peak throughput with 802.11ax/80mhz, within 10 feet, and line of sight to the router. I usually run 802.11ac/80mhz for more consistent performance. Much more info on that here: 802.11ax vs 802.11ac with MT76

@Pico These iperf tests are local, they don't use the WAN interface. I run iperf3 on the router, but I get the same performance when running iperf3 on a wired client.

iperf will also consume router CPU cycles and CPU IO, if either server- oder client-side of iperf is run on the router.

If you dont aim at max thoughput measurements, you may want to ensure the same test setup, to properly you compare results with others.

This router is capable of 3.6gbit in an iperf loop back test, while a wired client is limited to 1gbit. If we do get 160mhz channel support then a wired gigabit port will be the bottleneck.