Batman mesh node can not ping to another node

Hi all,

I am new to batman-adv and mesh networking in general.

  • IPQ6018 driver.
  • two radios 2.4/5 GHz and one ethernet port for LAN/WAN.
  • I installed kmod-batman-adv 4.4.60 and batctl.

Topology:

Node A can get br-wan IP by Gateway. If batman mesh was created, Node B and Node C can get IP by Node A mesh0.

At first, the three APs established the mesh network, they can also ping each other.
After standing for a while, node A and B can ping each other. Node A and C can also ping each other, But B and C can not ping each other or delay receiving the packet.
Client Still on Internet from node C or B SSID.
I tried many methods, like change batman parameter, but still can't find the solution.
Please help me.

/etc/config/wireless

config wifi-device 'radio0'
	option mode 'ap'
	option type 'mac80211'
	option beacon_int '100'
	option path 'platform/soc/c000000.wifi'
	option disabled '0'
	option country 'US'
	option txpower '21'
	option max_txpwr '26'
	option all_channel '0'
	option channel '48'
	option min_signal_allowed '0'
	option wds '1'
	option hwmode '11ac'
	option htmode 'VHT20'

config wifi-iface 'wmesh'
	option ifname 'mesh0'
	option network 'bat0_hardif_mesh0'
	option mode 'mesh'
	option mesh_fwding '0'
	option mesh_ttl '1'
	option mcast_rate '24000'
	option key '12345678'
	option disabled '0'
	option device 'radio0'
	option mesh_id 'rayopenmesh'
	option encryption 'none'

/etc/config/network
config interface 'lan'
	option type 'bridge'
	option ifname 'eth1 eth2'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option mtu '1500'

config interface 'wan'
	option proto 'dhcp'
	option inet_src 'eth0'
	option mtu '1500'
	option type 'bridge'
	option manual_hostname '1'
	option hostname 'Edge-core'
	option ifname 'eth0 bat0'

config interface 'wan6'
	option ifname 'eth0'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '0'
	option enable_vlan '0'

config interface 'bat0'
	option proto 'batadv'
	option routing_algo 'BATMAN_IV'

config interface 'bat0_hardif_mesh0'
	option proto 'batadv_hardif'
	option master 'bat0'
	option mtu '1536'

Check, changing this to

option mesh_fwding '1'

1 Like