Batman-adv mesh works very slow Internet up link

Hi Community
I have a two node mesh network. An access router "zyxel armor z2" as an Internet gateway with a local web server and an ADSL modem. A "TP-Link RE650" as mesh point.
Client A is connected to the access router via WiFi (LoewenNet), Client B via WiFi (LoewenNet) to the Meshpoint.
MeshNet
Here is the configuration of the access router.
Network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdb7:2803:b7f8::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1.1 bat0.1'
        option proto 'static'
        option ipaddr '192.168.128.1'
        option netmask '255.255.255.0'
        option stp '1'
        option delegate '0'
        option ip6assign '60'
        option igmp_snooping '1'
        list dns '192.168.128.1'

config device 'lan_eth1_1_dev'
        option name 'eth1.1'
        option macaddr '54:83:3a:70:21:86'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'pppoe'
        option password 'password'
        option ipv6 'auto'
        option username '0103218858@connect.ch'
 #       option mtu '1450'

config device 'wan_eth0_2_dev'
        option name 'eth0.2'
        option macaddr '54:83:3a:70:21:87'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '6t 1 2 3 4'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 5'
        option vid '2'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '181'
        option ports '6t 1t 2t'

config switch_vlan
        option device 'switch0'
        option vlan '4'
        option vid '133'
        option ports '6t 1t 2t'

config interface 'GuestNetwork'
        option ifname 'eth1.181 bat0.181'
        option proto 'static'
        option ipaddr '192.168.181.1'
        option netmask '255.255.255.0'
        option type 'bridge'
        option ip6assign '60'
        option stp '1'
        option delegate '0'
        option igmp_snooping '1'

config route
        option target '192.168.129.0'
        option gateway '192.168.128.10'
        option interface 'lan'
        option netmask '255.255.255.0'

config interface 'SmartHome'
        option ifname 'eth1.133 bat0.133'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.133.1'
        option type 'bridge'
        option ip6assign '60'
        option stp '1'
        option delegate '0'
        option igmp_snooping '1'

config interface 'bat0'
        option proto 'batadv'
        option routing_algo 'BATMAN_IV'
        option aggregated_ogms '1'
        option ap_isolation '0'
        option bonding '0'
        option fragmentation '1'
        option gw_mode 'off'
        option log_level '0'
        option orig_interval '1000'
        option bridge_loop_avoidance '1'
        option distributed_arp_table '1'
        option multicast_mode '1'
        option network_coding '0'
        option hop_penalty '30'
        option isolation_mark '0x00000000/0x00000000'

config interface 'nwi_mesh0'
        option mtu '1532'
        option proto 'batadv_hardif'
        option master 'bat0'

Wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option country 'CH'
        option htmode 'VHT80'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option key 'password'
        option ssid 'LoewenNet5G'

config wifi-iface 'LoewenNetGuests5G'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'ap'
        option network 'GuestNetwork'
        option key 'password'
        option ssid 'LoewenNetGuests5G'

config wifi-iface 'LoewenNetIoT5G'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'ap'
        option network 'SmartHome'
        option key 'password'
        option ssid 'Loewennetiot5G'

config wifi-iface 'mesh0'
        option device 'radio1'
        option ifname 'mesh0'
        option network 'nwi_mesh0'
        option mode 'mesh'
        option mesh_fwding '0'
        option mesh_id 'LoewenNetMesh'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option htmode 'HT20'
        option country 'CH'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option key 'password'
        option ssid 'LoewenNet'

config wifi-iface 'LoewenNetGuests'
        option device 'radio1'
        option mode 'ap'
        option network 'GuestNetwork'
        option key 'password'
        option ssid 'LoewenNetGuests'
        option encryption 'psk2'

config wifi-iface 'LoewenNetIoT'
        option encryption 'psk2'
        option device 'radio1'
        option mode 'ap'
        option network 'SmartHome'
        option key 'password'
        option ssid 'Loewennetiot'
root@AccessRouter:~# batctl if
mesh0: active
root@AccessRouter:~# batctl o
[B.A.T.M.A.N. adv openwrt-2019.2-5, MainIF/MAC: mesh0/54:83:3a:70:21:84 (bat0/da:d9:14:89:f7:52 BATMAN_IV)]
   Originator        last-seen (#/255) Nexthop           [outgoingIF]
 * 74:da:88:4f:c7:5b    2.080s   (255) 74:da:88:4f:c7:5b [     mesh0]
root@AccessRouter:~# batctl n
[B.A.T.M.A.N. adv openwrt-2019.2-5, MainIF/MAC: mesh0/54:83:3a:70:21:84 (bat0/da:d9:14:89:f7:52 BATMAN_IV)]
IF             Neighbor              last-seen
        mesh0     74:da:88:4f:c7:5b    0.620s

Here the configuration of the Meshpoint
Network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdfa:1864:ab4a::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1 bat0.1'
        option proto 'static'
        option ipaddr '192.168.128.3'
        option netmask '255.255.255.0'
        option gateway '192.168.128.1'
        option ip6assign '60'
        list dns '192.168.128.1'
        option stp '1'
        option igmp_snooping '1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 6t'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '6t 0t'
        option vid '133'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '6t 0t'
        option vid '181'

config interface 'SmartHome'
        option ifname 'eth0.133 bat0.133'
        option proto 'none'
        option type 'bridge'
        option stp '1'
        option delegate '0'
        option igmp_snooping '1'

config interface 'GuestNetwork'
        option ifname 'eth0.181 bat0.181'
        option proto 'none'
        option type 'bridge'
        option stp '1'
        option delegate '0'
        option igmp_snooping '1'

config interface 'bat0'
        option proto 'batadv'
        option routing_algo 'BATMAN_IV'
        option aggregated_ogms '1'
        option ap_isolation '0'
        option bonding '0'
        option fragmentation '1'
        option gw_mode 'off'
        option log_level '0'
        option orig_interval '1000'
        option bridge_loop_avoidance '1'
        option distributed_arp_table '1'
        option multicast_mode '1'
        option network_coding '0'
        option hop_penalty '30'
        option isolation_mark '0x00000000/0x00000000'

config interface 'nwi_mesh0'
        option mtu '1532'
        option proto 'batadv_hardif'
        option master 'bat0'

Wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'HT20'
        option country 'CH'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option key 'password'
        option ssid 'LoewenNet'

config wifi-iface 'LoewenNetGuests'
        option device 'radio0'
        option mode 'ap'
        option network 'GuestNetwork'
        option key 'password'
        option ssid 'LoewenNetGuests'
        option encryption 'psk2'

config wifi-iface 'LoewenNetIoT'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'ap'
        option network 'SmartHome'
        option key 'password'
        option ssid 'Loewennetiot'

config wifi-iface 'mesh0'
        option device 'radio0'
        option ifname 'mesh0'
        option network 'nwi_mesh0'
        option mode 'mesh'
        option mesh_fwding '0'
        option mesh_id 'LoewenNetMesh'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:01.0/0000:02:00.0'
        option htmode 'VHT80'
        option country 'CH'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option key 'password'
        option ssid 'LoewenNet5G'

config wifi-iface 'LoewenNetGuests5G'
        option encryption 'psk2'
        option device 'radio1'
        option mode 'ap'
        option network 'GuestNetwork'
        option key 'password'
        option ssid 'LoewenNetGuests5G'

config wifi-iface 'LoewenNetIoT5G'
        option encryption 'psk2'
        option device 'radio1'
        option mode 'ap'
        option network 'SmartHome'
        option key 'password'
        option ssid 'Loewennetiot5G'
root@MeshPoint01:/# batctl if
mesh0: active
root@MeshPoint01:/# batctl o
[B.A.T.M.A.N. adv 2020.0-openwrt-1, MainIF/MAC: mesh0/74:da:88:4f:c7:5b (bat0/3a:58:47:8b:cd:b1 BATMAN_IV)]
   Originator        last-seen (#/255) Nexthop           [outgoingIF]
 * 54:83:3a:70:21:84    0.310s   (247) 54:83:3a:70:21:84 [     mesh0]
root@MeshPoint01:/# batctl n
[B.A.T.M.A.N. adv 2020.0-openwrt-1, MainIF/MAC: mesh0/74:da:88:4f:c7:5b (bat0/3a:58:47:8b:cd:b1 BATMAN_IV)]
IF             Neighbor              last-seen
        mesh0     54:83:3a:70:21:84    0.370s

From Client A I can access the Meshpoint, AccessRouter, Web Server and also the Internet with good performances.
From Client B I can access the MeshPoint, AccessRouter and the WEB server with good performances. Access to the Internet works with poor performance.
From the meshpoint a ping downloads.openwrt.org -s 1472 works

root@MeshPoint01:/# ping downloads.openwrt.org -s 1472
PING downloads.openwrt.org (176.9.48.73): 1472 data bytes
1480 bytes from 176.9.48.73: seq=0 ttl=55 time=26.987 ms
1480 bytes from 176.9.48.73: seq=1 ttl=55 time=24.683 ms
--- downloads.openwrt.org ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max = 24.683/25.835/26.987 ms

A ping downloads.openwrt.org -s 1500 does not work.

root@MeshPoint01:/# ping downloads.openwrt.org -s 1500
PING downloads.openwrt.org (176.9.48.73): 1500 data bytes
--- downloads.openwrt.org ping statistics ---
6 packets transmitted, 0 packets received, 100% packet loss	

The same from the Access Router:

root@AccessRouter:/# ping downloads.openwrt.org -s 1472
PING downloads.openwrt.org (176.9.48.73): 1472 data bytes
1480 bytes from 176.9.48.73: seq=0 ttl=56 time=22.169 ms
1480 bytes from 176.9.48.73: seq=1 ttl=56 time=22.065 ms
1480 bytes from 176.9.48.73: seq=2 ttl=56 time=22.223 ms
--- downloads.openwrt.org ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 22.065/22.152/22.223 ms

and 1500 or greater

root@AccessRouter:/# ping downloads.openwrt.org -s 1500
PING downloads.openwrt.org (176.9.48.73): 1500 data bytes
1508 bytes from 176.9.48.73: seq=0 ttl=56 time=21.834 ms
1508 bytes from 176.9.48.73: seq=1 ttl=56 time=22.171 ms
1508 bytes from 176.9.48.73: seq=2 ttl=56 time=22.233 ms
--- downloads.openwrt.org ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 21.834/22.079/22.233 ms

Adjusting the MTU on the Wan Interface brought no improvement.

Thanks for your help!
Michael