no, in order to support 320 you would have to have
(5945 - 6425 @ 320), (N/A, 23), (N/A), NO-OUTDOOR
Still my phone does not connect, it's a dhcp issue. I tried using openwrt's own dhcp server and turning it off and using the main dhcp server, but nothing works. Even tough i have bridged the wifi interfaces to the lan bridge. This used to work weeks ago, but not now.
Small issue, the cpu fan is starting and stopping all the time.
EDIT: Please discard my previous edit. dhcp packets never arrive at the main dhcp server. Any ideas why? Interfaces are supposed to be bridged, but are not.
.
.
.
.
why do you bridge something? It works good with external dhcp and dns server
Ok, i took the wifi interfaces out of bridge, same result.
In case this matters, i'm running OpenWrt 24.10-SNAPSHOT r28046-7ef734deac / LuCI openwrt-24.10 branch 24.330.73959~fefb9ac
rmandrad's image was not working properly.
Hi folks! Just joining the conversation! I'm more of a user than a dev on this one tho
I was browsing to find answers on how to configure proper bridges, namely how to assign ra#, rai# and rax# to a specific interface as i'm creating a guest and IOT zone for their own isolated zones. Seems like there's no dedicated function in the MTK wifi configuration tool and any changes using the built in wifi manager (Network->Wireless) breaks the MTK. I'm on the 21 MTK snapshot (from 20240620)
Did all of you guys move to a newer (24) build? (maybe the latest branch from @rmandrad ?)
Thanks
My current set-up:
EDIT:
my current firmware version : OpenWrt 21.02-SNAPSHOT unknown / LuCI openwrt-21.02 branch git-23.093.57360-e98243e
There's yet another one from MediaTek: https://git01.mediatek.com/plugins/gitiles/openwrt/feeds/mtk-openwrt-feeds/+/bd3fff67787c80cd2ebfc7ea45c95fc82ee07e73
that's the Banana stock firmware, it got nothing to do with openwrt.
ask your vendor, or install proper openwrt.
I'll try my luck with the latest one from MediaTek, Master branch, and by making my current "stock firmware" self-hosting. Would that be considered as proper OpenWRT or am I missing something?
https://firmware-selector.openwrt.org/?version=SNAPSHOT&target=mediatek%2Ffilogic&id=bananapi_bpi-r4
Thanks, that is the exact image I believe I had. Not sure about the innerworkings of the sysupgrade, but it's what I should be running. I'll still try my luck with this morning's commit, leaving 21.02 for 23.x
Thanks for the insight
There seems to be an issue with the wireless device when doing a "warm reboot", aka using the reboot
command in OpenWrt.
It doesn't seem to properly reset the Wi-Fi NIC and it then doesn't appear in dmesg
. Resulting in missing wifi devices.
People have mentioned this in September already. I had this issue just right now after doing some testing.
I would like to ask if anyone has encountered this issue. I am currently using the danpawlik version from the following link: https://github.com/danpawlik/openwrt-builder/releases. The BPI-R4 cannot modify the Radio Mode (11n, 11ac, 11ax, 11be) and MCS index. How should I address this problem?
uci set wireless.radio0.htmode='ht20'
iw dev sta01 set bitrates ht-mcs-2.4 0 lgi-2.4
After making the modifications, it still remains locked in EHT Mode. Although the network shows as connected, it is actually disconnected.
have you tried to change /etc/config/wireless instead ? also, I assume after your uci set you have done an uci commit ...yes?
Yes, I have executed uci commit&wifi reload and confirmed that the settings in /etc/config/wireless have been modified. I will first take 2.4G as an example (the 5G has been tested as well)
It seems that when connecting to a Wi-Fi 7 AP in Station mode, it can only connect using BE mode. I am unable to try connecting using N, AC, or AX modes.
If there are any issues with the method I provided, please let me know, and I will provide additional information
N Mode
config wifi-device 'radio0'
option type 'mac80211'
option path 'soc/11300000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
option radio '0'
option band '2g'
option channel 'auto'
option htmode 'HT20'
option cell_density '0'
config wifi-iface 'wifinet'
option device 'radio0'
option mode 'sta'
option network 'sta01'
option ifname 'sta01'
option ssid 'BBF_Wi-Fi_Perf_Test'
option encryption 'psk2'
option key '11111111'
root@OpenWrt:~# iwinfo sta01 assoclist
A2:9C:25:A0:9A:81 -14 dBm / -72 dBm (SNR 58) 4000 ms ago
RX: 292.4 MBit/s, EHT-MCS 12, 20MHz, EHT-NSS 2, EHT-GI 1 51114 Pkts.
TX: 344.1 MBit/s, EHT-MCS 13, 20MHz, EHT-NSS 2, EHT-GI 0 307665 Pkts.
AC Mode
config wifi-device 'radio0'
option type 'mac80211'
option path 'soc/11300000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
option radio '0'
option band '2g'
option channel 'auto'
option htmode 'VHT20'
option cell_density '0'
config wifi-iface 'wifinet'
option device 'radio0'
option mode 'sta'
option network 'sta01'
option ifname 'sta01'
option ssid 'BBF_Wi-Fi_Perf_Test'
option encryption 'psk2'
option key '11111111'
root@OpenWrt:~# iwinfo sta01 assoclist
A2:9C:25:A0:9A:81 -14 dBm / -76 dBm (SNR 62) 830 ms ago
RX: 286.7 MBit/s, EHT-MCS 11, 20MHz, EHT-NSS 2, EHT-GI 0 59788 Pkts.
TX: 309.6 MBit/s, EHT-MCS 12, 20MHz, EHT-NSS 2, EHT-GI 0 345930 Pkts.
have you tried using the latest snapshot ? reason I don't see the latest change that uses "option radio <0-2>" ?
also feel free to test any of my images - https://github.com/rmandrad/openwrt-images
Since the test results for 2.4G and 5G are the same, I only posted the information for Radio0. I saw the image you provided, and I will give it a try.
config wifi-device 'radio0'
option type 'mac80211'
option path 'soc/11300000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
option radio '0'
option band '2g'
option channel 'auto'
option htmode 'VHT20'
option cell_density '0'
config wifi-device 'radio1'
option type 'mac80211'
option path 'soc/11300000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
option radio '1'
option band '5g'
option channel '36'
option htmode 'EHT160'
config wifi-device 'radio2'
option type 'mac80211'
option path 'soc/11300000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
option radio '2'
option band '6g'
option channel 'auto'
option htmode 'EHT320'
config wifi-iface 'wifinet'
option device 'radio0'
option mode 'sta'
option network 'sta01'
option ifname 'sta01'
option ssid 'BBF_Wi-Fi_Perf_Test'
option encryption 'psk2'
option key '11111111'
this is my /etc/config/wireless if it helps - i don't see you are setting up the country also i suspect the underlying issue maybe the mac80211/hostpad scripts
config wifi-device 'radio0'
option type 'mac80211'
option path 'soc/11300000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
option radio 0
option htmode 'HE40'
option country 'GB'
option band '2g'
option channel '6'
option log_level '0'
option cell_density '3'
option doth '1'
list hostapd_options 'rnr=1'
list hostapd_options 'mld_ap=0'
option noscan '1'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'love'
option encryption 'sae-mixed'
option mbo '0'
option key 'xxx'
option ocv '1'
option ieee80211r '1'
option ft_over_ds '0'
option pmk_r1_push '1'
option ieee80211k '1'
option time_advertisement '2'
option time_zone 'GMT0BST,M3.5.0/1,M10.5.0'
option wnm_sleep_mode '1'
option wnm_sleep_mode_no_keys '1'
option bss_transition '1'
option proxy_arp '1'
config wifi-device 'radio1'
option type 'mac80211'
option path 'soc/11300000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
option radio 1
option htmode 'HE160'
option channel '100'
option country 'GB'
option band '5g'
option log_level '0'
option background_radar '1'
option cell_density '3'
option doth '1'
list hostapd_options 'rnr=1'
list hostapd_options 'mld_ap=0'
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'love'
option encryption 'sae-mixed'
option mbo '0'
option key 'xxx'
option ocv '1'
option ieee80211r '1'
option ft_over_ds '0'
option pmk_r1_push '1'
option ieee80211k '1'
option time_advertisement '2'
option time_zone 'GMT0BST,M3.5.0/1,M10.5.0'
option wnm_sleep_mode '1'
option wnm_sleep_mode_no_keys '1'
option bss_transition '1'
option proxy_arp '1'
config wifi-device 'radio2'
option type 'mac80211'
option path 'soc/11300000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
option radio 2
option band '6g'
option channel '53'
option htmode 'EHT320'
option country 'GB'
option log_level '0'
option background_radar '0'
option cell_density '3'
option doth '0'
list hostapd_options 'unsol_bcast_probe_resp_interval=20'
list hostapd_options 'mld_ap=0'
option disabled '0'
config wifi-iface 'default_radio2'
option device 'radio2'
option network 'lan'
option mode 'ap'
option ssid 'love'
option beacon_prot '1'
option encryption 'sae'
option sae_pwe '2'
option key 'xx'
option ieee80211w '2'
option mbo '1'
option ocv '0'
option ieee80211r '1'
option ft_over_ds '0'
option ieee80211k '1'
option time_advertisement '2'
option time_zone 'GMT0BST,M3.5.0/1,M10.5.0'
option wnm_sleep_mode '1'
option wnm_sleep_mode_no_keys '1'
option bss_transition '1'
option pmk_r1_push '1'
option proxy_arp '1'
option disabled '0'
BPI-R4 has been repeatedly tested so far.
It only works properly in AP mode;
it does not function in sta mode , STA mode will still connect according to the highest mode of the AP
I may need to use another device to confirm.
root@OpenWrt:~# cat /etc/os-release
NAME="mda-bananapi4-main-openwrt"
VERSION="6.6.63-12"
ID="mda-bananapi4-main-openwrt"
ID_LIKE="lede openwrt"
PRETTY_NAME="mda-bananapi4-main-openwrt 6.6.63-12"
VERSION_ID="6.6.63-12"
HOME_URL="https://openwrt.org/"
BUG_URL="https://bugs.openwrt.org/"
SUPPORT_URL="https://forum.openwrt.org/"
BUILD_ID="r28268-d4d161b8f3"
OPENWRT_BOARD="mediatek/filogic"
OPENWRT_ARCH="aarch64_cortex-a53"
OPENWRT_TAINTS="no-all busybox"
OPENWRT_DEVICE_MANUFACTURER="OpenWrt"
OPENWRT_DEVICE_MANUFACTURER_URL="https://openwrt.org/"
OPENWRT_DEVICE_PRODUCT="Generic"
OPENWRT_DEVICE_REVISION="v0"
OPENWRT_RELEASE="mda-bananapi4-main-openwrt 6.6.63-12 r28268-d4d161b8f3"
OPENWRT_BUILD_DATE="1733200739"
root@OpenWrt:~# cat /etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option path 'soc/11300000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
option radio '0'
option htmode 'HT20'
option country 'GB'
option band '2g'
option channel 'auto'
option log_level '0'
option cell_density '3'
option doth '1'
list hostapd_options 'rnr=1'
list hostapd_options 'mld_ap=0'
option noscan '1'
config wifi-device 'radio1'
option type 'mac80211'
option path 'soc/11300000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
option radio '1'
option htmode 'HE160'
option channel '100'
option country 'GB'
option band '5g'
option log_level '0'
option background_radar '1'
option cell_density '3'
option doth '1'
list hostapd_options 'rnr=1'
list hostapd_options 'mld_ap=0'
config wifi-device 'radio2'
option type 'mac80211'
option path 'soc/11300000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
option radio '2'
option band '6g'
option channel '53'
option htmode 'EHT320'
option country 'GB'
option log_level '0'
option background_radar '0'
option cell_density '3'
option doth '0'
list hostapd_options 'unsol_bcast_probe_resp_interval=20'
list hostapd_options 'mld_ap=0'
option disabled '0'
config wifi-iface 'wifinet'
option device 'radio0'
option mode 'sta'
option ifname 'sta01'
option ssid 'BBF_Wi-Fi_Perf_Test'
option encryption 'psk2'
option key '11111111'
root@OpenWrt:~# iwinfo sta01 assoclist
A2:9C:25:A0:9A:81 -19 dBm / -74 dBm (SNR 55) 8104 ms ago
RX: 344.1 MBit/s, EHT-MCS 13, 20MHz, EHT-NSS 2, EHT-GI 0 8057 Pkts.
TX: 344.1 MBit/s, EHT-MCS 13, 20MHz, EHT-NSS 2, EHT-GI 0 67 Pkts.
expected throughput: unknown
@rmandrad I've booted your last build the (3 december morning one) and it works perfectly, i can top 2Gbps in/out from my laptop with a Qualcomm wifi7 card The latest 24.10 snapshot was not so good, do you know if your changes will be merged soon on the mainline/24.10 branch ?
that actually look good using EHT-MCS 13! or can be an iwinfo issue
let me try a test on my side against another router (qnap-301w ax mode). I get the following
iwinfo phy0.0-sta0 assoclist
xxxxxxxxx -21 dBm / -76 dBm (SNR 55) 26799 ms ago
RX: 24.0 MBit/s 1 Pkts.
TX: 24.0 MBit/s 33 Pkts.
expected throughput: unknown
this is the wireless config
config wifi-iface 'wifinet3'
option device 'radio0'
option mode 'sta'
option ssid 'love'
option encryption 'sae-mixed'
option key 'xxxxx!.'
option ocv '0'
option network 'wan'