Bad latency and slow speed only on upload for 5GHz wrt3200acm - solved

Update - after installing the davidc502 snapshot over the weekend and dialing in wifi channels again (neighbors keep changing things!), I'm getting good performance on all my devices now. Unfortuantely, I can't really say whether it was the drivers and new version of firmware, or the monkeying around with channels, but I suspect the firmware and drivers since previously, the issue seemed limited to my android tablet only, and if it was interference all devices should have been bad. There seem to be some small issues with the davidc502 snapshot, e.g. changing the LAN interface IP address doesn't 'stick' unless I do it by updating the conf/network file, but in general it works well and the new drivers allow more info to be pulled from the wifi radios - e.g. I can now see an accurate report of link speed.

So I'm having some performance issues with a wrt3200acm I'm using as a bridge over 2.4 and also running an AP on 5ghz to provide coverage for the far end of my house. I find that regardless of how I tweak the 5ghz wifi settings for channel or width I often have terrible upload performance from some devices. As in muktisecond latency and kbps throughput. It's mostly on mobile devices, my laptop NIC doesn't seem to have these issues. I'm using the 2.4 band as a client bridge to my Google fiber AP and bridging using relayd to the Lan interface where I have one Ethernet client PC and am also running the 5 ghz as a regular AP.

Toggling wifi on and off on the device, eg my galaxy tab s2 8.0, will typically resolve the issue but only for a couple minutes then the poor performance on upload returns. Download speeds seem OK.

Anyone seen something like this? Oh, and I seem to be running the latest release version of lede 17.01.4.


Try to update the wifi drivers here: Pre-compiled updated mwlwifi drivers for stable releases

OK, you think it might help even if I'm on 17.01.4 which in theory has relatively 'new' drivers for the wifi chip? Is the newest release stable on 17.01.4 as far as you know?

If so, is the procedure to install from the LEDE command line still to wget the file then run opkg install with force downgrade option?

These drivers are still under development, and several improvements where released after 17.01.4; besides, there is no harm in updating...

Yes, I am afraid that the update procedure is still that one.

Just out of curiosity why are you running Lede still? It's quite outdated at this point. 18.06 is still a few weeks from release but you should try rc1 or davidc502's built off master that includes the latest wifi drivers:

No good reason. Basically it appeared to be the newest openwrt sort of firmware for the device that was a stable build. I'm OK to run something else so long as it's not riddled with bugs. I need to actually use the AP and my wife will get pissed if it's down all the time lol.

Install perf on the AP and run it against something connected over ethernet to the Google router. I wonder if your backhaul link isn't the greatest.

Do you need the second firewall/relayd?
I made an AP similar to yours to extend my wifi but I just have both the STA and AP radio joined to lan. I just needed more wifi not a layered network.

config wifi-iface
	option device	radio0
	option network	lan
	option mode	sta
	option wds	1

config wifi-iface
	option device	radio1
	option network	lan
	option mode	ap

And FORWARD set to accept in the firewall

config zone
	option name		lan
	list   network		'lan'
#	list   network		'wwan'	# relayd client
	option input		ACCEPT
	option output		ACCEPT
#	option forward		ACCEPT	# relayd client
	option forward		ACCEPT	# masqueraded (firewalled) client

This adds like 1-1.5ms latency for me, but I'm only going like 35 feet/20 metres. My back haul link is strong and stable.

Sorry, let me see if I follow you - you're saying check performance at the google router and the one running lede to determine if the bottleneck is at the link (currently 2.4 radio) between the repeater AP and the google router? I always get wicked good performance on the google router via ethernet, 8ms ping and depending on the server I'm hitting I've seen 850mbps speeds. Performance on my PC that's on ethernet to the LEDE rounter (i.e. running over 2.4 link to reach the google router but not over wifi otherwise) runs reliably, not impressive but ping stays below 100ms most of the time and ~30mpbs up/down, which is about what one might expect given it's a long distance in a very busy 2.4 band (lots of APs in the neighborhood).

That said, your idea of ditching relayd might be fine, I'm only using it b/c what I read seemed to indicate it was required to configure a wrt3200acm as a relay/bridge because traffic on the LAN network won't otherwise get routed to the wifi interface that's set up as client. What does your alternative setup look like in LUCI? Just setup 2.4 radio as client, 5ghz as AP, and have them both on "LAN" by checking that box in the "network" options?

Just to be clear, the issue I'm having it horrible performance on an android tablet and sometimes on my wife's iphone8+, other devices seem OK, but I have kpbs upload speeds and ~1-2second ping on those mobile devices - but not all the time, probably 75% of the time but sometimes they seem to run OK. My tablet acts fine if I hit the main google AP wifi though. So whatever is occurring seems unique the the tablet and iphone, but both work fine on other wifi APs. I think the issue is worse on the android device though, wifi to the repeater AP basically works like garbage all the time. My point being, I'm not trying to refine an issue of slightly less than a theoretical maximum speed, it's working very, very poorly on some mobile devices, so seems to be something fundamental.

The 5ghz channel space is clear nearby where I'm running the repeater's signal, and I've tried a couple channels just to be sure, that doesn't seem to be the issue. And the 2.4 link seems OK because the PC I have wired to the LEDE router gets decent performance and decent latency.

Regarding the suggestion to install the david502 build, do I just install it on top of the LEDE already on there? Seems reasonable to get the new wifi drivers regardless.

Thanks for the tips and sorry I'm not much of a networking expert, so I appreciate all the help.

I don't install LUCI, but that sounds about right.

If that's true RIP

These are THE WORST kinds of problems to debug.

Perf works by testing between a client and server. I saying to start a server on a pc connected over ethernet to the main router, and then run the client on the wrt3200acm or maybe a pc connected over ethernet to the wrt3200acm.

I feel you, I've noticed significantly less performance on my WRT32X too going from stock Linksys firmware to OpenWrt 18.06 which uses mwlwifi. I honestly think Linksys puts little to no effort into open source, nor does anyone else right now. The driver doesn't support mesh or mu-mimu either. Sorry I can't be of any help just wanted to second this issue.

Thanks, I'll check out running perf. If there's a windows version I can run it on a big PC that's on ethernet to the main router. Otherwise, if it's linux only, I only have a 100mpbs R Pi 3, but maybe OK to just inspect the overall quality of that link over time, even if it's not capable of massive speeds, I just want to know it works at a steady 30+ mpbs.

Also, this is probably overkill, but I picked up an RF Explorer Wifi combo just to have it. I've always been tempted to get one and am sick of not really being able to properly 'see' what's going on in my frequency space. For all I know there's interference somewhere. I do notice that listening to HF (shortwave) radio, there's soem serious noise on my block. I sort of suspect maybe some grow light ballasts freaking out. There's a house a couple doors down where it tends to smell a bit 'green' when you walk by, if you follow.

Phinn - yeah it's too bad. I bought it thinking yeah for sure this will be one of the best devices for open source firmware, several folks on reddit seem to think so at least. And it's got all the features I wanted (and then some). I was looking at the Archer C7 too, but it seems there's not a reliable way to get one of the 'old' ones with a supported chipset and I didn't want to roll the dice with an amazon buy.

I'll upgrade to the newer version this weekend though while the wife is at her friend's and won't miss having the bridge running to the downstairs HTPC system. What I need to do is just run some cat6, but the way our house is setup it's not a trivial task unfortunately.

The Open Source driver is still under heavy development and hopefully one day it will run great.
For example there is a TX problem with Intel 8260 adapters and these adapters are build into many up-to-date Notebooks...
I also think that Linksys/Belkin doesn't put much effort into the open source driver, which is quite sad! :confused:

Updated posted at the top. Things seem to be working well now after changing a few things and installing a davidc502 snapshot.

1 Like

Glad to see this resolved, davidc502 with the latest drivers and all work well on my WRT32X. Performance is a bit below the stock firmware, but that's unfortunately normal for OpenWrt because of driver support.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.