Bad address 'openwrt.org

Hello everyone, I come back to you with a problem, my three access points are working correctly, they distribute the wifi well, I manage to connect from the outside but when I do a diagnostic I have a message 'ping error: bad address' openwrt.org', on the other hand I can ping 8.8.8.8. I attach my files to you. Thanking you in advance for your help.

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd5c:648d:f739::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option delegate '0'
	option ipaddr '192.168.0.2'
	option gateway '192.168.0.254'
	option ifname 'bat0 eth1.1'
	option stp '1'
	list dns '192.168.0.254'
	list dns '208.67.222.222'
	list dns '208.67.222.220'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 0t'

config interface 'WAN'
	option ifname 'eth1.1'
	option proto 'none'
	option delegate '0'

config interface 'bat0'
	option proto 'batadv'
	option routing_algo 'BATMAN_IV'
	option aggregated_ogms '1'
	option ap_isolation '0'
	option bonding '0'
	option fragmentation '1'
	option gw_mode 'off'
	option log_level '0'
	option orig_interval '1000'
	option bridge_loop_avoidance '1'
	option distributed_arp_table '1'
	option multicast_mode '1'
	option network_coding '0'
	option hop_penalty '30'
	option isolation_mark '0x00000000/0x00000000'

config interface 'nwi_mesh0'
	option mtu '2304'
	option proto 'batadv_hardif'
	option master 'bat0'

2020-11-29_175233

2020-11-29_180123

2020-11-29_175949

2020-11-29_175902

2020-11-29_175828

2020-11-29_175753

Your DNS is wonky. What does the following show?

# nslookup openwrt.org

Thanks for your help. Here is the answer :

2020-11-29_211506

I'm not sure if list is the way to go to specify DNS servers. Looks like neither of your DNS servers is being found by nslookup. That's pretty weird, given you're specifying three of them.

If you call one of the DNS servers, like below e.g., does it work?

nslookup openwrt.org 192.168.0.254

If so, then try using option instead of list:

option dns '192.168.0.254,208.67.222.222,208.67.222.220'

2020-11-30_082255

I modified the line as you suggested to me but it did not change anything.

At least the DNS server works. Weird that neither list nor option seems to work. I assume just specifying option dns '192.168.0.254 does work?

I have already tried deleting the other two DNS servers but it doesn't work either.

I found the solution to my problem, I had to deactivate dnsmasq.

2 Likes

Glad you solved it. In the future, please consider copy/pasting your output instead of using screenshots, those are not searchable, unlike full text.

2 Likes

Thank you very much I take note of your remarks;)

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.