Backfire 10.03 factory reset procedure

I have an old Netgear DG834Gv2 router with Backfire 10.03 installed.
The password is lost.
The standard procedure of holding down the reset button for 10 sec does not seem to work.

Is it possible that in early Openwrt versions the factory reset procedure was different?

Can anyone remember how to reset Backfire to factory settings?

Given the limitation of this device (4MB flash, 16MB RAM), this is a perfect time to e-cycle the device and get something that can support a modern version of OpenWrt. It is unwise to use any old versions, especially a 12 year old firmware that has numerous security issues.


The information required is clearly stated on the subject line.
Thanks for your input though.

1 Like

Yes, I understand what you're asking... but 3 things:

  1. Backfire is unsupported and has been for ~10 years
  2. It is unlikely that anyone will remember the reset procedures for a version that is more than a decade old
  3. There is a general consensus by the frequent contributors and admins that the use of old versions (especially ancient versions) should be discouraged due to the security considerations as they can have significant impacts on the users/networks to which they are connected and can even indirectly impact other users on the internet if a device is easily compromised. That's in addition to reasons relating to the above 2 points).

You may choose to disregard these concerns and recommendations, if you like. However, it is also stated for future readers who may see this thread -- they should also be made aware of the same concerns/considerations.


Please cease contaminating this thread.

I am hoping for some valuable input Re: Backfire 10.03 factory reset procedure.

1 Like

This is not 'contamination' since it is important and valid information regarding the use of extremely old firmware. Consider that this is like safety recommendations and regulations.... a baby car seat from 40 years ago would not be used today for obvious reasons. Your device on Backfire is a similar situation.

1 Like

Allow to boot fully, then hold down the reset button.

There were some models where the reset button was not supported. In that case you'd need to log into OpenWrt with serial, or use the bootloader brick recovery process if any exists.


I think that the current reset button logic was programme€d in 2013.
Later than Backfire.
(Before that there has apparently been mode device/target specific low-level coding for reset button functionality, but that has been sporadic)

But the failsafe mode should be there, if I remember right.


Best information about the reset possibilities are likely on the device wiki page...

1 Like

A good point about the reset button, seems to be my case.

All good pointers, thank you. Tried them all now but no luck. Will solder a serial connector now, this should do the job.

Have you tried to access old versions of the wiki using the Wayback machine?

1 Like

does the reset button work at all? maybe there is a mechanical defect?

1 Like

Ok, here is an update:
Soldered a pin header onto the board, got in through a serial console and reset the password. All is good.
But now that I could see what is happening on the console I decided to check why I could not get into a "failsafe" mode in the first place via the standard reset button procedure.
1/ the reset button is functional because the bootloader reacts to it and goes into some "copying" mode when it is held down during the power up.
2/ it is possible to get into a failsafe mode by pressing F on the serial console when prompted during the boot up.
3/ The catch is that while the router in the failsafe mode - the eth0 interface is not up and not configured!!!
So even if I managed to get into a failsafe mode by pressing the reset button somehow, I still would not be able to access the box via ssh or telnet over ethernet!!!

It was an interesting quest but all is good now and this veteran hardware will be put to good use in my project.

Thanks again, gentlemen, for your constructive input.


Just for the record - that's what it looked like in those days :slight_smile:

NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <>
All bugs added by David S. Miller <>
VFS: Mounted root (squashfs filesystem) readonly on device 31:3.
Freeing unused kernel memory: 136k freed
Please be patient, while OpenWrt loads ...
- preinit -
Press the [f] key and hit [enter] to enter failsafe mode
- failsafe -

BusyBox v1.15.3 (2010-04-06 03:13:44 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 Backfire (10.03, r20728) --------------------------
  * 1/3 shot Kahlua    In a shot glass, layer Kahlua 
  * 1/3 shot Bailey's  on the bottom, then Bailey's, 
  * 1/3 shot Vodka     then Vodka.
1 Like

Some nice Archaeology! Pleas don't put this old router on the internet. Not if you want to keep anything safe. If it is just for a robot or something then have at it.

1 Like

Could you please all stop with your mentra of insecurity? We have heard you the first time. The default is that most connections from wan are blocked anyway so what the hell do you think should happen anyway. The person seams to have a reason to run this device as it is.

That was a different person BTW.

There are UDP vulnerabilities, WiFi vulnerabilities, DNS vulnerability, etc.

Basically, most of the vulnerabilities discovered would not need an exposed WAN to exploit - they merely need the bad (old) software running on that antiquated version.

(No need to tell me to stop, I was just answering you.)

1 Like

The same argument does not mature better if 5 person repeat it.
And yes you are so right the person is just screwed by running this device because north Korean hackers are just everywhere and have just waited for such a high stake target. /s
Of course such a device should be replaced if running somewhere were it matters but all of you have practical zero insight in what context this device is running so the unreflected "but we will all die" is just noise.

Not true. See:

Correct. No need to be rude, though.

Perhaps you shouldn't have asked, which is why I asked that you not say stop. I thank you; but didn't expect the rudeness, though. You asked what could occur with WAN closed by default - then you suggest some extraordinarily special use case.

So I highlighted mine as well.

Actuall,y there's bots/scanners/malware that scan and try public IPs 24/7/365.

Honesty, these exploits on old firmware are n00b-script-level, not state-actor level (it seems you're trying to imply the the notion is far-fetched by mentioning N. Kor.