Back to stock firmware WRT3200ACM

Hello everyone, I'm trying in all the ways to return to the firmware stock but I can not, can you help me? I tried the procedure via ssh but it does not work, I can not install the firmware.

Which procedure ?

Just follow the advice to use "-F" switch with sysupgrade to force the flash.

Advice can be found on forum:

I did exactly as you wrote me these errors, look at the picture

That looks like it worked, what was the result? Remember there are two partitions.

I restarted but does not open the stock firmware but always openwrt. Honestly, I do not know how to use the two partitions, I would like all the stock to come back

what version of owrt is currently running?

Version 18.06.2

I'm not aware of any bugs in that version which would stop you from forcing the OEM; but there have been occurrences. You could try just flashing some other version of owrt, repeat the above, to see if it will let you off.

so i advise you to install a less recent version of the firmware?

You could try 18.06.1, or snapshot, does not really matter.

where do I download the least recent version?


ok, I try to install the previous version. Thanks



I just tested with my WRT3200ACM running the 18.06 snapshot r7693-62feabecd8 (which is 18.06.2 + newer kernel etc.). As you can see from the commit log, there has not been anything mvebu or sysupgrade specific since the 18.06.2 release, so there should be no difference in the sysupgrade behaviour:;a=shortlog;h=62feabecd8a84cfe0d6a5aa3bad2720dbf328370

Flashing the Linksys stock firmware works quite as expected:

 OpenWrt 18.06-SNAPSHOT, r7693-62feabecd8

root@router3:/#  cd /tmp
root@router3:/tmp#  wget
--2019-02-17 11:34:32--
2019-02-17 11:34:38 (7.93 MB/s) - 'FW_WRT3200ACM_1.0.6.186168_prod.img.1' saved [42467584/42467584]

root@router3:/tmp#  sysupgrade -F -n /tmp/FW_WRT3200ACM_1.0.6.186168_prod.img
Image metadata not found
Image check 'fwtool_check_image' failed but --force given - will update anyway!
Commencing upgrade. Closing all shell sessions.

The router flashed the firmware ok and after the boot, the Linksys GUI was ready at

Note My router is normally a dumb AP and was not connected to internet during the flash, so after the flash it kept flashing an orange LED, but the router had booted quite ok and the Linksys GUI was there. There was no need to separately reboot the device after the flash.

If that does not work for you, there is probably something weird going on in your system.
You might e.g. reset all Openwrt settings first (with "firstboot"), or you might flash an older version like anomeome suggested (and do it without saving settings, which does the same as "firstboot" would do).

Or maybe the download somehow failed?
The checksum should be:

root@router3:/tmp#  sha256sum /tmp/FW_WRT3200ACM_1.0.6.186168_prod.img

You can check from the SSH console which versions are installed.

For example, my router's primary partition mtd5 has the currently running Openwrt, while the other partition mtd7 has now the Linksys stock firmware:

root@router3:~# dd if=/dev/mtd5 bs=1 skip=32 count=25 2>/dev/null
ARM OpenWrt Linux-4.14.99

root@router3:~# dd if=/dev/mtd7 bs=1 skip=32 count=25 2>/dev/null
Linksys WRT3200 Router

Note that luci-app-advanced-reboot app will show that in a user-friendly fashion.

Why in the hell would any one want to flash back to stock anyway? Stock fermwair is a clusterfuck!

I managed to restart the router nice partition 2 but I can not get into the web interface, it seems that there is nothing installed, how do I install the firmware on partition 2?

I think that stock is at and OpenWrt is at To get Stock on both parts of the flash you would have to flash it twice in a row. First flash would boot on flash 1 and rite the new fermwair to flash part 2 and then reboot in to flash 2 and flash to part 1. Why don't you just stick with OpenWrt?

You simply flash from the current partition to get a new firmware to the other partition.

Both OpenWrt and Linksys stock firmware always flash the other partition and then change booting into that partition (while the current one stays as the fall-back option). This happens in a round-robin fashion. first start using 1, new firmware gets flashed to 2 and booting switches to 2, and next time the flash (from 2) goes into 1 and booting changes back to 1. and so on.

if I boot the drive partition there is openwrt and try to install the stock firmware I do not need to install it

That last post didn't make sense to me. What did you want to do? Stock on both partitions? Stock on one, and OpenWrt on the other?

Whatever you want, you must boot from the OPPOSITE partition to flash because neither firmware will overwrite the CURRENT partition.