Back to Stock Factory Firmware Linksys E4200 V2? OpenWrt FW to Linksys FW

Hi, been trying to find this out and can't seem to find anything... i guess solid enough for me, and if i did... some of it wasn't well explained, at least not in a way those who've NEVER used openwrt before like me lol.
anyways. only things I've gathered was i found the firmware file for my router(FW_E4200v2_2.1.41.164606.bin) and tried flashing it with WinSCP after copying the file to the tmp folder using this command after renaming the file(mtd -r write /tmp/firmware.bin firmware)and got errors as soon as i hit enter and many were saying you have to use the force command for it. but i was iffy of doing that and wanted to make sure if that's what i'm suppose to be doing and typing the right command for that(mtd -r -f write /tmp/firmware.bin firmware) but i also noticed on some routers your suppose to be "Stripping" the firmware? unsure how to go about that if i have to also, as i don't want to brick the router.
also openwrt version is...
Powered by LuCI openwrt-18.06 branch (git-18.228.31946-f64b152)(https://github.com/openwrt/luci) / OpenWrt 18.06.1 r7258-5eb055306f
and no, i can't do the Partition Switch since i didn't know doing the update openwrt was going to overwrite the other partition instead of the one i was using openwrt on so both have openwrt, one is 18.06.1 the other is 18.06.2. hence why i'm trying to get one partition or all of it back to factory.

Stating the obvious here, did you try reverting to stock form LuCI, as per https://openwrt.org/toh/linksys/ea4500

According to the device wiki page you should be able to sysupgrade (possibly needing -F) the official firmware image (after unzipping it of course).

Installing firmware by the direct use of mtd is not recommended, especially on a NAND flash.

not sure what you mean by that as i know nothing with openwrt hence why i was being specific. did get the factory firmware there though.

how would i go about that? remember, i know nothing of openwrt... am i suppose to be going to system>system software? i literally don't mess with this stuff anymore. use to like 10 years ago but never messed with in a long time.. no idea where i'm suppose to be going or doing these commands at or on. did read a lot of that but to my eye's... i literally didn't know what it was talking about lol. why the easiest thing i found was using the WinSCP thing.

Presuming your router is on 192.168.1.1
http://192.168.1.1/cgi-bin/luci/admin/system/flashops
From there you can flash the stock firmware (for which you can find a link in https://openwrt.org/toh/linksys/ea4500).

That's as per the page, but I claim no knowledge of this router.

yeah i did try that for the very first thing before i even went into searching about it but it came up with needing a specific "upgrade" file which only had openwrt files for but not the factory firmware then said the file type was also wrong or something. from then on out has been where i was boggled lol. i also used the " Flash new firmware image" part since the rest of the stuff in there is for backup and restore configuration files.

ok, just did it again so i could copy and paste what it said after uploading the file.>>
The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

Which "factory" image you are talking about?
Files that have "factory" wording in the file name but exist on the openwrt.org server are OpenWrt firmware intended for flashing from stock (original) firmware. THe following, for example, is OpenWrt formware for your route if you wanted to change form Linksys firmware to OpenWrt
http://downloads.openwrt.org/releases/18.06.2/targets/kirkwood/generic/openwrt-18.06.2-kirkwood-linksys_viper-squashfs-factory.bin

If you want to change form OpenWrt to Linksys, then procedure form LuCI is as I mentioned in the provisos post. For it you would need the Linksys firmware, which is one of these
http://downloads.linksys.com/downloads/firmware/1224693043651/FW_E4200_2.0.37.131047.zip for classic
http://downloads.linksys.com/downloads/firmware/1224693028983/FW_E4200v2_2.1.41.164606.img.zip for cloud
I am not sure what are the differences, so for that you will need to consult your router's manual

yeah just trying to get back to the linksys firmware/stock (original) firmware/OpenWrt to Linksys, not any openwrt firmware. i don't know how to use or get to or what ever to luci i guess is apparently what i'm trying to say also lol.

LuCi is the GUI of OpenWrt.
You just go to http://192.168.1.1/cgi-bin/luci/admin/system/flashops and flash Linksys firmware.

It looks like you need to do some reading.

well... go up a couple comments where i posted what it said about that lol.
have downloaded the firmware. used that flash new firmware, and that's what i get.
this, again, is what i get.
"The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform."

i do re-edit my posts instead of constantly re-posting lol.

going to try the classic one and see if that's the issue. when i got it form a friend it had the cloud one. sooo... yeah lol. if i don't edit this or reply after a few minutes then that was it.
nope, same thing. different file type too lol.
in the cloud zip there is another folder in there with a "_MACOSX" and in it is another img file but was iffy trying that.

I read what you said. But I thought maybe you were talking about the "factory" version of OpenWrt, as the name can be confusing a little.

it's all good. just trying to figure this out is all lol. help is awesome so trying every stupid little thing possible. only reason i kept getting lost with the LuCi thing is because everything i found on it say's about commands which there is no command line or block in there(except in the configuration tab but then above it shows " Backup file list"). just simply click file then flash. but so far everything shows the same message.

changed the name of the post since you said that though. maybe a bit better or more specific to what i'm trying to do.

Sounds like you need to download the .IMG file (approx. 20 MB sized file, not the MacOS thumbnail) to your router's /tmp and flash it from there with "sysupgrade -F" like mk24 already proposed. That is the way to make the OpenWrt sysupgrade to bypass the OpenWrt-specific metadata check, which fails for the Linksys OEM firmwares.

You may look up similar discussion for WRT1900AC series including WRT3200ACM.

In your case it would be something like:

cd /tmp
wget link-to-stock-firmware_FW_E4200v2_2.1.41.164606.img
sysupgrade -F -n /tmp/FW_E4200v2_2.1.41.164606.img

Might be easiest to extract the .IMG from ZIP file in PC and transfer it via WinSCP or similar.

Ps. In the master snapshots LuCI already contains an option to use that -F option from GUI after the image check first fails, but that is not yet in 18.06, I think.

1 Like

ok, but am i supposing to be using the WinSCP and use those commands? that's the only thing i know with commands for the router once i connect to it. that's what i keep getting lost on also lol. using windows 10, every time i see the cd command i think linux even though windows can use that also lol.

and yes the Stock Factory file i'm trying to use is 20.6 MB

You can use WinSCP for the file transfer, but for the actual sysupgrade you need a terminal program (like "putty") to open the SSH console / command line interface, and then you run the sysupgrade command from the router's Linux console...

OR:
First flash Openwrt master buildbot snapshot, use the SSH command line to install LuCI GUI, then you can use LuCI to flash with the possibility for that image check bypassing.
(But you need command line for installing LuCI as those snapshots do not have it...)
Avoiding command line is not possible.

oh ok, good thing i did install putty already then. that was literally all i needed right there because i kept seeing mixed codes all over the place since the WinSCP used the codes i put in the OP. ok, sweet. might try that in a minute and see.

@hnyman
I will update the wiki with what you wrote.

ok, well, after the first attempt i noticed that the one cloud firmware links with the exact name give you a .bin file while the other gives a .img file with both having the mac folder with a 1KB .img file then the classic is a .ssa file, tried all 3 and they seem to fail... insta-disconnects me from putty and the cisco light above the Linksys E4200 name just stays in a breathing pattern the whole time til i do the partition switch trick with the power. also tried the wget command and it had an error with i think finding the link. soooo... yeah. now i'm at a lose lol.

@mhegab
ok, cool

Wait until it works.
That advice was based on the Linksys 1900 series (1900,1200,3200) dual firmware generic behaviour, but based on the feedback above, 4200 might require something different.

1 Like