AVM Repeater 1200 + Openwrt 21.02

Yesterday i tried to flash Openwrt to AVM Repeater 1200.
With precompiled 19.07 it worked as described on the wiki.
The precompiled 21.02 and selfcompiled from git did not start, tried from 19.07 with sysupgrade and by bootloader with initram.
As im not very experienced with Openwrt: Runs 1200 with 21.02 for someone?

It should...

I tried it, but the device just does not boot wth 21.03 images :frowning:

oh hey @fda ,

I have a question.
Did you follow the descripton in the wiki "blind" - i mean have you shoot up every command without headache?

I have "maybe" an problem. Fritz ! Repeater 1200 - Installation - Missing WLAN iw dev - #4 by frollic
... My Idea: test it bevor fully flash it to rom - but i have no wifi.

Can you test it for me if 802.11s is working?

I've not tested if Wifi is working, as i dont want to use Openwrt 19.x. There is the network config different than all other deivces with 21.x. And i was not able to build myself an 19.x image as some dependencies changed...

I noticed, at some point, FRITZ1200.bin is not more read from tftp. But after using the avm-recocery, the next run of "va_ramboot.py" do 100% an download by tftp (even the flashed does then not boot, but it flashed as the device no longer can boot)

Which Openwrt version are you running?


i use the 19.07.7 and i can confirm it's working - Also i have testet the 802.11s Mesh with the B/G/N Radio - and it's working too.

I have follow step-by-step the Wiki-Tut

I used ths eva_ramboot.py

#!/usr/bin/env python3

import argparse

from ftplib import FTP
from sys import argv
from os import stat

parser = argparse.ArgumentParser(description='Tool to boot AVM EVA ramdisk images.')
parser.add_argument('ip', type=str, help='IP-address to transfer the image to')
parser.add_argument('image', type=str, help='Location of the ramdisk image')
parser.add_argument('--offset', type=lambda x: int(x,0), help='Offset to load the image to in hex format with leading 0x. Only needed for non-lantiq devices.')
args = parser.parse_args()

size = stat(args.image).st_size
# arbitrary size limit, to prevent the address calculations from overflows etc.
assert size < 0x2000000

if args.offset:
	addr = size
	haddr = args.offset
	# We need to align the address.
	# A page boundary seems to be sufficient on 7362sl and 7412
	addr = ((0x8000000 - size) & ~0xfff)
	haddr = 0x80000000 + addr

img = open(args.image, "rb")
ftp = FTP(args.ip, 'adam2', 'adam2')

def adam(cmd):
	print("> %s"%(cmd))
	resp = ftp.sendcmd(cmd)
	print("< %s"%(resp))
	assert resp[0:3] == "200"

# The following parameters allow booting the avm recovery system with this
# script.
adam('SETENV memsize 0x%08x'%(addr))
adam('SETENV kernel_args_tmp mtdram1=0x%08x,0x88000000'%(haddr))
ftp.storbinary('STOR 0x%08x 0x88000000'%(haddr), img)

i put the uboot-fritz1200.bin in the same-folder as the .py
and i used the .bin from 19.07.7 - as the differnt in the wiki, where used the 19.07.4

After this, I used the AVM 1200 from:

Image for your Device sha256sum File Size Date
avm_fritzrepeater-1200-initramfs-fit-uImage.itb cb1066487e654d8fbdff732071455fac67a12732dfa034c92e4368f90c7c27f6 4789.4 KB Wed Feb 17 12:21:44 2021
avm_fritzrepeater-1200-squashfs-sysupgrade.bin 57cc65fba2eabd1df12f44de00f00c19ef69cbf690f44c48ca6fb78ac8a40dff 4990.3 KB Wed Feb 17 12:21:45 2021

i am not used the 21.xx.x cause it is an RC and while i'am testing it, i had directly problems on the Pi3.

Hope this help you?


Maybe did you have try to download all relevant files from the: "21.02.0-rc3" release?


Thx, but Openwrt 19.x works for me too, see op.
Im trying to find the commit which breaks 21.x, but older revisions have many compile errors

i didn't know, why you're compile the image - because an Image exist?

Why you use openwrt if there is an firmware by the vendor preinstalled?

Because it's a lot better?

you answered the wrong person

You asked me the wrong question: it is not the question why i used the openwrt instead of the preinstalled software, the question you have asked me analog means: why i not compiled the vendor-software and use it,

My question were: why you will compile the software instead of use the existing openwrt-binary?

Just a try:
Maybe you can install the 19.07.7 and Update over the gui as normal update?

It's a mistake that i answerd frollic ... but i can't edit it out

Please read op again:
"The precompiled 21.02 and selfcompiled from git did not start"
The question is if i did something wrong or if the something broken since 1200 was added

Fixed with help of blocktrron in irc

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.