Since your device is ath79, you can use direct dotted notation rather than bridge vlans...
to do that, delete these:
Edit the lan to use br-lan
again:
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.178.240'
option netmask '255.255.255.0'
option ip6assign '60'
option gateway '192.168.178.1'
list dns '192.168.178.2'
list dns '192.168.178.200'
list dns '192.168.178.203'
list dns '192.168.178.1'
Then create new bridges with dotted notation:
config device
option name 'br-guest'
option type 'bridge'
list ports 'eth0.40'
^^^ repeat this for VLANs 11 and 30, changing the name accordingly.
Then edit your network interfaces to use the bridges, like this for guest:
config interface 'Guest'
option proto 'none'
option device 'br-guest'
For the IoT network, make it unmanaged (option proto 'none'
)
On the wifi front, I'd recommend using either WPA2 or WPA3, but not mixed mode (sae-mixed) as this is not always well tolerated by client devices.
I also recommend removing all the 802.11r stuff (on all APs) as this is also not always going to play nice with the client devices. I generally suggest only using it if it's actually required, and that is determined only after all the APs have been tuned for power, channels, and position to the best extent possible. If you only have a single AP, 802.11r does not apply and should be removed.
DHCP should be disabled explicitly within the config file itself, and I recommend keeping the service running. It is also a good idea to leave the firewall running. Both services will be largely idle, but keeping them running will ensure that you won't have any surprises if they become re-enabled.
Once you've made all those changes, reboot and test again. If things still do not work properly, please post the updated configs.