AVM 7530 cannot finish initial OpenWrt installation


I am trying to install 22.03.04 on an avm Fritz!Box 7530. Everything worked out as per instructions. I got stuck at

root@OpenWrt:~# sysupgrade -n /tmp/avm_fritzbox-7530-squashfs-sysupgrade.bin 
Sun Apr 30 07:34:28 CEST 2023 upgrade: Commencing upgrade. Closing all shell sessions.
Command failed: Connection failed
root@OpenWrt:~# Connection to closed by remote host.
Connection to closed.

It reboots and Luci starts:

I also tried to do a Firmware update with Luci. This results in a reboot without any errors, but also without any improvement. Luci remembers only the set password, the console does not. All other setting are not stored either.
Does anybody have an idea what I should do?
Thank you for your advice and help.

The Luci message (initramfs…) means, that the actual flashing from the command you have shown has failed, as it is still booting from the temporary RAM-based firmware from the previous step, which is not preserving settings or changed password.

The following is guessing. Maybe you have one of the newer flash chips:

I am code-repository-dumb, so I do not know, whether the mentioned patch is already in the regular release already.
You might try to repeat both the „initramfs (!)“ and the „sysupgrade (!)“ step from your linked doc with the OpenWRT firmware files from the daily developer snapshot. as this will for sure contain the fix for the mentioned Toshiba flash chip. If this succeeds then the upcoming OpenWRT release v23 will be your friend

sorry for bothering you. I just ran through the procedure once more. Obviously I missed something some where. Now it is working fine and I am making my first steps into open WRT. Thank you very much for your help.

kind regards Jens

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.