Attended sysupgrade keeps showing old firmware

Since a few weeks attended sysupgrade isn't functioning as expected.
After "Search for firmware upgrade" a new firmware is found (i'm on snapshot).



So far so good, but after "Request firmware image", normally this takes a minute or so, almost immediately an old firmware is shown to install.


Cancelling the upload at this point and do again "Search for firmware upgrade" results in:


What i did until now

  1. Use auc. This works. But i want attended sysupgrade to work.
  2. Uninstall attended sysupgrade and reinstall it. This works as long as the last step (Install firmware image) isn't cancelled.

I seem to be having a problem with sysupgrade too, It reports a new version available but it is the same version I am currently running.

Unlike your situation It will install the upgrade and works fine

Do you have advanced mode enabled? I'm pretty sure that's expected behaviour when advanced mode is enabled. Can you try to turn advanced mode off and see if that changes the behaviour.

You have firmware 22.03.5 installed. Attended sysupgrade will show you the latest firmware available, which is 22.03.5. It is indicated that this firmware is already installed.
As @d687r02j8g indicated, this is standard behavior.

1 Like

That actually fixed it.

I guess I should of paid more attention, I just looked quickly and it seemed like there was an upgrade

1 Like

Dug a little bit deeper.
When presented with the older firmware (23104 in my case) i choose to install it, just to see what happened. And off course it installed the older firmware.
This would mean it is buffered somewhere on the device.

Does anybody know where these older firmware's are stored?

I have this too, numbers appearing after cancelling. It's been like that for a while but not the end of the world.

I'm on r22909, attended-sysupgrade offers r23248, after requesting the firmware I get r23248.

Wonder if it's specific to the snapshot version you have? After you upgrade using firmware selector, do you get the same issue on the latest snapshot?

I started this morning with a fresh new install (snapshot 23254). I have to wait a few days until new snapshots come available and see how the systems reacts.
For now i ran attended sysupgrade which offered 23254, it created and downloaded the firmware. I cancelled the install.