Attended-sysupgrade get's no results on my devices

Hi, could need some help.
The attended sysupgrade from LuCi is not working for me on any of my devices below:

D-Link DIR-860L B1
GL.iNet GL-B1300
TP-Link TL-WR902AC v1
Ubiquiti UniFi AC LR

On all of them is OpenWrt 21.02.3 running and attended-sysupgrade-common 0.3.1 installed. As server for the upgrades is configured.

Unfortunately on none of it a system upgrade can be found. Maybe I made something wrong, maybe the devices are not supported for this service. I checked "ping" and it is working from the router. So internet connection and DNS is working, I suppose.

Any suggestion what I have to do to get it working? Maybe just waiting until something is fixed anywhere?

I am grateful for any reply


What are you upgrading to, then?

I hoped to get shown available snapshots or 22.03.0-rc4.
At least, I would like to get an image with all packages, I have to install manually, if I update with plain sysupgrade file.

And it hasn't already worked, when I used 21.02.2 and 21.02.03 was available. I only missed to ask for help. :-/

1 Like

I had the same question. I belive you can find your answer here:

You mean, it will show rc images only if I activate "advanced mode". Right? Unfortunately even with activating this, I get any upgrade image displayed.

I get only this

If I reload the webpage after a while, this is shown:

So it seems nothing works.

Well, it works for some models, what I am trying to say is that you are on the last stable and published version, hence you can not update it with asu.RC4 is not considered stable and not published for asu as far as I understiod.
However you can customise and download RC versions from here:


Okay, I understand, what you mean. Unfortunately, it was also not working, when I used 21.02.2 on my devices and 21.02.3 was released.
Now I want to find the root cause of it, because I would like to use the attended sysupgrade if 22.03.0 is available.

I will let you know ones it is avaiable for my systems, so you can check on your routers.

Thanks for your offer and support!


  1. Change the server to for (via LuCI or /etc/config/attend....)

  2. Install the Attended Sysupgrade CLI
    opkg install auc

Change the branch to your download preference

and enjoy!

After this:

I got this back:

root@TL-WR902AC:~# auc -b SNAPSHOTS
auc (0.2.4-8)
Running: 21.02.3 r16554-1d4dea6d4f on ath79/generic (tplink,tl-wr902ac-v1)
No data available (61)

Any suggestions I can check?

Try both servers (one at a time) (This server has some interesting branches e.g. auc -f -b 22.03-SNAPSHOTS)

try command line (-f is to force verification)
auc -f -b </BRANCH/>

Unfortunately same result for both server.
Is it possible, that the server don't support all devices running with OpenWRT and my ones are part of it?

Nope, others are having issues too - see: Firmware selector server on home page failed

@viniribeirossa suggested the same there as well, didn't work.

In the LuCI interface it gives an error even when I try to update, however, in the CLI the update appears normally for me

What's your version?

I assume the OP is visiting the website - just like I am in the pictures.

Why do you keep mentioning LuCI and CLI?

It clearly doesn't work on the website.