Ath79: TPLink CPE510 v1 Ethernet not working

Hi all,

On Tplink CPE510v1 current ath79 image break Ethernet, no rx packets anymore.
After I night of troubleshooting with the help of Lyxis we conclude that the dts seems the culprit of the Ethernet bringup problem.
Ticket is created and troubleshooting help very welcome.

Greetgins Thomas

Try the top patch in my staging tree. From the driver codeflow, this should (!) not fix your TX issue but will resolve the warning in the kernel message buffer.

Hi Blocktrron,

Thanks for you patch that I just cheery-picked and tested on my CPE510v1. The warning in the bootlog disappear - so it works!
And it showed that I was on the wrong track to assume the Ethernet is broken on CPE510 dual port, as I enterpreted the kernel warning wrong and was not aware of the syntax chanfe for uci networking between ar71xx and ath79.
So all works now with the new syntax of ath79 eth0 & eth1 as expected.
Thx your very much! I can ack that your patch works op my side.

Greetins Thomas

Hi thuehn,
I have been testing the newer versions of OpenWRT to see if they resolved the ethernet break issue but, it has not been resolved. Could you provide me the firmware with the problem solved?