Ath79 builds with all kmod packages through opkg [flow offloading]


#142

does this offload technique includes offloading data generated by device and sent through wifi interface (e.g. iperf, USB drive transfer) or the only wifi offload that happens is in case of transfering data incoming from eth ports?


#143

If you device sends data directly over a local interface there is no routing involved and therefore it makes no sense to offload anything because no routing happen...

Also traffic from your wifi to eth ports or vice versa isn't routed if they are on the same bridge/subnet.


#144

@juppin
Can you build one for the Unifi AP AC Lite ( qca9563_ubnt_unifiac-lite.dts)?

That would be great, because I am about to deploy one and would like to upgrade beforehand.


#145

@juppin

  • Are you currently working off a fork of the openwrt repo? I'm just curious to do a diff between the two and see how ath79 replaces ar71xx.
  • Also in case you decide to stop supporting this project, it'd be great to learn how you do this.
  • How did you get the flow offloading working? Or is this an effect of using ath79?

#146

flow offloading is an effect of kernel 4.14, you can find a branch with ar71xx on 4.14 here


#147

Will include it in the next build...

My images are build from openwrt's master branch.

It's simply build with the also uploaded config.seed as .config and i've included my server as openwrt_core repo. Additionally my public key is also included in the image to validate my signed custom package list.

As lucize pionted out, this is a feature of kernel 4.14 on openwrt.


#148

I´ve added a new build!

Changelog:

  • package updates
  • rename of tplink_tl-re450-v2 to tplink_re450-v2 (needs sysupgrade -F)
  • add builds for all ubtn_unifiac models

Download 4.14.62

Please read first post if you come from ar71xx

PS: If you are already on 4.14.62 kernel version, you don´t have to upgrade to this image!

Greets


#149

Why don't you build the newly added devices?


#150

At the time i started this thread there where some devices that did not work.
I don´t want to support people if they soft bricked there device, so only devices that works properly get build by me.

Mention you device to be added and i will add it...


#151

Now TP-Link 1043nd v1 started working.
I added D-Link DIR-825 B1 that also works.


#152

The WNDR 3x00 work too. 3700 and 3800.


#154

I´ve updated my last build!

Changelog:

  • add new devices

All current supported devices:

  • D-LINK DIR-825 B1
  • NETGEAR WNDR3700
  • NETGEAR WNDR3700 V2
  • NETGEAR WNDR3800
  • Phicomm K2T
  • TP-Link Archer C7 V2
  • TP-Link RE450 V2
  • TP-Link WDR3600
  • TP-Link WDR4300
  • TP-Link WR1043 V1
  • TP-Link WR1043 V2
  • TP-Link WR1043 V3
  • TP-Link WR1043 V4
  • Ubiquiti UniFi AC Pro
  • Ubiquiti UniFi AC-Mesh
  • Ubiquiti UniFi AC-Mesh Pro
  • Ubiquiti UniFi AC-Lite

Download 4.14.62

Please read first post if you come from ar71xx

Please report issues with any devices

Greets


#155

Great job!
This way we can get more testing for newly added devices.
Some minor issues can be found.


#156

Keep me updated if i should add some other new devices!


#157

I mentioned those that I know to work for sure.

tplink,tl-wr941-v2 should work after the ag71xx issue has been resolved.
It was commited by 981213 who made all these fixes.

It looks like you added TP-Link WR841N/ND v11 :wink:


#158

I will only add devices with >= 8 MB flash because it makes no sense to have a working opkg on such devices.
They need a special build that suits the requirements of the special use case...


#159

Hm... The ath79 image is smaller a bit than ar71xx.
It fits well on 4MB even with LuCI.
I have MR3040 with LuCI and also smstools+iconv+ncm packages and I have 200+ kB left for opkg.

TP-Link flash layout is the only one doing well on 4MB though.

If we don't have LuCI with dependencies including uhttpd, we have plenty of space.


#160

Could you add Ath79 support for TP-Link WR842 V2. Thanks


#161

Hi !
Your builds for WNDR3700v2 has error eth1 tx timeout - WAN is useless.
This same error is in hnyman build WNDR3700v2-master-r7847-03e5dcbf10-20180813-2312.
Only working build is from hnyman WNDR3700v2-master-r7817-1961948585-20180810-2059.
Courious when I compiling my build I got this same error. I don't know fixit it.
BTW I use patchin file ag71xx_main.c but without success :frowning:


#162

These eth1 on WNDR 7x00 issues should be fixed soon in trunk.
hnyman reported them working without extra patches, that wasn't quite true :wink:

My almost the same DIR-825 B1 does work because of a different u-boot.