Ath79 builds with all kmod packages through opkg [flow offloading]


#183

I´ve added a new build!

Changelog:

  • kernel version 4.14.63
  • new minimal build (no additional packages: image size := ~4mb)
  • add build for TP-Link WR2543 V1
  • add build for TP-Link WDR4900 V2

Included features / packages (build with: -O2 -nomips16):

default build
  • same packages as on openwrt snapshots
  • luci-ssl + luci-theme-bootstarp
  • luci-app-sqm + sqm
  • luci-app-ddns + ddns-scripts
  • luci-app-openvpn + openvpn-mbedtls
  • wpad
  • nano
  • support for ath9k dynack
minimal build
  • same packages as on openwrt snapshots
  • support for ath9k dynack

Supported device images:

  • D-LINK DIR-825 B1
  • NETGEAR WNDR3700 (wan port issues)
  • NETGEAR WNDR3700 V2 (wan port issues)
  • NETGEAR WNDR3800 (wan port issues)
  • Phicomm K2T
  • TP-Link Archer C7 V2
  • TP-Link RE450 V2
  • TP-Link WDR3600
  • TP-Link WDR4300
  • TP-Link WDR4900 V2
  • TP-Link WR1043 V1
  • TP-Link WR1043 V2
  • TP-Link WR1043 V3
  • TP-Link WR1043 V4
  • TP-Link WR2543 V1
  • Ubiquiti UniFi AC Pro
  • Ubiquiti UniFi AC-Mesh
  • Ubiquiti UniFi AC-Mesh Pro
  • Ubiquiti UniFi AC-Lite

Download:

Download 4.14.63 (default build)

Download 4.14.63 (minimal build)


#184

Will this work on my Netgear WNDR3700 V4 ?


#185

No, currently thete is no of nand driver for your ar9344 soc in the ath79 target... Apart from that, your device is very similar to the TP-Link WDR3600/WDR4300.


#186

Hi, it works nicely on my wdr3600, good job. However I am still missing ability feature to control leds of embedded switch. Is it possible to get it working as on ar71xx target? Thanks. :smiley:


#187

wassup @juppin do you know if the 18.06.1 ar71xx is on 4.14 yet? my brain has been on hiatus for a bit, need to try and get back into the swing of things.


#188

The 18.06.1 changelog does not mention 4.14 for ar71xx:
https://openwrt.org/releases/18.06/changelog-18.06.1#targetar71xx_3_changes


#189

Why everyone asks that. 18.06 branch will never be on 4.14. 18.06.1 is a minor service release.
Maybe 19.01 must be, but not all devices will be on ath79, some will be still on ar71xx.


#190

There was a commit stating an update to kernel 4.14 for ar71xx but it has disappeared, it doesn't even show as rollbacked.


#191

Thanks tmomas


#192

K4.14 for ar71xx is at @blogic's tree.

ar71xx devices should be ported to ath79 to survive in the long run.


#193

Just for reference. :slight_smile:

TP-Link WR1043ND V1 | iperf -c 192.168.0.254 -i 10 -t 50 -m

OpenWrt SNAPSHOT, r7401+462-9009efa18b (Build 2018/08/15 or 2018/08/19 :blush:)

DHCP / Static, flow offload
[ ID] Interval Transfer Bandwidth
[ 3] 0.0-10.0 sec 678 MBytes 569 Mbits/sec
[ 3] 10.0-20.0 sec 678 MBytes 568 Mbits/sec
[ 3] 20.0-30.0 sec 674 MBytes 566 Mbits/sec
[ 3] 30.0-40.0 sec 677 MBytes 568 Mbits/sec
[ 3] 40.0-50.0 sec 676 MBytes 567 Mbits/sec
[ 3] 0.0-50.0 sec 3.30 GBytes 568 Mbits/sec
[ 3] MSS size 1448 bytes (MTU 1500 bytes, ethernet)
PPPoE, flow offload
[ ID] Interval Transfer Bandwidth
[ 3] 0.0-10.0 sec 298 MBytes 250 Mbits/sec
[ 3] 10.0-20.0 sec 296 MBytes 248 Mbits/sec
[ 3] 20.0-30.0 sec 296 MBytes 248 Mbits/sec
[ 3] 30.0-40.0 sec 296 MBytes 248 Mbits/sec
[ 3] 40.0-50.0 sec 296 MBytes 248 Mbits/sec
[ 3] 0.0-50.0 sec 1.45 GBytes 248 Mbits/sec
[ 3] MSS size 1440 bytes (MTU 1500 bytes, ethernet)

Qualcomm Fast Path For LEDE
#194

Hello @juppin Could you please add support for Western Digital My Net N750 in your new builds?
It is very similar to TP-Link WDR4300 it just has additional 8 MB flash and nice web recovery so there is no risk in trying new builds.

https://openwrt.org/toh/hwdata/westerndigital/westerndigital_mynetn750

Thanks in advance.


#195

yeah @xabolcs good call


#196

Aaand it's landed as a (non-default) selectable kernel version. :+1:


#197

I have updated to the latest release but still no control over the switch's LEDs :frowning: Is there some package I'm missing? Google search doesn't show much, and I have been able to control these leds on OpenWRT CC before.


#198

I assume you are using a device with gigabit switch (external ar83x7 switch)... Correct?

There is no support to setup the ar83x7 switch leds in device tree, this is only implemented with the non of hw init...
As long as anybody implement the of led init there will be no controll from linux of the switch attached leds.

For reference:
ar8327_hw_config_of
ar8327_hw_config_pdata


#199

Indeed, it's a TP-Link Archer C7 v2 (with its built-in AR8327N); and I was able to control its leds previously. I actually even have the config with their old definitions (basically, "turn off all the leds").

In the old config, the leds were like this:

config led
	option default '0'
	option trigger 'none'
	option name 'LAN1'
	option sysfs 'tp-link:blue:lan1'

config led
	option default '0'
	option trigger 'none'
	option name 'LAN2'
	option sysfs 'tp-link:blue:lan2'

config led
	option default '0'
	option sysfs 'tp-link:blue:lan3'
	option trigger 'none'
	option name 'LAN3'

config led
	option default '0'
	option name 'LAN4'
	option sysfs 'tp-link:blue:lan4'
	option trigger 'none'

But I do not have any of these devices now. (This is config from chaos calmer where it worked..)


#200

No device tree based device with ar83x7 switch will have user/kernel crontollable switch leds...
This feature exists only on mach file based devices currently!
ATH79 is device tree based and therefore no user/kernel controllable switch leds for now.

Switch over to the ar71xx target to have controllable switch leds!


#201

Ahh. Well that is a pity :frowning: I understand it is not your fault or anything; thanks for the explanation!


#202

Never say never. It is quite easy to implement.
Anyone who really needs it can do it :slight_smile: