Ath79 builds with all kmod packages through opkg [flow offloading]

I´ve added a new build!


  • Kernel 4.14.59
  • reworked ethernet / switch driver by @981213
  • package updates

Download 4.14.59

Please read first post if you come from ar71xx


What is this? It seems not included in the main branch of openwrt yet?

ath79 is currently source only. That code is only in the master branch of openwrt as of a day or so ago.

Hello @juppin

Would it be possible to explain your build process to 4.14? I would like to build this with the default packages instead of the ones listed above. Or do you have a build that includes just the default packages and excludes:

  • luci-app-sqm + sqm
  • luci-app-ddns + ddns-scripts
  • luci-app-openvpn + openvpn-mbedtls
  • wpad
  • nano

finally is this a squashfs build? Space on the * TP-Link Archer C7 V2 is limited and I would like to keep things simple.

Thanks for any help you can provide.

EDIT: Nevermind its in master branch now as Ath79 so

./scripts/feeds update -a
./scripts/feeds install -a

should do the trick I suppose

One more 1043 V4 is on your awesome build!
30 MBit, DHCP, nothing special, but at least ath79! :smiley: :+1:

Hi! Just installed your build and it's quite snazzy! (I was using the optimized build that's on a bit older kernel and I missed the ability to install OPKGs).

There is one thing I am missing however - and that is the ability to control the LEDs on the switch (ar8327 which is a part of the Archer C7 v2). Previously, I was able to do this with default openwrt as well as with the build from here: [GCC 7.2 BUILD] Optimized TP-Link Archer C7 V2 AC1750 LEDE Firmware but now I can only control the wireless LEDs and the system LED + USB leds. Would it be possible to compile support for those LEDs into your build? (or is it gone from trunk? D: )

Thanks for the excellent work on this build!

@juppin - Thanks for your amazing work!

I tried flashing this upgrade package to my Archer C7 using sysupgrade -n -F and found that the router rebooted and it was the identical version it was before?

  • What should the OpenWRT version say after flashing?
  • Does it sound like I'm doing anything potentially wrong?
root@OpenWrt_WDR3600:~# cat /etc/openwrt_release 
DISTRIB_DESCRIPTION='OpenWrt SNAPSHOT r7401+129-9009efa18b'

There was an issue while updating with sysupgrade and a not killed hostapd instance...
Connect over lan and do:

wifi down
sysupgrade -n -F ...
1 Like

Sorry to ask a possibly daft question but for an end-user, what does Ath79 mean?

From an enduser pov, nothing. Its modernization under the hood, with the main goal to bring the code into a form that is acceptable for Linux upstream, so that all (most) of the whole ar71xx supported devices can be handled by an upstream, unpatched Linux kernel.

There might be a slight decrease in kernel image size, but the general bloat of newer versions will likely eat that up completely.


Ahh it did work!

$ cat /etc/openwrt_release
DISTRIB_DESCRIPTION='OpenWrt SNAPSHOT r7401+129-9009efa18b'


Thank you for this build, it's working fine on my ArcherC7v2, only problem was IP address must have been edited via /etc/config/network file...

I have found your build for Lantiq XWAY Fritz 7312 here:
My main router/modem is TP-Link TD-W8970, based on Lantiq XRX200 chipset.
Would it be possible to add support for this very popular DSL modem in the future?
Thank you in advance

I had this build on my Archer C7 V2 for a week or so but couldn't get 5ghz wifi to work at all, and 2.4ghz wifi would just die off after a few days, so I decided to use the same flashing procedure to go back to ar71xx builds of sysupgrade -n -F. It seems to have made the router unbootable though and it seems to be caught in a bootloop. Any ideas?

edit: seems to be completely bricked to the point tftp won't even recover it, it attempts to send the firmware but it does not flash and just reboots itself every 1-2 seconds. Time to order a new router I guess, been itching for a dual-core one.

As long as your bootloader is okay this problem should be solvable...
I think you current tp link header is erased and you have to use a image with a modified header.
Checkout this: Can't get my archer c7 unbricked.. been trying all weekend

PS: The wireless driver is almost the same as on ar71xx for ath79. My devices have uptimes of five days and more until i do a sysyupgrade...

1 Like

Sorry, without a real device for testing this is not that funny. But if you have time and some programming/bash skills that shoulnd be that hard as long as there isn't a hw unit that needs a workaround or isn't supported by openwrt.

I tried tftping the firmware you posted in that thread - same result, seems to recognize and send but just reboots before it does anything. Unfortunately I don't have a serial cable to read what the thing is actually doing.

You have no arduino, pi or something similar?

Nope.. I've ordered a xiaomi MIR3G for $38 since I just have my cable modem directly connected to my desktop now using it as a wireless access point. I was trying these builds in the first place since the C7 wasn't as fast as I wanted anyway.

It's already supported by OpenWRT for some time, but official 18.06 build is 4.9 kernel based.
I was hoping you could create a custom 4.14 kernel based build with some NAT or PPTP offloading support...
I'm afraid I am not skilled enough for that, but thanks for explanation.

Ok, then why not build it yourself?

Is not that hard...

To switch to kernel 4.14 you have to modify only the top Makefile of the lantiq target.

Modify KERNEL_PATCHVER:=4.9 to KERNEL_PATCHVER:=4.14 and build the image with all packages you need...

Also if you are not that skilled, this should give you a custom image in a couple of hours...