grosjo
August 26, 2024, 1:23am
1
Hi
I have this is my logs
[ 14.621791] ath10k 6.9 driver, optimized for CT firmware, probing pci device: 0x56.
[ 14.676547] ath10k_pci 0000:00:00.0: enabling device (0000 -> 0002)
[ 14.683337] ath10k_pci 0000:00:00.0: pci irq legacy oper_irq_mode 1 irq_mode 0 reset_mode 0
[ 14.697740] urngd: v1.0.2 started.
[ 18.438834] ath10k_pci 0000:00:00.0: qca9888 hw2.0 target 0x01000000 chip_id 0x00000000 sub 0000:0000
[ 18.448419] ath10k_pci 0000:00:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 0
[ 18.462892] ath10k_pci 0000:00:00.0: firmware ver 10.4b-ct-9888-fW-13-5ae337bb1 api 5 features mfp,peer-flow-ctrl,txst7
[ 18.800859] ath10k_pci 0000:00:00.0: failed to fetch board data for bus=pci,vendor=168c,device=0056,subsystem-vendor=0n
[ 19.307814] ath10k_pci 0000:00:00.0: failed to fetch board-2.bin or board.bin from ath10k/QCA9888/hw2.0
[ 19.317577] ath10k_pci 0000:00:00.0: failed to fetch board file: -12
[ 19.335634] ath10k_pci 0000:00:00.0: could not probe fw (-12)
[ 19.362767] kmodloader: done loading kernel modules from /etc/modules.d/*
How to have this "board-2.bin" loaded ? Any config to be done in some DTS file or in the compilation process ?
Thank you
1 Like
Footprint to receive possible answers for my related problem .
brada4
August 26, 2024, 3:16am
3
Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </>
" button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
grosjo
August 26, 2024, 3:22pm
4
root@OpenWrt:~# ubus call system board
{
"kernel": "6.6.47",
"hostname": "OpenWrt",
"system": "Qualcomm Atheros QCA956X ver 1 rev 0",
"model": "YunCore WB5G08",
"board_name": "yuncore,wb5g08",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "SNAPSHOT",
"revision": "unknown",
"target": "ath79/generic",
"description": "OpenWrt SNAPSHOT unknown"
}
}
grosjo
August 26, 2024, 3:23pm
5
root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd1b:faf7:21a::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wan'
option device 'eth1'
option proto 'dhcp'
config interface 'wan6'
option device 'eth1'
option proto 'dhcpv6'
brada4
August 26, 2024, 3:57pm
7
Reset device to defaults to trigger wifi detection.
grosjo
August 26, 2024, 4:18pm
9
If I use
https://github.com/qca/qca-swiss-army-knife to re-generate the baord-2.bin
I get
[ 1493.165530] ath10k 6.9 driver, optimized for CT firmware, probing pci device: 0x56.
[ 1493.176119] ath10k_pci 0000:00:00.0: pci irq legacy oper_irq_mode 1 irq_mode 0 reset_mode 0
[ 1494.198615] ath10k_pci 0000:00:00.0: qca9888 hw2.0 target 0x01000000 chip_id 0x00000000 sub 0000:0000
[ 1494.208221] ath10k_pci 0000:00:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 0
[ 1494.222710] ath10k_pci 0000:00:00.0: firmware ver 10.4b-ct-9888-fH-13-5ae337bb1 api 5 features mfp,peer-flow-ctrl,txst7
[ 1494.593083] ath10k_pci 0000:00:00.0: board_file api 2 bmi_id N/A crc32 daee31f9
[ 1497.066142] ath10k_pci 0000:00:00.0: failed to receive control response completion, polling..
[ 1498.106189] ath10k_pci 0000:00:00.0: ctl_resp never came in (-145)
[ 1498.112605] ath10k_pci 0000:00:00.0: failed to connect to HTC: -145
[ 1498.209641] ------------[ cut here ]------------
[ 1498.214432] WARNING: CPU: 0 PID: 136 at kernel/workqueue.c:3401 0x8009ba8c
[ 1498.221583] Modules linked in: ath10k_pci(O+) ath10k_core(O) ath(O) jitterentropy_rng nft_fib_inet nf_flow_table_inet ]
[ 1498.277405] CPU: 0 PID: 136 Comm: kworker/u2:3 Tainted: G O 6.6.47 #0
[ 1498.285502] Workqueue: ath10k_wq 0x82c2034c [ath10k_core@1cb93f64+0x56000]
grosjo
August 27, 2024, 11:46am
10
Maybe missing something in the DTS file to setup the pcie card ?