AT&T Fiber - Zyxel Armor Z2 - ARRIS BGW210 Configuration Help

Hello FrustratedUser here,

As you can see from the title my current setup is the AT&T provided RG connected to the ONT and I'd like to put my Armor Z2 behind that router. My Armor Z2 is currently running OpenWRT 18.06.2.

I've connect the WAN port of my Armor Z2 to an Ethernet port on the back of the ARRIS router but I get no internet connection through the Armor Z2. I've looked around for the correct way to configure OpenWRT but it seems everyone else's is able to configure itself automatically.

Anyone have any experience with this?

Without seeing any of your configs...

I would make sure that the OpenWrt LAN and LAN on the Z2 are numbered differently. Basically, make sure they're not both 192.168.1.0/24.

It's the default fresh out of the box configs. They are on different subnets, and OpenWRT is installed on the Z2. I'll dump the configs and post them soon.

This is a Zyxel Armor Z2 connected to an Arris BGW210 which is connected to the ONG. The stock Zyxel firmware works fine but OpenWRT does not.
Here are my configs.

/etc/config/system:


config system
	option hostname 'OpenWrt'
	option timezone 'UTC'
	option ttylogin '0'
	option log_size '64'
	option urandom_seed '0'

config timeserver 'ntp'
	option enabled '1'
	option enable_server '0'
	list server '0.openwrt.pool.ntp.org'
	list server '1.openwrt.pool.ntp.org'
	list server '2.openwrt.pool.ntp.org'
	list server '3.openwrt.pool.ntp.org'

config led 'led_wlan2g'
	option name 'WLAN2G'
	option sysfs 'nbg6817:amber:wifi2g'
	option trigger 'phy1tpt'

config led 'led_wlan5g'
	option name 'WLAN5G'
	option sysfs 'nbg6817:amber:wifi5g'
	option trigger 'phy0tpt'

config led 'led_wan'
	option name 'WAN'
	option sysfs 'nbg6817:white:internet'
	option trigger 'netdev'
	option mode 'link tx rx'
	option dev 'eth1'

/etc/config/network:


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fded:7cc2:0e3c::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device 'lan_dev'
	option name 'eth1.1'
	option macaddr '8c:59:73:fe:26:e2'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'

config device 'wan_dev'
	option name 'eth0.2'
	option macaddr '8c:59:73:fe:26:e3'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 0t'

It looks fine. It does appear you changed the MAC addresses.

  • Did you change any firewall settings?
  • Please show the results of the command ifconifg eth0.2
  • I noticed that your LAN is eth1.1, did you make edits to any interfaces?