Asus TUF Gaming AX6000 support

From. Where did You get that image?
If from openwrt site then it's stock.
Does it have luci?
Try telnet or ssh to 192.168.1.1

2 Likes

The image came from the main page, the first table: https://openwrt.org/toh/asus/tuf-ax6000
"Firmware OpenWrt snapshot Upgrade URL" - Factory sysupgrade image
I can SSH in:

BusyBox v1.36.1 (2024-06-02 20:43:46 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt SNAPSHOT, r26504-d4acd05218
 -----------------------------------------------------
=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
--------------------------------------------------
root@OpenWrt:~#

Perhaps I need to downgrade to earlier version? How do I get the file on to the router via SSH? The router itself doesn't have a WAN connection as I wasn't able to configure PPPoE

As I said. You don't have luci installed.
It's normal for images from openwrt.org

You have to manually Download coresponding packages or install an image with luci

You can contact me on PW if You want
I can share a site with food images with luci enabled

1 Like

Thank you. I used WinSCP to copy over the latest stable from here, ran sysupgrade via SSH and now up and running: https://firmware-selector.openwrt.org/?target=mediatek%2Ffilogic&id=asus_tuf-ax6000

1 Like

I just upgraded from:

Version-from   SNAPSHOT r26279-140b48a9e9 (kernel 6.6.30)
Version-to     SNAPSHOT r26557-de59fc4540 (kernel 6.6.32)

Using https://github.com/efahl/owut/

The device rebooted, and I thought it was bricked... but it turns out it is in a weird state. Connecting to serial I see the boot, everything seems OK... but the network access is odd.

I can ping my home network, I can ping 1.1.1.1, but DNS is completely broken, and I cannot ssh to the device or access luci.

It's like it is in a half working state. It appears that the wifi interfaces didn't come up either. Has anyone seen the latest snapshot work?

All I see in dmesg wrt. wifi is:

[    8.226485] mt798x-wmac 18000000.wifi: HW/SW Version: 0x8a108a10, Build Time: 20221012174648a
[    8.226485]
[    8.392400] mt798x-wmac 18000000.wifi: WM Firmware Version: ____000000, Build Time: 20221012174725
[    8.484363] mt798x-wmac 18000000.wifi: WA Firmware Version: DEV_000000, Build Time: 20221012174937
[    8.590680] mt798x-wmac 18000000.wifi: missing precal data, size=403472
[    8.597336] mt798x-wmac 18000000.wifi: registering led 'mt76-phy0'
[    8.605034] mt798x-wmac 18000000.wifi: registering led 'mt76-phy1'

More weird things. I can ping downloads.openwrt.org but I cannot ping google.com. opkg update worked, and installing some trivial package worked. nslookup google.com times out with no servers could be reached, nslookup downloads.openwrt.org returns proper info from my internal DNS server, which is configured in /etc/resolv.conf.

The prompt in ash is root@(none):~# but I see the correct file contents in /etc/config/system with my expected hostname. uname -n returns (none).

Very weird.

Ran /etc/init.d/system start and got /etc/rc.common: line 86: uci_load: not found, something to dig with.

Last update for now: after getting another sysupgrade image over (same one I flashed with owut) and upgrading with -n, system reflashed but still in the busted state.

Will manually download a new image from the firmware builder and try again.

Looks like this commit is just broken :thinking:, just downloading the regular image from https://firmware-selector.openwrt.org/?version=SNAPSHOT&target=mediatek%2Ffilogic&id=asus_tuf-ax6000 resulted in a broken router too.

Went back to the previous image, everything works. Looks like a broken image.

People have reported similar problems in the Cudy WR3000 and GL-MT6000 thread. Latest snapshots are just borked.

A bad commit was reverted so snapshots today or tomorrow should be fine again.

1 Like

Thank you.

Bad commit: https://github.com/openwrt/openwrt/commit/17d8c5825e6f5c5d2e4d2c320c3b4b797f4ca0e9

Revert: https://github.com/openwrt/openwrt/commit/80d1c353b79e6c216dcb2534420470e3e6ed5d60

Bumping turning on Packet Steering, I went from 600mbit to 940mbit on my 1gbit fibre connection.

1 Like

I'm trying to turn the Asus Aura RGB LED off, to no avail.

During boot the LED i first blue, then "breathing" yellow, and finally red.

I can switch between red and mauve/purple using sysfs:

echo 0 >/sys/class/leds/blue:cover/brightness # Red
echo 1 >/sys/class/leds/blue:cover/brightness # Mauve

In fact, any value except 0 gives mauve.

How did you turn the LED off?

Have you figured out anything more about this LED?

Serious price drop of the TUF AX6000 on the official ASUS US website: $139!

1 Like