Asus TUF AX4200 support

No soldering is required to flash this router.

Opening the case is quite easy: carefully remove the 4 pads under the router, it reveals 4 holes for the screws. Remove the screws, then start prying the top open FROM THE BACK. No tools are required, just pull the top with tip of your fingers and push the back in a bit with the other hand and it will come. Once you worked the back open, work your way towards the front on the sides, the front will come off after moving the cover a bit up and down whilst pushing it towards the front.

Use a USB Serial TTL (3.3v) interface. The wires must be of the type with pins (pogo) used for breadboards. Insert the pins into the corresponding GND, TX and RX (ONLY!) to the right of the routers' motherboard. NO NEED TO SOLDER, the holes are wider, but just doing this will get a stable serial connection. Then follow the instructions in the first post. NOTE: you can use any IP address for your TFTP server and for your router, you don't have to stick to the IPs indicated above (needless to say they must be in the same subnet).

If the brightness of the LEDs bother you, this is the time to get a sharpie pen and color the bottom of the plastic LED lens glued to the case top, it will dim them.

Since it is quite likely that you will not need the serial anymore (unless you are a developer, you want to re-install the original firmware or you brick your router), no need to leave wires dangling outside either.

1 Like

This Asus TUF AX4200 might not have an ethernet switch as good as other routers of different makes/models.

I found out that I had a device possibly with an electrically faulty ethernet port (but still working) that connected to other routers had not effect.

When I connected this device to the AX4200 not only it took down all the ports on the router's switch, but also it impacted the main switch to which this router was connected by disconnecting other devices connected to the main switch.

Here is my LAN schema:

             LAN main switch
faulty device ---- router --- fibre modem

I suspect the the faulty device might have had an internal short, possibly injecting higher than standard voltages on the ethernet.

Previously I had a Linksys WRT32x, then replaced with a Netgear R7800. None of these devices were impacted by the faulty device. It is likely they their own internal switch blocked any spurious voltage coming from the faulty device.

When I installed the AX4200 in place, its LAN ports started crashing, but the scary part was that the issue was propagated to the main LAN switch connected to the router as it was affecting other ports on the main switch too. The R7800 and WRT32x were blocking this.

I had to go through a one by one connection to identify the faulty device. On the positive side, now I know I had a device that was faulty and I replaced it. However the conclusion is that the AX4200 electronics aren't as good as those of a WRT32x or an R7800. My WRT32x even survived a lightning strike that fried every other device connected to my LAN (including a previous R7800).

1 Like

Yea I purchased my WRT32X about 6 years ago on Amazon Renewed for $100, it's been my router (sqm, dsa, nftables, adblock, samba, usb3, dual boot, etc.) working perfectly solid for so long. I can vouch for it as an awesome device (mwlwifi limitations aside).

On here reading about experiences looking into an upgrade though for a modern wifi 6 device. Narrowing it to DL-WRX36, this AX4200, or the upcoming GL-MT6000. Thanks for the heads up on that concern.

@patrykk Thank you for a detailed explanation on how to attach the serial port. Your guide converted me from “Too bad this router is a no-go, since I don’t want to solder anything to a new device”, to “Let’s give it a try today”. :slightly_smiling_face:

One correction though: It’s 3.3V, not 5V. Not sure if this router is 5V tolerant.

By the way, the golden wires are called Pogo pins, I believe.

1 Like

Please dont connect any voltage pin. Only Ground and two serial pins (rx,tx).

1 Like

Probably not. Not many are. Better start low and go up if you're in doubt.

I don't think we're discussing Vcc voltage. The I/O pin voltages need to be within spec, which usually is absolute max 3.6 V


Thank you! I amended my post.

1 Like

So , for people that already use openwrt, is it stable?
I'm also curious if there is anything that is not supported by openwrt (besides the leds).
Been using older openwrt router for a while and then i bought this one....used the main firmware for more than 2 months, but now i have an usb serial flasher and I'm ready to flash openwrt :d , my only concern is stability.

Regards !

I received the router on Thursday, it took me about 20 minutes to open it and flash OpenWRT 23.05. I expected it to be difficult. It could not be easier.

Initially I had problems because of a faulty device (see my post above regarding the switch electrical protections, or lack of).

The AX4200 has become my main home router since Friday. The WiFi radio coverage is even better than the R7800 that it replaced. I run lots of stuff on it including VLANs, multiple SSIDs, VPNs and MWAN3 to failover to an LTE modem. So far it has been very stable.

LEDs do work, but you can't do much. For example you can set WiFi and Power LEDs to off or blink. I used the only Red LED (overimposed on the 2.5 White LAN LED) to show WAN activity

1 Like

After 4 or 5 days ( sometimes more sometimes less I can see minor wifi throughput drop with distance. I mean behind one wall and 6 meters away from router TX throughput drop from 120MB/s to 80MB/s. Simple OpenWrt reboot doesn't want to solve problem. I need to unplug the router for a while. I'm not sure that my BT device affect this problem. I need to investigate it dipper.

best regards,

1 Like

Ok, so stable, great great.
One last question, have you guys also backed up before flashing, and if so how exactly ?
Just flashed my sonoff power-meter with tasmota successfully as a test for my flasher , and now the router is blinking with anticipation :slight_smile: , i think he knows.
Jokes aside, thank you both @ezplanet and @patrykk for the quick replies and details provided

I think this is possible, since for this device the firmware images do not have a digital signature.
Instead of a digital signature, idiotic technology is used that uses XOR and NOT instructions.

Relatively recently, AsusWRT developers removed the SCP binary from all firmware and wrote that this was done to improve security. But from the hacker’s point of view, nothing has changed, so hacker can still transfer files via SSH or TFTP. But for the average user this has turned into a headache.

Today I’ll try to recreate this idiotic verification algorithm from Asus.
I didn’t find a similar algorithm in this repository:

And then I’ll try to flash the InitRamFS image via WEB AsusWRT.


Looking forward to this

Flashed mine and it is working awesome!
I also took many pictures of the disassembly so that we can maybe create a short guide over the device page, maybe a step by step for users that are using this method for the first time, like me :slight_smile:

Thanks again everyone for the support and replies


@remittor I’m really looking fordward to that. Thank you!

Thanks You for your work i'ts very good news :muscle::+1:

I managed to create a valid trx-image that the AsusWRT installs (I think so). In the system log I see the same messages as when flashing the original trx-stock image.

May  6 23:01:11 rc_service: httpd 1648:notify_rc stop_upgrade_ate 1 0 0
May  6 23:01:13 kernel: _nvram_free: 1648(httpd) nvram_idx(0 / 2)
May  6 23:01:14 miniupnpd[1696]: shutting down MiniUPnPd
May  6 23:01:15 ahs: ===Terminate ahs daemon===

But after a very long reboot, the stock AsusWRT starts.

It is very likely that some checks are built into the bootloader. And in this case, the bootloader simply restored the stock working image to the flash chip (but I don’t know how it does this).

There is this line in the bootloader: rootfs-1 No %s %s %s Image
It seems very likely that the bootloader does not expect to encounter the "initrd-1" section inside the fit image.
And I still haven’t even connected the uart. I think it's time.

We need to think about how this can be fixed...


you think any chance to can be fixed ?

I would also like to say thank you for the support of this device, awesome work! I'm using 23.05 and it is working fine!

dmesg shows these entries:

[    1.168166] mtk_soc_eth 15100000.ethernet: generated random MAC address 32:59:68:7c:af:1a
[    1.176388] mtk_soc_eth 15100000.ethernet: generated random MAC address 7a:c4:50:ce:5b:5e
[   14.883962] mt798x-wmac 18000000.wifi: eeprom load fail, use default bin

But the MACs I see in LuCI are not random, the LAN and 2.4GHz Wifi are the factory ones while the 5GHz differs by the first octet only. Not sure if the eeprom fail is causing any issues, maybe the radios are running without calibration.