Asus TUF AX4200 support

Yes. Latest snapshot have fix: https://github.com/openwrt/mt76/issues/843#issuecomment-1877547009

firmware selector broken with kernel mismatches, will check back later.

Hello,

Another datapoint, I installed openwrt on mine today with the trx from @remittor (and thanks a lot for that) then flashed with 23.05.2 from openwrt.org (sysupgrade without keeping conf) and I didn't have any problem.

Did you check the integrity of the image (with sha256sum)?

After a metric ton of troubleshooting i found out my coax cable that comes from my isp to the modem was faulty.... go figure with the timing of switching builds.

Hello,

Here are some data with SQM and the TUF ax4200.

My home connection is FTTH 1Gbps/400Mbps, the router is using openwrt 23.05.2 and is behind the device from my ISP (livebox4 orange, France) with a wired connection (1Gbps).

My test are initiated from my desktop with a 1Gbps wired connection to the router.

SQM configured with the instruction on the wiki ( https://openwrt.org/docs/guide-user/network/traffic-shaping/sqm )

without SQM:

Grade B
DL 910Mbps ; UL 402 Mbps ; ping 12ms +30DL +21UL.

With SQM cake/piece_of_cake (limit at 845000 / 360000)

grade A
DL 699Mbps ; UL 310 MBps ; ping 14ms +27DL +0UL

With SQM FQ_codel/simplest_tbf (limit at 845000 / 360000)

grade A+
DL 826.0 Mbps ; UL 328.9 Mbps ; ping 13ms +0DL +0UL

With SQM FQ_codel/simple (limit at 900000 / 390000)

grade A+
DL 880.2 Mbps ; UL 388.8 Mbps ; ping 10ms +2DL +0UL

In this latest one, I tried to raise DL/UL limit till I lost the A+ grade, simplest.qos and simplest_tbf.qos give the same results than simple.

1 Like

I've been using this router for several months now and it's simply incredible for online gaming

Is very stable i use adguard in more

Connexion FTTH i'm live in France liké You know everything,

1 Like

Looks like filogic is ditching kernel 5.15 in favor of 6.1.
https://github.com/openwrt/openwrt/commit/da970d63fb52fb50915f7f94aaf1d8e0b158b7d3

1 Like

It's hit the snapshots now too! jumps off the cliff

My 5ghz went down again today, DAWN not connecting was the only symptom in the log. As usual, the mesh and 5ghz clients thought they were online but no.

My mesh stopped yesterday (without it being provoked by iw scan) but I didn't have the time to look at it in more details - as before it seems that mesh link is up, but no L2 traffic going in the direction of the "secondary" node. The AP SSID on the same router and same radio (5Ghz) was fine.

I cannot download the file openwrt-23_tuf-ax4200-initramfs.tr, the link loads and then everything turns grey and google shows a notification "you are offline" which is complete bullshit otherwise the link wouldnt even load and i couldnt be on this forum rn.
Google is evil and disgusting, could you share the file elsewhere for example protondrive or mega?

Works for me. I uploaded a copy here https://ufile.io/orrq25r5 if you still need it.

1 Like

i got it by using another device but thank you!, always preffer to download from non-google sources

There was report about an issue with TUF-AX6000 and using Attended Sysupgrade (auc). auc was serving broken images that resulted with a serial console recovery. Not sure if this issue relates to AX4200, but just a heads up in case it does.

There was a report in AX6000 thread with the same issue.

Apparently this is a similar issue with this one :

I can't confirm if it works or not (I've seen problems with auc in past), but be careful just in case you are using auc. Could be a false positive though.

A quick update: latest Firmware Selector snapshot for AX6000 worked well for me (can't say about AX4200, since I don't own it).

Maybe it's the same thing for AX4200...

People owning either the TUF-AX4200, TUF-AX6000 or RT-AX59U, please test and report back if this works:

3 Likes

Will do once the firmware selector's back to a working state.

Do I understand correctly that you expect to see a change in WIFI and eth ports MAC addresses to match factory config?

Edit: My bad, I just noticed it's still a PR so I would need setup the environment to build it myself. I can't really do that at the moment.

This sent mine into a bootloop. I need to connect a serial cable to see what's going on .

1 Like

hi daniel like a rt3200 belkin ? what is the difference to proceed UBI is benefice ?

thanks

Nope, not like on the RT3200 where we had to re-do everything. ASUS was a whole lot smarter and already did most things the right way which is why we don't have to demolish their bootchain.

Just, up to now, we had to extract MAC addresses and Wi-Fi EEPROM using a script in userspace. And now we can do it in device tree which is more elegant and removes board-specific knowledge from userspace (which is desirable imho).

2 Likes

@daniel Here's the full serial boot log you asked for:

https://pastebin.com/nXd42vU4

Thank's for your time & support

2 Likes