ASUS RT-N66U, missing WAN interface

I just flashed my ASUS RT-N66U with the latest build (first time install) and I seem to be missing the WAN interface. There's no Switch menu under Network and there are no entries under Network on the Status page. What am I doing wrong here? Reading the installation instructions it should pretty much be working right out of the box, but I can't get a connection to the outside world so the device is pretty much useless as it stands.
I tried the 19.07.04 version, and then the 19.07.05.
(but as of right now, the links for the RT-N66U are missing, so maybe there's been some issues?)
Or could someone send me/point me to a version that actually works on this device?

The device page is here. However there isn't much information about the interfaces. Can you post the output of uci export network ?

I will do that when I get home tonight.
And I will try previous releases and see if that changes anything.

I installed the 18.06.9 version to see if that made any difference, but it wasn't much better.
The output states 3 interfaces:

package network

config interface 'loopback' 
   option ifname 'lo'
   option proto 'static'
   option ipaddr '127.0.0.1'
   option netmask '255.0.0.0'

config globals 'globals'
   option ula_prefix 'fd52:3629:1962::/48'

config interface 'lan'
   option type 'bridge'
   option ifname 'eth0'
   option proto 'static'
   option ipaddr '192.168.1.1'
   option netmask '255.255.255.0'
   option ip6assign '60'

config interface 'wan' (which I created because it was missing, but it didn't help at all)
   option proto 'dhcp'
   option ifname 'eth0'

This won't work, you have assigned both lan and wan on eth0.
Which interfaces are available on this device? ip link or ifconfig -a

Hi,

same issue here. WAN device (eth0.2) is just missing. I have multiple RT-N66U running (all H/W Ver.: B1) and only one with this issue.

ip link:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel master br-lan state UP qlen 1000
    link/ether <mac> brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether <mac> brd ff:ff:ff:ff:ff:ff
4: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether <mac> brd ff:ff:ff:ff:ff:ff

ifconfig -a

br-lan    Link encap:Ethernet  HWaddr <mac>
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::a60:6eff:febc:32c8/64 Scope:Link
          inet6 addr: fd3d:4231:e83c::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3054 errors:0 dropped:0 overruns:0 frame:0
          TX packets:617 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:206242 (201.4 KiB)  TX bytes:92937 (90.7 KiB)

eth0      Link encap:Ethernet  HWaddr <mac>
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3080 errors:0 dropped:0 overruns:0 frame:0
          TX packets:649 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:251153 (245.2 KiB)  TX bytes:95370 (93.1 KiB)
          Interrupt:4 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:50 errors:0 dropped:0 overruns:0 frame:0
          TX packets:50 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3916 (3.8 KiB)  TX bytes:3916 (3.8 KiB)

wlan0     Link encap:Ethernet  HWaddr <mac>
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

i flashed 19.07.4 and .3 and it did not change anything.

also firstboot did not help.

Ah, I tried to install openwrt for the first time today on my RT-N66U and spent an hour trying to figure out where the WAN interface and switch config is before I found this thread. =)

I have tried both 19.07 as well as 21.02 rc3 with the same results. No wan interface and there is no switch setting tab either?!

Is there anything other than ip link and if config I can provide to help troubleshooting? Any other steps I can perform? Sort of dead in the water at the moment.. =)

Thanks!

root@OpenWrt:~# ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel master br-lan state UP qlen 1000
    link/ether 10:bf:48:d2:dd:d0 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 10:bf:48:d2:dd:d0 brd ff:ff:ff:ff:ff:ff
4: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 10:bf:48:d2:dd:d0 brd ff:ff:ff:ff:ff:ff
root@OpenWrt:~# ifconfig -a
br-lan    Link encap:Ethernet  HWaddr 10:BF:48:D2:DD:D0
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::12bf:48ff:fed2:ddd0/64 Scope:Link
          inet6 addr: fd73:ab15:29aa::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:14513 errors:0 dropped:191 overruns:0 frame:0
          TX packets:3543 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2530158 (2.4 MiB)  TX bytes:2245195 (2.1 MiB)

eth0      Link encap:Ethernet  HWaddr 10:BF:48:D2:DD:D0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:14515 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4027 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2733454 (2.6 MiB)  TX bytes:2271331 (2.1 MiB)
          Interrupt:4

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:4990 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4990 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:541186 (528.5 KiB)  TX bytes:541186 (528.5 KiB)

wlan0     Link encap:Ethernet  HWaddr 10:BF:48:D2:DD:D0
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

root@OpenWrt:~#

So this is how I fixed my RT-N66U. I went back to the latest Asuswrt Merlin build and reset all settings. I then updated the CFE as per this guidance here: CFE bootloader update | SmallNetBuilder Forums (snbforums.com) (Mine was on the factory CFE). I then went back and re-tried to apply the latest openwrt build (RC3) and this time it worked. I have the switch option and I also have a WAN port.

1 Like

Which CFE version did you have to upgrade to see the extra interfaces? My N66U is currently on bl_version 1.0.1.4 and I was thinking about giving OpenWRT 21.02-rc3 a try coming from the stock firmware.

Also, are the closed source wireless kernel modules working on the N66U in 21.02-rc3? I'm curious if it improves the 2.4GHz signal and throughput and/or if 5GHz is available.