Asus RT-N56U A1 & OpenWrt 18.06.1 - occasional WLAN network problems


#1

Hi,

After several days of fully functional AP, the communication from wireless part to LAN seems partially broken.

Setup:

  • RT-N56U (10.11.13.10) is connected to existing lan 10.11.13.0/24 (WAN port not used)

  • It provides 2 WLAN networks on 2.4 GHz radio:

    • wlan0 extends the LAN, i.e. DHCP server is provided by router 10.11.13.1, and
    • wlan0-1 creates a separate network (10.11.17.0/24) for guests, where DHCP is provided by RT-N56U.

This is a fully functional setup.

After several days (and occassionally even sooner):

  • wlan0 clients cannot get IP address. RT-N56U ('wifi') does not show anything suspicious and the 'router' (10.11.13.1) logs DHCP offer failure:
Feb 11 18:43:01 tiger rsyslogd[371]: Feb 11 18:43:01 wifi hostapd: wlan0: STA 4c:66:41:94:a2:c5 IEEE 802.11: associated (aid 2)
Feb 11 18:43:01 tiger rsyslogd[371]: Feb 11 18:43:01 wifi hostapd: wlan0: AP-STA-CONNECTED 4c:66:41:94:a2:c5
Feb 11 18:43:01 tiger rsyslogd[371]: Feb 11 18:43:01 wifi hostapd: wlan0: STA 4c:66:41:94:a2:c5 WPA: pairwise key handshake completed (RSN)
Feb 11 18:43:02 tiger rsyslogd[371]: Feb 11 18:43:02 router router: dhcp1 offering lease 10.11.13.140 for 4C:66:41:94:A2:C5 without success
  • wlan0-1 clients get IP address correctly (thanks to DHCP served by RT-N56U), but cannot access internet (i.e. not even the 'router').

It appears as if the communication from wireless clients to lan gets partially broken.

However, I can still fully connect to luci on the lan port (i.e. wired connection).
I tried (step by step) to:

  • restart wireless radio0;
  • restart network (System // Startup // Network), dnsmasq, firewall, odhcpd;

but without any affect on the above behaviour. Rebooting RT-N56U solves the problem, though.

Any ideas what might be the culprit and how to debug that? So far, it helps to reboot the device overnight via cron, but that does not help always...


#2

Well, form wht you said, I suspect it's the link between the two routers that's failing.

Did that PC have internet when you did so? Could you keep it like that and see if it will have internet when wireless devices don't?


#3

If you can't narrow it down it could be a hardware problem. It is very common for wifi to gradually fail on this router. I have seen lots of reports about it in forums, and it has failed on one of the two I own. It works for a while, and then it dies.


#4

Then how does this explain this:

It's very likely that the link between the two routers is the problem. This explains why those who get IP by the main router lose their IP while those who get IP by the Asus don't.


#5

It fails gradually. It works for a while and then it fails and requires some kind of restart, or the network goes down for a few seconds and then comes back up. At least that's what I experienced.


#6

WiFi problem doesn't explain this


#7

Thanks for comments.

I can confirm that the wireless part really seems to work - wlan0-1 clients get associated and get IP address from RT-N56U. I did not try if they can reach other clients on lan (like 10.11.13.2) - at the moment, this is blocked by firewall (only route to router is allowed), but I can adjust for test purposes.

However, the lan part seems to be working as well - at least for wired clients: I can connect via luci, via ssh. I think that in the past I also tried pinging from RT-N56U to the wired world - both LAN and public internet (although I cannot confirm for 100 % now).

To me it seems as if the communication is partially broken in the RT-N56 - between the the wireless and wired part. Interestingly, it is not fully broken - e.g. the router gets request for DHCP lease, but the offer is not accepted/confirmed. I also tried to restart router but that did not help. Only restarting RT-N56U does - so it indeed seems as a hw problem.

I will try to wait for another break-down (possible only in the weekend, wifi is used by family members) and do some more test to narrow down the weak point or try to dump the communication on the network directly on RT-N56U. (However, I am no expert in so it will probably not tell me much.)


#8

Easiest two things to try would be to see if when the problem occur, does Asus have internet access? And do Asus clients connected by cable have internet access?

You can ping from ASUS to the other router or to internet by typing the appropriate IP or domin in the following page
http://10.11.13.10/cgi-bin/luci/admin/network/diagnostics