Asus RT-AC51U intermittent reboots (2 routers)

Hello,

I have two Asus RT-AC51U routers, both running: OpenWrt 21.02.1 r16325-88151b8303 / LuCI openwrt-21.02 branch git-21.295.67054-13df80d

With the following Architecture: MediaTek MT7620A ver:2 eco:6

Before adding OpenWRT, both were stable on the original Asus firmware.

They have almost identical configuration, 3 VLANs, 3 SSIDs, no WAN, firewall and DHCP disabled.

The issue I have is they both reboot intermittently (around 3 times per day), I've added a monitoring agent (Zabbix) to see if I can pick up any process, CPU or memory trends around the time of the reboots.

I've also setup a syslog destination for debug logs to see if I can catch anything there, nothing so far seem obvious.

Please could someone give me some pointers as to what I should consider monitoring, logs I should review or any other ideas?

Thanks!
S

Exactly same problem with one RT-AC51U just older firmware.

openwrt-21.02 branch (git-21.231.26241-422c175) / OpenWrt 21.02.0 r16279-5cc0535800

Constant reboots but not on regular basis, just random ones. The only plugin I have tried to install was adblock, after some time I thought that it's the reason (like cpu load) so uninstalled it. No success, still reboots when it's convenient for it to do so :rofl:

Thanks for the camaraderie!

Hopefully someone has some pointers for us to troubleshoot!

After trying just about everything, including attempting (and failing) to get a serial console up on one of my Asus routers, I bought a TP-Link C7 Archer 1750, dropped an identical configuration on to it and it's completely stable (the Asus routers are STILL rebooting a couple of times a day).

Posting this response in case anyone is considering using the Asus routers for OpenWRT - They are not stable.

1 Like

I have 4 of these as AP's and have found that the instability was introduced at the 21 release. I am using 19.07.8 on 3 of these with no reboots.

My configuration is pretty similar to yours with VLANs and multiple SSID's.

Hopefully 21 will be fixed at some point but at the moment I am sticking with 19 as it has worked well for me for years.

1 Like

Robert, where were you 20 days ago?!

:slight_smile:

Thanks for commenting, hopefully it will help someone else as I've already switched routers...

Moved back to v19, no more reboots!.

Thanks for the steer @rdarling.

1 Like

I have RT-AC51U but was not willing to do the upgrade to OpenWRT yet due to the fact it is the main router in the house. (It runs older and patched Padavan FW). However I have several Xiaomi Mi Routers (4A Gigabit, 4A 100Mbit, 4C) and was using OpenWRT in version 19.07 quite stable but have perhaps similar issues after upgrading to 21.02 and reconfiguring them. I have a suspicion whether it may not be related to migration from swconfig to DSA which appears to me as the major change between these versions. I have no proof for that from logs or anything, unfortunately. Would it be possible to somehow configure 21.02 to use the obsolete swconfig instead of DSA to try to bisect the things that apparently changed between these versions? If someone would make a full diff between the 19.07 and 21.02 release for this particular device to check for major changes it may elucidate things, especially if someone would be willing to try various versions with batches of patches added to 21.02 disabled until the reason for the instability is empirically discovered. A tedious work, anyway :frowning:

No, DSA vs swconfig is decided at build time on the source level, involving quite significant changes in multiple places. There is no simple config option for that (neither runtime, nor at build time).

I have now had the latest release - 21.02.2 - running on one of my AC51U's for almost 5 days. So far there has been no problems with reboots and nothing of concern in the logs. It is early days but this does seem quite promising.

I can also confirm the DSA has not been implemented yet for this device so it still has the switch menu.

I also upgraded a different AC51U to 19.07.9 and it seem to be running fine as well.

OK, 18 days without a reboot so I am going to call this solved. Hopefully it works for you as well @SeanN