Asus RT-AC51U and wireless bridge mode: issues

Hi guys!

I've bought on Amazon this router at a special price. It arrived and I've noticed that I can't use WDS option with stock Asus firmware (my main modem/router is a Technicolor from TIM, italian internet and phone brand), so I've decider to use OpenWrt on it and try wireless bridge mode, option that worked on a couple of other modded routers I've used thru years.

I configured it in this way:

main router:
Asus OpenWrt router: - subnet - gateway

Then I joined wifi main router network. Everything seems to be ok, but Internet is not working on ethernet and on OpenWrt wifi, too.

Is there any issue with OpenWrt on this router with repeater option, or am I doing anything wrong?

Thanks in advance for the reply!

If that connection is on your WAN interface, you'll need to renumber your OpenWrt LAN to something other than

1 Like

later I'll try using a different IP on OpenWrt LAN and I'll let you know if it works.


1 Like

Just be aware that "WDS" is not standardized, different vendors implement this functionality differently and there is no interoperability between them. The linux kernel's WDS implementation (via mac80211, common to all mac80211 mainline drivers, but not proprietary ones!) is called 4addr, which won't be compatible to the OEM WLAN of your ISP router.

This reduces your options to a "routed client" setup or relayd, both not really ideal setups in a home environment (especially relayd is problematic and buggy by concept, while "routed client" is working better, just more complex and inconvenient).

1 Like

Unfortunately I can't use a wired solution. Or a Powerline solution, too.

I have the main modem/router on the second floor of my house and the secondary one is on the first floor. So I need to connect them via wireless.

Is there any solution you can suggest me to connect them in a more.stable way?

Changing the subnet of the secondary OpenWrt router worked! Thanks!

I'm trying the connection in the same room as the main router and it works. I have to try it using the secondary OpenWrt router on the first floor of my house. I hope signal will be strong enough to pass thru walls!

1 Like