Asus ROG GT-AC5300

Hey folks!
I was given the above router years ago and it has served me well.
I've installed openwrt on several of the Gl.inet wifi routers, so i'm not a complete noob..

I learned last week that there was a build for the gt-ac5300 so of course i went for it.

what happened to the wifi?

All is up and seems to be great. the install went without a hitch.. but, there aren't any provisions to configure my wifi..

i'd hate to have to revert back to the asus firmware..

thanks!

The hardware data page for the device shows that it uses the Broadcom BCM4366E chip for WiFi...

Broadcom chipsets have very limited support in OpenWrt.

The fact that the WLAN driver is "unknown" is not a good sign.

You might look through the forum search results for the GT-AC5300 -

https://forum.openwrt.org/search?q=GT-AC5300

i wish i knew that before i uploaded openwrt.. now i don't have any wifi.. i don't know why they'd upload the firmware for this thing if the wifi isn't working

You're lucky this device has official snapshots. I don't know how it will work.

lucky? unless i can figure out a way to get the old firmware installed, my router is ruined.

i wouldn't have done it had i known this was going to happen.. i'm sure i'm not the only person who's lost a router because they flashed it with an image labeled as 'stable' only to find out part of it doesn't work.

this really puts me in a pickle..

It's quite commonly the case that OpenWrt doesn't support all hardware features of a given hardware, particularly common with Broadcom hardware. What should be warning signs:

  • relatively new SOC support
  • no device page detailing the device and its current state of support
  • the (git-) commit adding support for it not explicitly listing what is- or is not supported at this point

Kind of suggests that the OEM firmware should be flashable in a simple fashion.

That's why I said I don't know if it works.

while i've installed openwrt on several other routers/wifi ap's and configured some rules and whatnot, i'm still new to it. and when it says 'here's the link to the stable version of openwrt for your particular hardware', and next to it is a link for daily snapshots.. the stable link tells me that it'll work.. maybe it doesn't have the latest drivers and there are a few issues to work out, but it'll work. some of the devices on the list, despite being stable builds, still at least give a forewarning that a feature, such as usb recognition or the leds don't work.. but one would think the radios of a wifi router would work at least somewhat ok if it's being labeled as 'stable'..

so i'm stuck at the moment.. because even the asus firmware recovery utility doesn't seem to work.

Mainly: there is no support for the BCM4908 SoC integrated PCIe controller.

The work has started, see
[PATCH] PCI: brcmstb: implement BCM4908 support
https://patchwork.kernel.org/project/linux-pci/patch/20210816125029.16879-1-zajec5@gmail.com/
but it requires cleaning up.

If you could help & get that patch fixed & upstream, that would be greately appreciated.

2 Likes

You can use rescue mode.

Download the latest firmware from asus

The follow instructions.

https://www.asus.com/me-en/support/FAQ/1000814/

OpenWrt was succesfully tested on the GT-AC5300 model. It's possible to:

  1. Install OpenWrt using vendor UI
  2. Perform UBI aware sysupgrade
  3. Install vendor firmware using OpenWrt sysupgrade

Did you try to flash the Asus Firmware through The openwrt web interface ?

1 Like

FYI - I have now updated the dataentry:

grafik

i tried but it didn't work. i'll try again, i'm not sure if i tried it via the UBI, i don't recall.

i think i saw #3 on the list, however i don't believe i was able to make sense of it. i'm a complete novice when it comes to linux/bash cli..

Weird weird weird.... check this out..

today i downloaded the latest firmware from asus's website, again.. i figured 'what the hell..' and i logged in through luci, and attempted the firmware upgrade through the gui. it sat there spinning for a while. i looked at the lights and they were all illuminated (unlike with the openwrt firmware, where only 2 were illuminated).

so i tried opening the usual 192.168.1.1, but nothing.. again, i figured 'what the hell...' and i powered it off.

i powered it back on, tried again, but nothing.. so i tried 192.168.1.2, which is the address i had assigned to it in its previous life (hoping i would be brought to the default luci page) and the asus firmware came up!!

this is where it gets really weird.. i tried the admin password i had set for it, and it worked.. i went in to look around, and ALLLLLLL the settings were still there! so, despite being over written by openwrt (and openwrt claimed all the storage on the flash), it never wiped it out completely and when i was able to get the asus firmware installed, all the settings were still there!!

i re-flashed it again with the latest firmware just to make sure all was written to the flash correctly..

strange.. oh well.. i've got my asus wifi back.. that's all that matters

maybe there is a dual boot image in the router, in case the router crash for some reason it can still boot on the second Flash image. Maybe Openwrt was flashed on the 2nd flash memory so the 1st one with your settings was never overwritten.

1 Like