Asus MAP-AC2200 - Invalid Interface IP addresses

Hello OWRT gurus,

I have an Asus map-ac220, device info below, that I'd like use it to segregate my network into a management and an iot vlans.

I've been unsuccessfully trying to configure vlans using dsa.

The default network config is:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
		
config interface 'wan'
        option device 'eth0'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth0'
        option proto 'dhcpv6'

What I've done,

  1. Removed the default bridge br-lan
  2. Added 2 of 8021q devices and bridges
root@OpenWrt:/etc# cat config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'wan'
        option device 'eth0'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth0'
        option proto 'dhcpv6'

config device
        option type '8021q'
        option ifname 'eth1'
        option vid '1'
        option name 'eth1.1'
        option ipv6 '0'

config device
        option type '8021q'
        option ifname 'eth1'
        option vid '1000'
        option name 'eth1.1000'
        option ipv6 '0'

config device
        option name 'br-adm'
        option type 'bridge'
        list ports 'eth1.1'

config device
        option name 'br-iot'
        option type 'bridge'
        list ports 'eth1.1000'

Up to this point, everything went well. Until I added 2 interfaces,

config interface 'adm'
        option device 'br-adm'
        option proto 'static'
        option ipaddr '192.168.1.333'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'iot'
        option device 'br-iot'
        option proto 'static'
        option ipaddr '172.23.233.333'
        option netmask '255.255.255.0'
        option ip6assign '60'

The result of adding the interfaces is

Would you please tell me what went wrong? How can I properly configure it?
Your assistance will be appreciated.

Thanks in advance.
-JJ

P.S. it's okay if proto is set to none; but that's not what I want.

Device Info:

root@OpenWrt:/etc# uname -a
Linux OpenWrt 5.10.176 #0 SMP Thu Apr 27 20:28:15 2023 armv7l GNU/Linux
root@OpenWrt:/etc# cat os-release
NAME="OpenWrt"
VERSION="22.03.5"
ID="openwrt"
ID_LIKE="lede openwrt"
PRETTY_NAME="OpenWrt 22.03.5"
VERSION_ID="22.03.5"
HOME_URL="https://openwrt.org/"
BUG_URL="https://bugs.openwrt.org/"
SUPPORT_URL="https://forum.openwrt.org/"
BUILD_ID="r20134-5f15225c1e"
OPENWRT_BOARD="ipq40xx/generic"
OPENWRT_ARCH="arm_cortex-a7_neon-vfpv4"
OPENWRT_TAINTS=""
OPENWRT_DEVICE_MANUFACTURER="OpenWrt"
OPENWRT_DEVICE_MANUFACTURER_URL="https://openwrt.org/"
OPENWRT_DEVICE_PRODUCT="Generic"
OPENWRT_DEVICE_REVISION="v0"
OPENWRT_RELEASE="OpenWrt 22.03.5 r20134-5f15225c1e"
root@OpenWrt:/etc# cat board.json
{
        "model": {
                "id": "asus,map-ac2200",
                "name": "ASUS Lyra MAP-AC2200"
        },
        "network": {
                "lan": {
                        "device": "eth1",
                        "protocol": "static"
                },
                "wan": {
                        "device": "eth0",
                        "protocol": "dhcp"
                }
        }
}

When using custom VLANs on the map-ac2200 (ipq40xx), please upgrade to 23.05~ and DSA first. The ipq40xx swconfig based switch drivers used before are rather 'special' when it comes to this and the newer DSA based drivers fix quite a few bugs and weird quirks in this regard (on top of that, you get the more common DSA configuration syntax as well).

2 Likes

Do you REALLY have the above? Octets cannot exceed 255, yet you have 333.

1 Like

@slh Thanks. I'll upgrade and report back.
@bib1963 You're right. I'll change it after upgrade. Thanks.

1 Like

I upgraded it to 22.05 and was able to configure it the way I'd like. I'm running Unbound + AGH - no wifi, no dnsmasq, and no problem thus far.

It may not apply to this device; but in swconfig, pvid is used to set port id. How can port ids be set in DSA?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.