ASUS DSL-AC51 PPPoE connection issues

Hi,
I am trying to switch my ASUS DSL modem/router (with the original firmware) to the modem-only/bridge mode and connect it to my OpenWrt router (Linksys EA8300, 22.03.2 r19803-9a599fee93) via PPPoE.

First, I followed these instructions on how to switch the ASUS router to the bridge mode: https://superuser.com/questions/1757989/asus-dsl-modem-routers-how-do-you-turn-on-bridge-mode-avoid-double-nat. The original functioning PPPoE settings looked like this:

Then I updated the wan interface to PPPoE:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdd9:4305:a50b::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'eth1'
	option proto 'pppoe'
	option username 'CETIN'
	option password 'CETIN'
	option ipv6 '0'
	option macaddr 'xx:xx:xx:xx:xx:xx'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0'

So far I have not been able to make the connection work. In the ppp log I can see attempts for a connection with timeouts:

Thu Feb  2 18:14:20 2023 daemon.info pppd[19520]: Plugin pppoe.so loaded.
Thu Feb  2 18:14:20 2023 daemon.info pppd[19520]: PPPoE plugin from pppd 2.4.9
Thu Feb  2 18:14:20 2023 daemon.notice pppd[19520]: pppd 2.4.9 started by root, uid 0
Thu Feb  2 18:14:35 2023 daemon.warn pppd[19520]: Timeout waiting for PADO packets
Thu Feb  2 18:14:35 2023 daemon.err pppd[19520]: Unable to complete PPPoE Discovery
Thu Feb  2 18:14:35 2023 daemon.info pppd[19520]: Exit.

What I have tried without success:

  • Restarting both modem and router several times.
  • Adding mac adres of the modem to the wan interface setting.
  • Setting wan interface with the specified VLAN; eth1.848.

I am out of options, I feel like I have tried everything (I am a novice at networking stuff). Any advice would be appreciated.

The big question would be if your modem (still-) does the VLAN tagging for you, or if you have to do that on your OpenWrt router now - both is possible (personally I'd prefer doing it on the OpenWrt router, but there is little functional difference).

Timeout waiting for PADO packets would be quite typical for VLAN mismatches.

1 Like

ASUS recommends removing VLAN tag from WAN in the IPTV settings, so that is what I did:

The alternative would be to turn this option off and let OpenWrt handle the VLAN tagging? How could I set this up on the OpenWrt side?

I have tried to disable the "Remove VLAN TAG from WAN" option but it didn't change anything.

This is what my VLAN tries looked like:

config interface 'wan'
	option proto 'pppoe'
	option ipv6 '0'
	option macaddr 'xx:xx:xx:xx:xx:xx'
	option username 'CETIN'
	option password 'CETIN'
	option keepalive '10 6'
	option device 'eth1.848'

For the sake of completeness, this is a snippet from the modem's log:

...
2011-01-01 00:30:15 kernel: tcphy[0]: Link-down!!!
2011-01-01 00:30:15 kernel: Link State: LAN_1 down.
2011-01-01 00:30:17 kernel: tcphy[0]: Link-up at 100F. tx_amp_save=0.
2011-01-01 00:30:17 kernel: tcphy[8]: boosten=1 agccode=5 zfgain=4 ch_idx=19 snr=2 
2011-01-01 00:30:17 kernel: Link State: LAN_1 up.
2011-01-01 00:30:18 kernel: br1: received packet on elan.1 with own address as source address
2011-01-01 00:30:23 kernel: br1: received packet on elan.1 with own address as source address
2011-01-01 00:30:28 kernel: br1: received packet on elan.1 with own address as source address
2011-01-01 00:30:33 kernel: tcphy[0]: Link-down!!!
2011-01-01 00:30:33 kernel: Link State: LAN_1 down.
2011-01-01 00:30:35 kernel: tcphy[0]: Link-up at 100F. tx_amp_save=0.
2011-01-01 00:30:35 kernel: tcphy[8]: boosten=1 agccode=5 zfgain=4 ch_idx=19 snr=2 
2011-01-01 00:30:35 kernel: br1: received packet on elan.1 with own address as source address
2011-01-01 00:30:36 kernel: Link State: LAN_1 up.
2011-01-01 00:30:40 kernel: br1: received packet on elan.1 with own address as source address
...