[ASU] Stuck on sysupgrade

I decided to upgrade my TP-Link C6 v3 to the latest version. I used Attended Sysupgrade package to do it because it worked great last time, but unfortunately it got stuck on the Installing the sysupgrade. Do not unpower device! message. The WiFi signal was gone but never came back. Any way to recover from this? I haven't touch the router since.

Tried plugging in an Ethernet cable to a LAN port?

1 Like

I did that and was able to reach the LuCI, but the wireless SSID's are disabled (Wireless is not associated ) and I can't get them back. Also, I can't reach the Internet except for this forum :thinking:

Which version was on it before?

then go for the LuCi menu „System“ -> „Backup“,
in that menu do 2 things: make a backup of your config, then use the „reset to defaults“.
But don‘t try to restore that backup file later on, rather use it as a hint archive of your custom config.

1 Like

Did you enable them?

Interesting...that's odd. Did you save your settings or reset?

As Pico asked, what was the beginning version and the version you sysupgraded to?

(The first Idea I had when you said this - is it seems you may not have DNS resolution. You have the Forum's IP cached on your client because you were activity on the page before beginning the sysupgrade.)

Sorry for my late response. I finally upgraded to version 23.05.0 (from 22.03.05) with no errors or issues. The answer was in this thread. I had to remove the wolfssl packages and add the mbedtls ones to the build in ASU. Sorry thant my dumbness wasted your time :frowning:

1 Like

interesting and unexpected outcome :slight_smile: .
Maybe this needs an extra comment in the release notes, as other ASU users might run into this issue as well.


I forgot to give more context in the OP. First of all, the error that ASU gave me was:

Collected errors:
 * check_data_file_clashes: Package libustream-mbedtls20201210 wants to install file /builder/build_dir/target-mips_24kc_musl/root-ath79/lib/libustream-ssl.so
	But that file is already provided by package  * libustream-wolfssl20201210
 * opkg_install_cmd: Cannot install package luci-ssl.
make[2]: *** [Makefile:189: package_install] Error 255
make[1]: *** [Makefile:154: _call_manifest] Error 2
make: *** [Makefile:274: manifest] Error 2

First, I incorrectly took out the libustream-wolfssl package in ASU and, although the image was build and flashed, I got the Wi-Fi problem I mentioned. Then, I removed all the wolf related packages with the same result as before. Finally, I did what the solution post said.

Thanks everyone for your time :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.