Asking for Help: OpenWRT on TP-Link Archer C60 connecting to TM Unifi

Hello. Malaysian here.

About awhile back, I purchased a TP-Link AC1350 (Archer C60) as a replacement router in case the currently working router got fried in a power surge.

Then, I tried to use it, and to my surprise, the firmware was not compatible with the TMNet Unifi fibre-optic connection protocols. Despite what the box says, the hardware I actually got was instead for the US market. And I couldn't flash the firmware to the Malaysia compatible ones, as the hardware itself was different.

I gave up, and had to purchase a different one.

But I kept the C60 around.

Recently, I came across OpenWRT, and to my delight, there's a version for the C60, and there are site tutorials for configuring it to connect to Unifi. So, I flashed the firmware in, followed the instructions, and...

The internet connection didn't work.

I tried two different methods, but the screenshot of the OpenWRT looked different from the one I have.

Site 1
Site 2

Can anyone help me with this issue? The goal is to have the C60 able to access the internet directly through the fibre optic modem.

Here are screenshots of my configuration:

Despite the hardware having a WAN port and 4 LAN ports, I don't see an option of the WAN on the GUI.

Can anyone help?

Note: I'm a newbie at this. Very Green.

Hi, I have just done that with an old tp-link mr3420, this is what I did:

  1. my WAN port is on eth0, it is not part of the "switch", I just create an interface called "eth0.500", select pppoe, enter your login details, and make this interface as "wan" under the firewall settings.

  2. create a virtual lan for "local internet", use vlan 1, cpu port need to be tagged, and select one or more ports that you want as untagged (leave one for iptv, and set it to off).

  3. go to "Interfaces", make sure in the interface "Lan" -> "Physical Settings", "eth1.1" is selected, eth1.1 is the virtual lan that you just created on step 2 above, this interface should have the wireless network included as well.

  4. create vlan for iptv, name it vlan 2, cpu port tagged, all other port set to off, except the iptv port that you have selected in step 2, set it to untagged.

  5. go to "Interfaces", create another interface for iptv, selected unmanaged protocol, use "eth0.600", and bride this with vlan 2 (eth1.2)

in my case, I think the map look something like:

eth0.500 (wan) <-> firewall <-> eth1.1 + wireless (lan)

eth0.600 (iptv) bridge with vlan eth1.2

I don't know much about openwrt, just configured my old router as backup and for fun, hope this give you some idea how to proceed, it seems different router has different configuration, and it may also possible to do the same with different settings, I think in the case of TP-LINK MR3420, the wan port is not part of the switch, but I can get the internet to login and works just by creating a interface for eth0.500 and with the correct login details, all the other steps are just to create the vlan for local ethernet and iptv.


Just to point out the obvious, on my router, the wan port is on eth0, and the switch is on eth1, which is different from yours, also the LEDE ui on my router show port 4 as the cpu port, but it seems like the port 0 is actually the cpu port, generally you should have your cpu port tagged (so that you can use eth0.1, eth0.2 in the Interfaces), and the port that connect to tv box and computer etc to be untagged.


I am playing around with the vlan and just want to let you know that if you do not want to use the router's wan port (or if the wan port if not part of the switch), it is also possible to use one of the "lan" port as wan port, see the attached photo.

you can route the 600 vlan directly to the iptv lan port, without even route it to the "cpu", you route traffic/packet to "cpu" if you wan to further process it, for example the 500 vlan, you route it to cpu, then you connect your Interface wan to eth1.500 or eth0.500 (depends on your router), and you connect your interface lan to eth0.1 or eth1.1, and if the zone is setup correctly, eth0.1 in lan, eth0.500 in wan, and the default settings of the firewall should route the traffic correctly from lan to wan.